UPDATE PACK 5 FEEDBACK THREAD

Archived topics about LMDE 1
Locked
maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 7:00 am

I have upgraded all packages but upgrading the nvidia propdriver continues to be a total mess. I have followed the advice to remove all *nvidia* packages first and then install nvidia-glx, but to no avail. Also some problems with XFCE, X and conky, are related to the nvidia upgrades. I had to restore my system once again.

These are the packages I need to upgrade (v 295.40.1):

libgl1-nvidia-alternatives
libgl1-nvidia-glx
libglx-nvidia-alternatives
libxnvctrl0
nvidia-alternative
nvidia-detect
nvidia-glx
nvidia-installer-cleanup
nvidia-kernel-common
nvidia-kernel-dkms
nvidia-settings
nvidia-support
nvidia-vdpau-driver
nvidia-xconfig
xserver-xorg-video-nvidia

I run NON-realtime kernel linux-image-3.2.0-3-686-pae, and realtime linux-image-3.4.0-10.dmz.1-liquorix-686

nvidia-glx wants to pull in REALTIME kernel linux-image-3.2.0-3-rt-686-pae with binary module nvidia-kernel-3.2.0-3-rt-686-pae as dependancies. It also removes nvdia-dkms. So after the upgrade I am left with only the binary realtime nvidia module, and only able to boot from the realtime kernel.

After booting the realtime kernel with binary module, X eats 50% CPU, making the computer slow like molasses, and the XFCE panel will not load. When I start Gnome3 the the positioning of conky is off (in XFCE conky is OK).

When I uninstall the rt kernel and module, and install the NON-realtime nvidia-kernel-3.2.0-3-686-pae binary module, and boot from the non-rt kernel, X eats 30% CPU and the XFCE panel loads only after a minute or so. Gnome3 has the same problem with conky.

When I remove the binary module and install nvidia-dkms, it builds the modules for both the old non-rt kernel and the liquorix kernel. But with the non-rt kernel, X eats 30% CPU again, and with liquorix realtime, X eats 50%, and the problems with XFCE and conky remain.
nvidia_upgrade.png

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by zerozero » Thu Sep 06, 2012 7:55 am

maxibuntu,
i faced a similar situation yesterday trying to upgrade wine from the default repo to the version provided by liquorix; in the end it failed (also it was too late and i gave up for the night, going to resume the tests in awhile);
but my point is:
- without liquorix i could upgrade from latest to incoming clean
- adding liquorix when in incoming to upgrade wine pulls in rt kernel and also the pae, so i would say that there's something wrong with the dep over at liquorix;
- do you have wine installed or is liquorix also trying to install wine and in the push all the dep?
- try the dist-upgrade with liquorix disabled and give us the output
Image

[ bliss of ignorance ]

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 8:41 am

zerozero,

I had wine1.3/1.4 installed from 'http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ precise', and liquorix from 'http://liquorix.net/debian/ sid'.

Just a minute ago I disabled these repos an deinstalled all packages from those repos and rebooted.

But nvidia-glx still wants to pull in the rt-pae kernel.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by zerozero » Thu Sep 06, 2012 8:44 am

ahh ok then forget if you use ubuntu ppa's you should know what to do.
Image

[ bliss of ignorance ]

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 8:56 am

zerozero wrote:ahh ok then forget if you use ubuntu ppa's you should know what to do.
That's the only ubuntu ppa I use. But disabling the ubuntu wine ppa and enabling liquorix does not try to pull in wine when i try to install liquorix.

Disabling all sources except the mint incoming repos makes no difference, nvidia still wants to pull in the rt-pae kernel...

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by zerozero » Thu Sep 06, 2012 9:25 am

maxibuntu,
starting with (default wine from debian repo)

Code: Select all

zerozero@wine ~ $ apt policy wine
wine:
  Installed: 1.4.1-1
  Candidate: 1.4.1-1
  Version table:
 *** 1.4.1-1 0
        500 http://debian.linuxmint.com/incoming/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
added after that liquorix

Code: Select all

Reading package lists... Done
W: GPG error: http://liquorix.net sid InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 3EFF4F272FB2CD80
zerozero@wine ~ $ sudo apt-get install '^liquorix-([^-]+-)?keyring.?'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'liquorix-archive-keyring' for regex '^liquorix-([^-]+-)?keyring.?'
Note, selecting 'liquorix-keyring' for regex '^liquorix-([^-]+-)?keyring.?'
Note, selecting 'liquorix-keyrings' for regex '^liquorix-([^-]+-)?keyring.?'
The following packages were automatically installed and are no longer required:
  libebackend-1.2-2 libedata-book-1.2-13 libedata-cal-1.2-15
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  liquorix-archive-keyring liquorix-keyring liquorix-keyrings
0 upgraded, 3 newly installed, 0 to remove and 1 not upgraded.
Need to get 9,764 B of archives.
After this operation, 115 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  liquorix-archive-keyring liquorix-keyring liquorix-keyrings
Install these packages without verification [y/N]? y
next dist-upgrade results in

Code: Select all

The following NEW packages will be installed:
  autopoint cups-bsd docbook-xsl fonts-horai-umefont fonts-liberation fonts-unfonts-core git git-man kate-data katepart kde-runtime kde-runtime-data kdelibs-bin kdelibs5-data
  kdelibs5-plugins kdoctools krb5-locales libasprintf0c2:i386 libasyncns0:i386 libattica0 libattr1:i386 libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libcapi20-3 libcapi20-3:i386 libclucene0ldbl libcomerr2:i386 libcroco3:i386 libcuda1 libcuda1:i386 libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdbusmenu-qt2
  libdlrestrictions1 liberror-perl libexif12:i386 libflac8:i386 libfontconfig1:i386 libgcrypt11:i386 libgd2-xpm:i386 libgettextpo0 libgettextpo0:i386 libglib2.0-0:i386
  libgnutls26:i386 libgomp1:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-l10n libgphoto2-port0:i386 libgssapi-krb5-2:i386 libgstreamer-plugins-base0.10-0:i386
  libgstreamer0.10-0:i386 libieee1284-3:i386 libiodbc2 libjbig0:i386 libjson0:i386 libk5crypto3:i386 libkatepartinterfaces4 libkcmutils4 libkde3support4 libkdeclarative5
  libkdecore5 libkdesu5 libkdeui5 libkdewebkit5 libkdnssd4 libkemoticons4 libkeyutils1:i386 libkfile4 libkhtml5 libkidletime4 libkio5 libkjsapi4 libkjsembed4 libkmediaplayer4
  libknewstuff3-4 libknotifyconfig4 libkntlm4 libkparts4 libkpty4 libkrb5-3:i386 libkrb5support0:i386 libkrosscore4 libktexteditor4 liblcms1:i386 libldap-2.4-2:i386
  libltdl7:i386 libmysqlclient18 libnepomuk4 libnepomukquery4a libnepomukutils4 libnss-winbind libntrack-qt4-1 libntrack0 libnvidia-compiler libnvidia-compiler:i386
  libnvidia-ml1 libnvidia-ml1:i386 libogg0:i386 libopenal1:i386 liborc-0.4-0:i386 libp11-kit0:i386 libpam-winbind libpcre3:i386 libphonon4 libplasma3 libpolkit-qt-1-1 libqca2
  libqt4-dbus libqt4-declarative libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xml
  libqt4-xmlpatterns libqtwebkit4 libsane:i386 libsane-extras:i386 libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386 libsndfile1:i386 libsolid4 libsoprano4 libssh-4
  libstreamanalyzer0 libstreams0 libtasn1-3:i386 libthreadweaver4 libtiff4:i386 libunistring0:i386 libusb-0.1-4:i386 libutempter0 libv4l-0:i386 libv4lconvert0:i386
  libvirtodbc0 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 libxpm4:i386 libxslt1.1:i386 libxt6:i386 libxtst6:i386 linux-image-3.2.0-3-rt-686-pae:i386
  linux-image-3.2.0-3-rt-amd64 mysql-common ntrack-module-libnl-0 nvidia-kernel-3.2.0-3-rt-686-pae:i386 nvidia-kernel-common:i386 nvidia-opencl-common nvidia-smi:i386
  oxygen-icon-theme phonon phonon-backend-vlc plasma-scriptengine-javascript qdbus shared-desktop-ontologies soprano-daemon ttf-liberation ttf-mscorefonts-installer
  ttf-umefont ttf-unfonts-core virtuoso-minimal virtuoso-opensource-6.1-bin virtuoso-opensource-6.1-common winbind
The following packages have been kept back:
  wine
0 upgraded, 173 newly installed, 0 to remove and 1 not upgraded.
Need to get 227 MB of archives.
After this operation, 694 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
among other things please note this
linux-image-3.2.0-3-rt-686-pae:i386
linux-image-3.2.0-3-rt-amd64 mysql-common ntrack-module-libnl-0 nvidia-kernel-3.2.0-3-rt-686-pae:i386 nvidia-kernel-common:i386 nvidia-opencl-common nvidia-smi:i386
taken from that output and compare with this
zerozero@wine ~ $ inxi -Sr

Code: Select all

System:    Host wine Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import incoming
           deb [arch=amd64,i386] http://debian.linuxmint.com/incoming testing main contrib non-free
           deb [arch=amd64,i386] http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
           deb [arch=amd64,i386] http://debian.linuxmint.com/incoming/multimedia testing main non-free
           deb http://liquorix.net/debian sid main

hey i have a 64bit install :lol: why on earth liquorix is installing rt-686-pae?

EDIT
all that crazy (i would more, dangerous output above) is caused by the wine upgrade from the default repo to the liquorix version;
what i did in the meantime: in synaptic i removed

Code: Select all

Commit Log for Thu Sep  6 14:28:41 2012


Completely removed the following packages:
libwine-gecko-1.4
wine
wine-bin:i386
so now the policy output is

Code: Select all

zerozero@wine ~ $ apt policy wine
wine:
  Installed: (none)
  Candidate: 1.5.10-1
  Version table:
     1.5.10-1 0
        500 http://liquorix.net/debian/ sid/main amd64 Packages
     1.4.1-1 0
        500 http://debian.linuxmint.com/incoming/ testing/main amd64 Packages
and the dist-upgrade

Code: Select all

Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Image

[ bliss of ignorance ]

sobrus
Level 2
Level 2
Posts: 87
Joined: Thu Aug 30, 2012 1:36 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by sobrus » Thu Sep 06, 2012 9:32 am

ptruchon wrote:@sobrus

I had the same problem with the fglrx drivers. The problem seems to be on the ATI's end of things. See page 5 of this thread for more info: http://forums.linuxmint.com/viewtopic.p ... 80#p617784
As far as I know current 12.8 version supports both xorg 1.12 and kernel 3.5.
So it shouldn't be a problem to include this version in LMDE, especially since Debian has 12.6 (it should work as well) in repo again.

@zerozero
This is insane... 32-bit realtime kernel on 64-bit desktop system hahaha, Maybe you should make second, 32bit, root partition ? :O
Or it will be easier to buy second computer with 32bit LMDE :)
I'm still using Mepis version 1.5.12. At least ... it works :D

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 1:51 pm

zerozero,

That's weird stuff indeed, but I it is probably not related to my own experiences... I am running 686 and have the dep problem with or without liquorix, with or without wine.

But I just discovered that the rt kernel is pulled in ONLY when using synaptic or mintupdate-debian. When I use CLI the rt kernel it is not pulled in:

Code: Select all

debian@box:~$ LC_ALL=us_US sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  zenity zenity-common
The following packages will be upgraded:
  libgl1-nvidia-alternatives libgl1-nvidia-glx libglx-nvidia-alternatives libxnvctrl0 nvidia-alternative nvidia-detect nvidia-glx nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-settings nvidia-support nvidia-vdpau-driver nvidia-xconfig xserver-xorg-video-nvidia
15 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 24.8 MB of archives.
After this operation, 3595 kB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.
I did not yet go ahead with the dist-upgrade but I will try shortly...

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by zerozero » Thu Sep 06, 2012 2:00 pm

maxibuntu,
that looks a lot more reasonable :)
for these big updates i always recommend apt (sorry Clem :oops: )
in that output i would just watch for

Code: Select all

1 not fully installed or removed.
there's something fishy there.
Image

[ bliss of ignorance ]

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 3:08 pm

zerozero,

In the end the upgrade should work with mintupdate...

Code: Select all

1 not fully installed or removed.
That is probably mint-artwork-xfce. I reported that before in this thread.

Code: Select all

Setting up mint-artwork-xfce (2012.07.10.1) ...
/var/lib/dpkg/info/mint-artwork-xfce.postinst: 36: /var/lib/dpkg/info/mint-artwork-xfce.postinst: glib-compile-schemas: not found
dpkg: error processing mint-artwork-xfce (--configure):
 subprocess installed post-installation script returned error exit status 127
I just updated the stuff with CLI. It did not pull in the rt-kernel but still there are the problems with the nvidia driver: Eating CPU time, not loading XFCE, conky positioning off. I also wrote a clean config with nvidia-xconfig and that made no difference. My nvidia card is GeForce 8400 GS.

Code: Select all

debian@box:~$ LC_ALL=us_US sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  zenity zenity-common
The following packages will be upgraded:
  libgl1-nvidia-alternatives libgl1-nvidia-glx libglx-nvidia-alternatives libxnvctrl0 nvidia-alternative nvidia-detect nvidia-glx nvidia-installer-cleanup
  nvidia-kernel-common nvidia-kernel-dkms nvidia-settings nvidia-support nvidia-vdpau-driver nvidia-xconfig xserver-xorg-video-nvidia
15 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 24.8 MB of archives.
After this operation, 3595 kB disk space will be freed.
Do you want to continue [Y/n]? 
Get:1 http://debian.linuxmint.com/incoming/ testing/non-free libglx-nvidia-alternatives i386 302.17-3 [82.9 kB]
Get:2 http://debian.linuxmint.com/incoming/ testing/non-free xserver-xorg-video-nvidia i386 302.17-3 [4215 kB]
Get:3 http://debian.linuxmint.com/incoming/ testing/non-free nvidia-alternative i386 302.17-3 [83.8 kB]
Get:4 http://debian.linuxmint.com/incoming/ testing/non-free libgl1-nvidia-alternatives i386 302.17-3 [83.0 kB]
Get:5 http://debian.linuxmint.com/incoming/ testing/non-free libgl1-nvidia-glx i386 302.17-3 [8892 kB]
Get:6 http://debian.linuxmint.com/incoming/ testing/non-free nvidia-glx i386 302.17-3 [361 kB]
Get:7 http://debian.linuxmint.com/incoming/ testing/non-free nvidia-vdpau-driver i386 302.17-3 [1139 kB]
Get:8 http://debian.linuxmint.com/incoming/ testing/contrib nvidia-kernel-common i386 20120630+1 [10.1 kB]
Get:9 http://debian.linuxmint.com/incoming/ testing/non-free nvidia-kernel-dkms i386 302.17-3 [8934 kB]
Get:10 http://debian.linuxmint.com/incoming/ testing/contrib nvidia-support i386 20120630+1 [15.9 kB]
Get:11 http://debian.linuxmint.com/incoming/ testing/contrib libxnvctrl0 i386 302.17-2 [15.8 kB]
Get:12 http://debian.linuxmint.com/incoming/ testing/contrib nvidia-settings i386 302.17-2 [823 kB]
Get:13 http://debian.linuxmint.com/incoming/ testing/contrib nvidia-xconfig i386 302.17-2 [83.0 kB]
Get:14 http://debian.linuxmint.com/incoming/ testing/non-free nvidia-detect i386 302.17-3 [86.8 kB]
Get:15 http://debian.linuxmint.com/incoming/ testing/contrib nvidia-installer-cleanup i386 20120630+1 [17.7 kB]
Fetched 24.8 MB in 1min 14s (335 kB/s)
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
Preconfiguring packages ...
(Reading database ... 213759 files and directories currently installed.)
Preparing to replace libglx-nvidia-alternatives 295.40-1 (using .../libglx-nvidia-alternatives_302.17-3_i386.deb) ...
Unpacking replacement libglx-nvidia-alternatives ...
Preparing to replace xserver-xorg-video-nvidia 295.40-1 (using .../xserver-xorg-video-nvidia_302.17-3_i386.deb) ...
Unpacking replacement xserver-xorg-video-nvidia ...
Preparing to replace nvidia-alternative 295.40-1 (using .../nvidia-alternative_302.17-3_i386.deb) ...
Unpacking replacement nvidia-alternative ...
Preparing to replace libgl1-nvidia-alternatives 295.40-1 (using .../libgl1-nvidia-alternatives_302.17-3_i386.deb) ...
Unpacking replacement libgl1-nvidia-alternatives ...
Preparing to replace libgl1-nvidia-glx:i386 295.40-1 (using .../libgl1-nvidia-glx_302.17-3_i386.deb) ...
Unpacking replacement libgl1-nvidia-glx:i386 ...
Preparing to replace nvidia-glx 295.40-1 (using .../nvidia-glx_302.17-3_i386.deb) ...
Unpacking replacement nvidia-glx ...
Preparing to replace nvidia-vdpau-driver:i386 295.40-1 (using .../nvidia-vdpau-driver_302.17-3_i386.deb) ...
Unpacking replacement nvidia-vdpau-driver:i386 ...
Preparing to replace nvidia-kernel-common 20111111+3 (using .../nvidia-kernel-common_20120630+1_i386.deb) ...
Unpacking replacement nvidia-kernel-common ...
Preparing to replace nvidia-kernel-dkms 295.40-1 (using .../nvidia-kernel-dkms_302.17-3_i386.deb) ...

-------- Uninstall Beginning --------
Module:  nvidia
Version: 295.40
Kernel:  3.2.0-3-686-pae (i686)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia.ko:
 - Uninstallation
   - Deleting from: /lib/modules/3.2.0-3-686-pae/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod.....

DKMS: uninstall completed.

------------------------------
Deleting module version: 295.40
completely from the DKMS tree.
------------------------------
Done.
Unpacking replacement nvidia-kernel-dkms ...
Preparing to replace nvidia-support 20111111+3 (using .../nvidia-support_20120630+1_i386.deb) ...
Unpacking replacement nvidia-support ...
Preparing to replace libxnvctrl0 295.33-2 (using .../libxnvctrl0_302.17-2_i386.deb) ...
Unpacking replacement libxnvctrl0 ...
Preparing to replace nvidia-settings 295.33-2 (using .../nvidia-settings_302.17-2_i386.deb) ...
Unpacking replacement nvidia-settings ...
Preparing to replace nvidia-xconfig 295.33-1 (using .../nvidia-xconfig_302.17-2_i386.deb) ...
Unpacking replacement nvidia-xconfig ...
Preparing to replace nvidia-detect 295.40-1 (using .../nvidia-detect_302.17-3_i386.deb) ...
Unpacking replacement nvidia-detect ...
Preparing to replace nvidia-installer-cleanup 20111111+3 (using .../nvidia-installer-cleanup_20120630+1_i386.deb) ...
Unpacking replacement nvidia-installer-cleanup ...
Processing triggers for readahead-fedora ...
Processing triggers for man-db ...
Processing triggers for menu ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Setting up mint-artwork-xfce (2012.07.10.1) ...
/var/lib/dpkg/info/mint-artwork-xfce.postinst: 36: /var/lib/dpkg/info/mint-artwork-xfce.postinst: glib-compile-schemas: not found
dpkg: error processing mint-artwork-xfce (--configure):
 subprocess installed post-installation script returned error exit status 127
Setting up libglx-nvidia-alternatives (302.17-3) ...
Setting up libgl1-nvidia-alternatives (302.17-3) ...
Setting up nvidia-alternative (302.17-3) ...
Setting up nvidia-support (20120630+1) ...
Setting up nvidia-kernel-common (20120630+1) ...
update-initramfs: deferring update (trigger activated)
Setting up libxnvctrl0 (302.17-2) ...
Setting up nvidia-detect (302.17-3) ...
Setting up nvidia-installer-cleanup (20120630+1) ...
Setting up nvidia-vdpau-driver:i386 (302.17-3) ...
Setting up nvidia-kernel-dkms (302.17-3) ...
Loading new nvidia-302.17 DKMS files...
Building only for 3.2.0-3-686-pae
Building initial module for 3.2.0-3-686-pae
Done.

nvidia:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-3-686-pae/updates/dkms/

depmod....

DKMS: install completed.
Setting up nvidia-settings (302.17-2) ...
Setting up nvidia-xconfig (302.17-2) ...
Processing triggers for nvidia-alternative ...
Processing triggers for glx-alternative-nvidia ...
Setting up libgl1-nvidia-glx:i386 (302.17-3) ...
Setting up xserver-xorg-video-nvidia (302.17-3) ...
Setting up nvidia-glx (302.17-3) ...
No diversion 'diversion of /usr/lib/xorg/modules/extensions/libGLcore.so to /usr/lib/nvidia/libGLcore.so.xlibmesa by nvidia-glx', none removed.
No diversion 'diversion of /usr/lib/xorg/modules/extensions/libGLcore.a to /usr/lib/nvidia/libGLcore.a.xlibmesa by nvidia-glx', none removed.
No diversion 'diversion of /usr/lib/xorg/modules/extensions/libglx.a to /usr/lib/nvidia/libglx.a.xlibmesa by nvidia-glx', none removed.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-3-686-pae
Processing triggers for menu ...
Processing triggers for glx-alternative-mesa ...
Errors were encountered while processing:
 mint-artwork-xfce
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB
localepurge: Disk space freed in /usr/share/doc/kde/HTML: 0 KiB

Total disk space freed by localepurge: 0 KiB

E: Sub-process /usr/bin/dpkg returned an error code (1)
Restored my system again and I will keep it that way for now...

User avatar
LexMK
Level 1
Level 1
Posts: 46
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by LexMK » Thu Sep 06, 2012 8:01 pm

Good thing, it seems, I decided to pick Radeon for my new laptop. Had nothing but problems with Nvidia drivers: free ones were not good enough performance-wise, proprietary ones kept messing up stuff....

Had a GeForce 9500M, now I have a HD 6320. It's good enough even with free drivers, I think I'm going to keep it like this. Not want to risk with new drivers when default ones are working fine.
Asus eee 1225B AMD E450 with Radeon 6320

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 8:18 pm

LexMK wrote:Good thing, it seems, I decided to pick Radeon for my new laptop. Had nothing but problems with Nvidia drivers: free ones were not good enough performance-wise, proprietary ones kept messing up stuff....

Had a GeForce 9500M, now I have a HD 6320. It's good enough even with free drivers, I think I'm going to keep it like this. Not want to risk with new drivers when default ones are working fine.
For me the big showstopper was that the nouveau driver never had TV-out support. That was a few years ago however. Maybe it has progressed now, i'll check it out.

EDIT: Well, just found out TV-out after all those years is still not supported for my card, too bad...

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Thu Sep 06, 2012 9:26 pm

Another bug: package mintsystem places files in /usr/local/bin/

Just a thought... It occurred to me that pulling in the wrong deps might mean there's something wrong with the package system instead of the packages...

Code: Select all

debian@box:~$ dpkg -L mintsystem
/.
/etc
/etc/init.d
/etc/init.d/mintsystem
/etc/linuxmint
/etc/linuxmint/adjustments
/etc/linuxmint/adjustments/10-mintsystem-synaptic.overwrite
/etc/linuxmint/adjustments/README
/usr
/usr/share
/usr/share/doc
/usr/share/doc/mintsystem
/usr/share/doc/mintsystem/changelog.gz
/usr/share/doc/mintsystem/copyright
/usr/local
/usr/local/bin
/usr/local/bin/highlight
/usr/local/bin/search
/usr/local/bin/apt
/usr/local/bin/mint-md5sum
/usr/lib
/usr/lib/linuxmint
/usr/lib/linuxmint/mintSystem
/usr/lib/linuxmint/mintSystem/adjustments
/usr/lib/linuxmint/mintSystem/adjustments/synaptic.glade
/usr/lib/linuxmint/mintSystem/adjustments/window_main.ui
/usr/lib/linuxmint/mintSystem/mint-adjust.py
/usr/lib/linuxmint/mintSystem/templates
/usr/lib/linuxmint/mintSystem/templates/preferences
/usr/lib/linuxmint/mintSystem/templates/apt.conf
/usr/bin
/usr/bin/mint-fortune
/usr/bin/rtfm

timbo
Level 1
Level 1
Posts: 47
Joined: Sun Oct 09, 2011 5:06 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by timbo » Fri Sep 07, 2012 4:22 am

I installed the updates and so far realize 1 bug only. Cinnamon settings do not work any longer. Clicking on it does not trigger anything (neither in panel, nor when I try it via the main menu).

------

Solved: I installed python-gconf out of a hunch and it did the trick!

naughty_bit
Level 1
Level 1
Posts: 44
Joined: Fri Sep 07, 2012 6:33 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by naughty_bit » Fri Sep 07, 2012 7:17 am

Main differences from vanilla: Liquorix kernel, sgfxi nvidia way, no dkms and glx-alternatives.

Updated from cli with mdm stopped and using apt-get.

Cinnamon:

1. Print Screen no longer works, it spits out "No command 33 has been defined"
2. Lock screen shows Linux Mint default wallpaper instead of the current one.
3. No gui for Gnome Startup services available.

I'll update if there is anything else.

Thank you for all of your hard work!

User avatar
LexMK
Level 1
Level 1
Posts: 46
Joined: Fri Oct 21, 2011 8:09 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by LexMK » Fri Sep 07, 2012 1:08 pm

maxibuntu wrote:
LexMK wrote:Good thing, it seems, I decided to pick Radeon for my new laptop. Had nothing but problems with Nvidia drivers: free ones were not good enough performance-wise, proprietary ones kept messing up stuff....

Had a GeForce 9500M, now I have a HD 6320. It's good enough even with free drivers, I think I'm going to keep it like this. Not want to risk with new drivers when default ones are working fine.
For me the big showstopper was that the nouveau driver never had TV-out support. That was a few years ago however. Maybe it has progressed now, i'll check it out.

EDIT: Well, just found out TV-out after all those years is still not supported for my card, too bad...
Well, it's a driver made by guessing at random. The Nouveau team can't even try to reverse-engineer the official driver, since Nvidia would sue you if you try. It's clearly stated in their user license. The more I know about software licenses, the more I understand why Torvalds said "F**k you!" to Nvidia.
Asus eee 1225B AMD E450 with Radeon 6320

maxibuntu
Level 2
Level 2
Posts: 80
Joined: Thu Nov 24, 2011 9:56 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by maxibuntu » Fri Sep 07, 2012 2:11 pm

LexMK wrote:
maxibuntu wrote:
LexMK wrote:Good thing, it seems, I decided to pick Radeon for my new laptop. Had nothing but problems with Nvidia drivers: free ones were not good enough performance-wise, proprietary ones kept messing up stuff....

Had a GeForce 9500M, now I have a HD 6320. It's good enough even with free drivers, I think I'm going to keep it like this. Not want to risk with new drivers when default ones are working fine.
For me the big showstopper was that the nouveau driver never had TV-out support. That was a few years ago however. Maybe it has progressed now, i'll check it out.

EDIT: Well, just found out TV-out after all those years is still not supported for my card, too bad...
Well, it's a driver made by guessing at random. The Nouveau team can't even try to reverse-engineer the official driver, since Nvidia would sue you if you try. It's clearly stated in their user license. The more I know about software licenses, the more I understand why Torvalds said "F**k you!" to Nvidia.
Yeah, I know. I'ts time for an open source graphics card...

naughty_bit
Level 1
Level 1
Posts: 44
Joined: Fri Sep 07, 2012 6:33 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by naughty_bit » Sun Sep 09, 2012 4:44 am

Added:

Network manager wireless icon doesn't show up every time and the connected network is not shown in the list. However it does show as icon only that wired is established although it is not.

Hitting Alt+Ctrl+Del opens a window with following error message:
There was an error running gnome-system-monitor:

Failed to execute child process "gnome-system-monitor" (No such file or directory)

MissHannahMint
Level 1
Level 1
Posts: 6
Joined: Thu Aug 02, 2012 8:00 am

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by MissHannahMint » Sun Sep 09, 2012 12:18 pm

Hi there,

I've been running LMDE incoming very successfully since over a month now without experiencing any problem, but since yesterday, there have been two total freeze-ups (neither mouse nor keyboard would respond anymore, the only way out being to reset the computer). I wasn't doing anything special at those times (typing in libreoffice and browsing with firefox). Nothing has changed on my system with respect to the configuration before the freezes started occurring apart from an upgrade to the latest mintsystem package which I installed two days ago or so. Of course, that might be pure coincidence... All packages on my system are up-to-date.

Cheers.

Code: Select all

$ inxi -SxxxGxF
System:    Host ivybridge Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
CPU:       Quad core Intel Core i5-3570K (-MCP-) cache 6144 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 27226.2 
           Clock Speeds: (1) 1600.00 MHz (2) 1600.00 MHz (3) 1600.00 MHz (4) 1600.00 MHz
Graphics:  Card Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller X.Org 1.12.1.902 Res: 1680x1050@59.9hz 
           GLX Renderer Mesa DRI Intel Ivybridge Desktop  GLX Version 2.1 Mesa 8.0.3 Direct Rendering Yes
Audio:     Card Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Network:   Card-1 Atheros AR9285 Wireless Network Adapter (PCI-Express) driver ath9k BusID: 01:00.0
           Card-2 Atheros AR8151 v2.0 Gigabit Ethernet driver atl1c v: 1.0.1.0-NAPI at port e000 BusID: 02:00.0
Disks:     HDD Total Size: 240.1GB (3.6% used) 1: /dev/sda INTEL_SSDSC2CW24 240.1GB 
Partition: ID:/ size: 16G used: 6.8G (45%) fs: rootfs ID:/ size: 16G used: 6.8G (45%) fs: ext4 
           ID:/boot size: 510M used: 58M (12%) fs: ext4 ID:/home size: 159G used: 8.1G (6%) fs: ext4 
           ID:swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes 133 Uptime 13 min Memory 418.6/15980.8MB Runlevel 2 Client Shell inxi 1.4.23

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: UPDATE PACK 5 FEEDBACK THREAD

Post by zerozero » Sun Sep 09, 2012 1:16 pm

i don't know but the last updates to mintsystem look pretty unrelated with those symptoms

Code: Select all

mintsystem (7.8.2) maya; urgency=low

  * Don't highlight when stdout isn't a tty (called by a script or using piped commands)

 -- Clement Lefebvre <root@linuxmint.com>  Fri, 07 Sep 2012 10:05:24 +0100

mintsystem (7.8.1) maya; urgency=low

  * Switch mint-fortune to use mateconf instead of gconf
Image

[ bliss of ignorance ]

Locked

Return to “LMDE 1 Archive”