Page 4 of 16

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 8:28 am
by chemicalfan
Right, sorry this is my first update, so I'm noob here :oops:

This is the thread I'm talking about - http://forums.linuxmint.com/viewtopic.php?f=197&t=91405
Specifically:
- incoming repos:

Code: Select all
deb http://packages.linuxmint.com/ debian main upstream import incoming
deb http://debian.linuxmint.com/incoming testing main contrib non-free
deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/incoming/multimedia testing main non-free
(your thread, I believe Zerozero! :D)

Has it always said that (at least, since UP4), or has that been changed recently?

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:08 am
by uglyone
My disk run out of space.... and the upgrade continued witiut stoping. Any ideas on how to reinstall the upgrade???

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:20 am
by Schoelje
@uglyone
To state the obvious, first make sure to free enough space on your disk (8G should do it). You won't be able to successfully end the upgrade process when you don't have enough disk space.

When you're convinced you have enough room, simply:

Code: Select all

sudo apt-get -f install && sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:21 am
by uglyone
I know that... however the update continued to the finish. Without stating that it had "no space left"

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:25 am
by Schoelje
But did it end successfully?
Is your system working as expected (even after a reboot)?
If so, it seems that the upgrade finished just before running out of space.

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:27 am
by uglyone
Not everything is working: cinnamon logs me out right after login.

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:33 am
by Schoelje
Please run this an post the results:

Code: Select all

apt policy cinnamon

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:44 am
by uglyone

Code: Select all

apt policy cinnamon
cinnamon:
  Installed: 1.4.0-lmde2UP3
  Candidate: 1.4.0-lmde2UP3
  Version table:
 *** 1.4.0-lmde2UP3 0
        700 http://packages.linuxmint.com/ debian/incoming amd64 Packages
        100 /var/lib/dpkg/status
     1.4.0-lmde1 0
        700 http://packages.linuxmint.com/ debian/main amd64 Packages

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 9:53 am
by Schoelje
Looks good.
If you verified that your /etc/apt/sources.list looks exactly as stated in the first post of this thread, you could try to reinstall:

Code: Select all

apt-get install cinnamon --reinstall
In this same thread I read several issues with cinnamon, so read them carefully. There might be a hint to the solution of your problem.
e.g.: http://forums.linuxmint.com/viewtopic.p ... 74#p614674

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 10:19 am
by uglyone
I don't use "apt-get". I use aptitude. Howvever... tried that and didn't worked.
I got this message when i try to login (on gnome and cannamon): "failed to start session cinnamon"

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 10:34 am
by uglyone
Problem solved. It finnaly gave me an option to read x11 error log and i notice that it complained about graphics card and 3d acelaration. So i wen back to nvidia current (with upgrade to sp5 it installed a beta driver).
Everything is runnign fine now :) Thanks very much for your help Schoelje . :)

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 10:36 am
by Schoelje
It sounds like an issue with your 3D card drivers...
Could you post the results of this:

Code: Select all

inxi -SGxrxxx

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 10:38 am
by zerozero
aptitude is usually more aggressive in the removals and trying to solve conflicts;
check carefully the removals you got in your system.

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 11:01 am
by uglyone

Code: Select all

System:    Host uglyone Kernel 3.4.0-7.dmz.1-liquorix-amd64 x86_64 (64 bit) Distro Linux Mint Debian Edition
Graphics:  Card NVIDIA C51 [GeForce Go 6150] X.Org 1.12.1.902 Res: 1280x800@60.0hz 
           GLX Renderer GeForce Go 6150/integrated/SSE2 GLX Version 2.1.2 NVIDIA 304.32 Direct Rendering Yes
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.linuxmint.com debian main upstream import incoming
           deb http://debian.linuxmint.com/incoming testing main contrib non-free
           deb http://debian.linuxmint.com/incoming/security testing/updates main contrib non-free
           deb http://debian.linuxmint.com/incoming/multimedia testing main non-free
           deb http://ppa.launchpad.net/hotot-team/ppa/ubuntu maverick main
           deb-src http://ppa.launchpad.net/hotot-team/ppa/ubuntu maverick main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/google-talkplugin.list
           deb http://dl.google.com/linux/talkplugin/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/liquorix.list
           deb http://liquorix.net/debian sid main
When i switched to nvidia-current cinnamon worked just fine
Thanks you for your help :)

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 3:59 pm
by chemicalfan
Got it working with the apt source update with incoming after a couple of upgrades & dist-upgrades. My only issue now is with the font colours in the windows now - the title bars are black font on black background, and a lot of the text within the window body is white on a grey background. This seems like the sort of thing I should be able to change via a GUI setting, but I can't find it (doh, noob failure). I suspect it could be changed in a config file too, but I don't know where cinnamon's settings are (another noob failure :()

Edit: Oh, and the menu is screwed up a bit - duplicate entries, the "Install Linux Mint" option. Oh, and the minimize and maximize buttons are invisible in the window decoration. The joys of unstable software! :D :roll:

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Wed Aug 08, 2012 8:36 pm
by mockturtl
chemicalfan wrote:Got it working with the apt source update with incoming after a couple of upgrades & dist-upgrades. My only issue now is with the font colours in the windows now - the title bars are black font on black background, and a lot of the text within the window body is white on a grey background. This seems like the sort of thing I should be able to change via a GUI setting, but I can't find it (doh, noob failure). I suspect it could be changed in a config file too, but I don't know where cinnamon's settings are (another noob failure :()

Oh, and the minimize and maximize buttons are invisible in the window decoration. The joys of unstable software! :D :roll:
Look for the ^ icon in the bottom right, or run cinnamon-settings from a terminal. Set "Themes -> Other Settings -> GTK+ theme" to Adwaita.

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Thu Aug 09, 2012 4:19 am
by chemicalfan
mockturtl wrote:Look for the ^ icon in the bottom right, or run cinnamon-settings from a terminal. Set "Themes -> Other Settings -> GTK+ theme" to Adwaita.
Thanks mate, will give it a go when I get in from work :)

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Thu Aug 09, 2012 12:59 pm
by ptruchon
First, thanks to everybody for helping out with LMDE. At home, we run latest on our two computers, but we also have incoming running on one partition so as to get ready for potential problems before they hit our main computers. Here is one (which is not LMDE's fault, but which I need to figure out at some point):

I use the fglrx-driver (ATI) for one of the computers (or else the fan runs full speed at 50 *C). But apparently, it works with xserver-xorg-core 2:1.11.4-1 of latest but not 2:1.12 of incoming. (See http://wiki.debian.org/ATIProprietary) Later today, I will reinstall LMDE on my testing partition and try to upgrade it to UP5 while keeping back the xserver-xorg-core packages to see if I can then install the fglrx-driver packages.

Since this isn't a problem with LMDE, I suspect that this problem will make its way into latest at some point. Does anyone have advice on how to best deal with this (short of staying with UP4 that is)? If not, I'll report back later today or tomorrow.

Cheers!

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Fri Aug 10, 2012 4:21 am
by ketoth
ptruchon wrote:First, thanks to everybody for helping out with LMDE. At home, we run latest on our two computers, but we also have incoming running on one partition so as to get ready for potential problems before they hit our main computers. Here is one (which is not LMDE's fault, but which I need to figure out at some point):

I use the fglrx-driver (ATI) for one of the computers (or else the fan runs full speed at 50 *C). But apparently, it works with xserver-xorg-core 2:1.11.4-1 of latest but not 2:1.12 of incoming. (See http://wiki.debian.org/ATIProprietary) Later today, I will reinstall LMDE on my testing partition and try to upgrade it to UP5 while keeping back the xserver-xorg-core packages to see if I can then install the fglrx-driver packages.

Since this isn't a problem with LMDE, I suspect that this problem will make its way into latest at some point. Does anyone have advice on how to best deal with this (short of staying with UP4 that is)? If not, I'll report back later today or tomorrow.

Cheers!
Yes by lacking precise hardware specs, the fans tend to fullspeed with the free drivers. Actually a noisy fan helps me to find out the proprietary driver isn't taking over control :D After installing fglrx and fglrx-control, run the control center with "sudo amdcccle". If you have to run "sudo aticonfig --initial", it will tell you. A reboot later and normally everything's fine with the fan. (actually, a reboot is always necessary after fglrx install).

And oh, please double-check: an idling GPU should be at lower than 50°C. Isn't it the CPU fan who runs crazy ? (it isn't unlikely that a loop bug in the desktop environment keeps a core working for nothing)

Re: UPDATE PACK 5 FEEDBACK THREAD

Posted: Mon Aug 13, 2012 5:56 pm
by appye
REBOOT prompt. Something. It is unnerving when a major system update (especially a UP, which should REQUIRE a reboot) just blinks out like that. I run the updates, and then the whole thing blinks out and changes the mintupdate-debian icon to the standard green checkbox. Why is there no dialogue of any kind after mintupdate is finished running? This seems like a silly oversight to me.