Page 1 of 1

Broke my sound output,

Posted: Wed Oct 03, 2012 8:20 pm
by QuotidianMe2
I've had no problem with sound until today, sadly whilst showing off linux on my machine to a co-worker. I work in a hotel and, as people would come and go, I had to keep muting video files played both on firefox (youtube) and with vlc, muted variously at both locations and also at the "mixer" at the bottom panel. I did so in no particular order, just whichever way seemed convenient.

Then I couldn't get anything to make a sound. I've looked at the volume settings on all the above mentioned items, I've also checked the hardware "Mute" button on the keyboard, nope.

Anyplace else obvious (or not so obvious) I should look to turn the sound on? I'm guessing something got written by the machine and now isn't getting un-wrote, is all. But really, I'm just a driver, and not much of a mechanic.

If it helps, here's the output of

Code: Select all

inxi -Fx
System: Host zora_neale Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
CPU: Dual core Intel Core i5-2430M (-HT-MCP-) cache 3072 KB flags (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips 9577.38
Clock Speeds: (1) 800.00 MHz (2) 800.00 MHz (3) 800.00 MHz (4) 800.00 MHz
Graphics: Card-1 Intel 2nd Generation Core Processor Family Integrated Graphics Controller Card-2 NVIDIA GF108 [GeForce GT 520M] X.Org Res: 1366x768@60.0hz
GLX Renderer Mesa DRI Intel Sandybridge Mobile GLX Version 3.0 Mesa 8.0.3 Direct Rendering Yes
Audio: Card Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
Network: Card-1 Broadcom BCM43227 802.11b/g/n driver wl BusID: 03:00.0
Card-2 Broadcom NetLink BCM57785 Gigabit Ethernet PCIe driver tg3 v: 3.121 BusID: 02:00.0
Disks: HDD Total Size: 640.1GB (1.7% used) 1: /dev/sda WDC_WD6400BPVT 640.1GB
Partition: ID:/ size: 87G used: 8.1G (10%) fs: rootfs ID:/ size: 87G used: 8.1G (10%) fs: ext4
ID:swap-1 size: 12.70GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 48.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes 147 Uptime 41 min Memory 421.5/5840.0MB Runlevel 2 Client Shell inxi 1.4.23
Thanks in advance, as always.

Re: Broke my sound output,

Posted: Thu Oct 04, 2012 5:56 pm
by QuotidianMe2
I've looked around, but haven't found anything similar (was working, not now working). It did work fine with an old Linux Mint Live Julia CD I had, so I don't think it's the hardware dying suddenly.

I do wonder about the .pulse directory in /home ... could one of the items in there with names like "/3c57545fd9007fcac1f08fcd00001118-device-volumes.tdb" be the culprit? I bet it's some parameter in some file somewhere in pulse, but I know nada, and people who have solutions don't ever seem to have this problem.

Still open to the most imaginative of suggestions.


Re: Broke my sound output,

Posted: Fri Oct 12, 2012 8:55 pm
by QuotidianMe2
Lotta lookers, no takers? S'cool. I tried a couple of random re-installs of pulse audio ... but I think it was beyond that. Something was installed in order to use the wireless portal at work (NoScript said ABE was blocking it's install till I said let it go.) This sound problem began shortly after that, but I didn't even consider mentioning it until my computer couldn't run my live distro discs. Perhaps whatever it was broke Grub somehow? I dunno. Anyway, it did something because after this, I couldn't run live distros unless they were older. That's broke enough for me. I just deleted and reinstalled the OS, all's cool now (but no more wireless for me at work.)

Thanks anyway y'all! :wink:

Re: Broke my sound output,

Posted: Sun Nov 11, 2012 11:18 pm
by Zodak
This just happened to me. I was watching a video, and I noticed some audio clipping, so I decided to mess with it a bit in the mixer. I muted and then unmuted, and then had no sound--not just in flash, but systemwide, it seems.

I've done some of the simple things, namely: un/reinstalled pulseaudio, ensured that I was in the audio group, and made a new /etc/asound.conf file.

Nothing has worked yet.

Here's the output of

Code: Select all

inxi -A
Audio: Card-1 Intel N10/ICH 7 Family High Definition Audio Controller driver snd_hda_intel
Card-2 NVIDIA GF119 HDMI Audio Controller driver snd_hda_intel
Sound: Advanced Linux Sound Architecture Version 1.0.24
The card that is set as default is Card-1, which is the one that I want to use.


I fixed my issue! Hopefully it's the same as yours, QuotidianMe2.

I was doing more digging on the issue, when I came across a post on a different forum about alsamixer reporting different settings than amixer. So using terminal, I looked at the output from alsamixer, and it said everything was unmuted. Then I looked out the output for amixer, and sure enough, it said that 'master' was 'off'. So once I ran the following command, my problem was resolved.

Code: Select all

amixer sset Master toggle
Hope it works for you!

Re: Broke my sound output,

Posted: Fri Nov 30, 2012 8:57 am
by starccraft

Re: Broke my sound output,

Posted: Tue Jan 29, 2013 2:20 am
by nichochar
I had the exact same issue, and the amixer command fixed it. Thanks.