Touchpad Not Working?

Archived topics about LMDE 1
Forum rules
Finwe
Level 1
Level 1
Posts: 7
Joined: Mon Mar 11, 2013 2:22 am

Re: Touchpad Not Working?

Post by Finwe » Fri Mar 29, 2013 2:33 am

WhatUsernameIsFree? wrote:Hi,

From following the Debian Wiki I get the following:

egrep -i 'synap|alps|etps' /proc/bus/input/devices returns nothing.

Code: Select all

sudo Xorg :1 -configure

X.Org X Server 1.12.1.902 (1.12.2 RC 2)
Release Date: 2012-05-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-2-amd64 x86_64 Debian
Current Operating System: Linux ultrabook 3.6.0-6.dmz.1-liquorix-amd64 #1 ZEN SMP PREEMPT Thu Nov 8 19:51:13 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.6.0-6.dmz.1-liquorix-amd64 root=UUID=98316dea-d85b-4d34-81cc-ea888f19d84f ro quiet
Build Date: 20 May 2012  08:57:17AM
xorg-server 2:1.12.1.902-1 (Cyril Brulebois <kibi@debian.org>) 
Current version of pixman: 0.26.0
	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sat Nov 24 10:12:34 2012
List of video drivers:
	sisusb
	vmware
	s3
	mga
	voodoo
	chips
	vboxvideo
	tdfx
	apm
	neomagic
	i740
	ark
	mach64
	openchrome
	intel
	savage
	rendition
	tseng
	vesa
	sis
	nouveau
	r128
	i128
	cirrus
	ati
	siliconmotion
	radeon
	s3virge
	trident
	fbdev
(++) Using config file: "/root/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.
Server terminated with error (2). Closing log file.
Can someone explain to me what's happening? I can't see the touchpad in lsusb or lspci but it clearly works in Windows. I'm looking to get rid of my Windows partition soon, but can't until this is fixed (In case there's information regarding this touchpad I need.)

Thanks
I'm having the exact same problem. Ideas?

WhatUsernameIsFree?
Level 4
Level 4
Posts: 217
Joined: Wed Oct 19, 2011 1:32 pm

Re: Touchpad Not Working?

Post by WhatUsernameIsFree? » Sun Mar 31, 2013 9:37 am

Unfortunately my solution involves a USB mouse.

hhead
Level 3
Level 3
Posts: 122
Joined: Thu Jan 12, 2012 7:01 am

Re: Touchpad Not Working?

Post by hhead » Tue Aug 06, 2013 6:42 am

Thanks the fn-F4 move on my laptop solved it for me...

dennisharding
Level 1
Level 1
Posts: 1
Joined: Mon Jan 27, 2014 2:49 pm

Re: Touchpad Not Working?

Post by dennisharding » Mon Jan 27, 2014 3:01 pm

I had same problem when upgrading hard drive. piddeled for over a day to find I just wasn't getting the flat cable into the socket far enough.
But I did find a nice utility on the dell site to check almost all your hardware. Makes a bootable media to run most any test you can.
you can find it here. http://www.dell.com/support/drivers/us/ ... erid=GTW03# . Sometimes laptops/portables just get things knocked loose so it may be worth a try.

rcgrasso
Level 1
Level 1
Posts: 2
Joined: Sun Mar 01, 2015 4:03 pm

Re: Touchpad Not Working?

Post by rcgrasso » Sun Mar 01, 2015 4:33 pm

Hi, I'm a new user of MINT and, after installed it on my ASUS X550LD, I had the touchpad doesn't work and also makes conflict with my USB mouse. After reading various posts I thought it could be a problem with my touchpad (gestures capable) not coming from Synaptics (I think Focaltech?). Read different pages on the web and I found a solution adding this line "psmouse.proto=bare" in kernel cmd line on boot. Even if I can't use gestures, it's perfect for me waiting for the driver. Here you are the link:(http://askubuntu.com/questions/499889/n ... untu-14-04).
Bye

JeremyB
Level 18
Level 18
Posts: 8287
Joined: Fri Feb 21, 2014 8:17 am

Re: Touchpad Not Working?

Post by JeremyB » Sat Mar 07, 2015 9:10 am

rcgrasso wrote:Hi, I'm a new user of MINT and, after installed it on my ASUS X550LD, I had the touchpad doesn't work and also makes conflict with my USB mouse. After reading various posts I thought it could be a problem with my touchpad (gestures capable) not coming from Synaptics (I think Focaltech?). Read different pages on the web and I found a solution adding this line "psmouse.proto=bare" in kernel cmd line on boot. Even if I can't use gestures, it's perfect for me waiting for the driver. Here you are the link:(http://askubuntu.com/questions/499889/n ... untu-14-04).
Bye
There is a fix in the works for Focaltech touchpads, you can watch the bug report https://bugs.launchpad.net/archlinux/+s ... ug/1372609

n081
Level 1
Level 1
Posts: 1
Joined: Tue Aug 18, 2015 8:23 am

Re: Touchpad Not Working?

Post by n081 » Tue Aug 18, 2015 8:34 am

Hello, I'm using PacardBell EasyNote ENTG71BM and had the same problem on Linux Mint 17.2. I just opened BIOS and in Main tab changed touchpad settings from advanced to basic. Now it works. Hope will help to you, too. Don't forget to turn it on via keyboard then.

xseryoga
Level 1
Level 1
Posts: 1
Joined: Sat Dec 12, 2015 3:00 am

Re: Touchpad Not Working?

Post by xseryoga » Sat Dec 12, 2015 3:13 am

Hello All,

just registered to tell:
I've had the same problem with my Acer Aspire E5-573G-P1RN and Linux Mint 17.3 MATE 64bit USB boot.

The working solution for me is:
frank75riz wrote:Not sure if this will work for you, but if you hit Fn+F7 before you log in it might work, at least it did for me!
I've pressed fn+F7 once during the splash screen, then three times more during Linux Mint boot dialog.

Thanks!

Locked

Return to “LMDE 1 Archive”