Release file expired

Archived topics about LMDE 1 and LMDE 2
Locked
ormu

Release file expired

Post by ormu »

When I try to do 'apt-get update' (or update package lists in Synaptic) I get an error message:
E: Release file for http://debian.lth.se/lmde/latest/dists/ ... /InRelease is expired (invalid since 117d 10h 22min 1s). Updates for this repository will not be applied.
Everything worked earlier today but not now. Contents of sources.list here:
deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import
deb [arch=amd64,i386] http://debian.lth.se/lmde/latest testing main contrib non-free
deb [arch=amd64,i386] http://debian.lth.se/lmde/latest/security testing/updates main contrib non-free
deb [arch=amd64,i386] http://debian.lth.se/lmde/latest/multimedia testing main non-free
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib

ketoth
Level 2
Level 2
Posts: 81
Joined: Sat Dec 31, 2011 8:01 pm

Re: Release file expired

Post by ketoth »

Sources are ok. Can't reproduce this (the actual InRelease is good), maybe they got the mirror out of sync or under maintenance (that's possible, I saw they had UP4 as incoming a few days ago).

User avatar
dwainehead
Level 2
Level 2
Posts: 57
Joined: Tue Jan 10, 2012 2:03 pm

Re: Release file expired

Post by dwainehead »

Got this code from MOnsta the other day:

Code: Select all

    $ cat /etc/apt/apt.conf.d/80mintupdate-debian
    Acquire::Check-Valid-Until "false";
LMDE x64 20120409 UP5 AMD FX 4100 x4 3.6gHz Gigabyte GA-970A-UD3 16g Corsair Vengeance PC1600 Hitachi 750gig sata 3 EVGA Geforce 550Ti 1g kernel 3.2.0-3

ormu

Re: Release file expired

Post by ormu »

I tried to change to another mirror but it gives the same error:
E: Release file for http://mirror.rts-informatique.fr/linux ... /InRelease is expired (invalid since 119d 23h 16min 29s). Updates for this repository will not be applied.
sources.list here:
deb [arch=amd64,i386] http://packages.linuxmint.com/ debian main upstream import
deb [arch=amd64,i386] http://mirror.rts-informatique.fr/linux ... ian/latest testing main contrib non-free
deb [arch=amd64,i386] http://mirror.rts-informatique.fr/linux ... t/security testing/updates main contrib non-free
deb [arch=amd64,i386] http://mirror.rts-informatique.fr/linux ... multimedia testing main non-free
deb http://download.virtualbox.org/virtualbox/debian squeeze contrib

ormu

Re: Release file expired

Post by ormu »

Same problem with debian.linuxmint.com repositories...

What is this supposed to do? Disable validity check? I don't currently have that file, probably because I removed mintupdate-debian a while ago.
dwainehead wrote:Got this code from MOnsta the other day:

Code: Select all

    $ cat /etc/apt/apt.conf.d/80mintupdate-debian
    Acquire::Check-Valid-Until "false";

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Release file expired

Post by zerozero »

probably the easiest fix is to reinstall MU-debian (even if you are not going to use it) or creating the file 80mintupdate-debian with that one liner might also work (never tried it tho)
Image

[ bliss of ignorance ]

ormu

Re: Release file expired

Post by ormu »

Hm, thanks, that worked. The file name doesn't even have to be "80mintupdate-debian".

Locked

Return to “LMDE Archive”