Page 1 of 1

[solved][gui bug] Pack 4 used, but not Pack 5 ?

Posted: Mon Dec 03, 2012 6:28 am
by petrusminos
I saw today in my update manager there's a pack 5 to apply to my system...
But nothing to do with this update 5.

I usually use the terminal to update/upgrade my LMDE
- apt-get update && apt-get dist-upgrade
---> nothing new

But this window show me it's currently upd 5 and the 4 in system...
Am i really updated with my terminal commands ?
$ cat /etc/apt/sources.list
deb debian main upstream import
deb testing main contrib non-free
deb testing/updates main contrib non-free
deb testing main non-free

Re: Pack 4 used, but not Pack 5 ?

Posted: Mon Dec 03, 2012 11:47 am
by zerozero
as you can see bellow the mirror is updated
update-pack info
update-pack text
what probably is happening here (if update/dist-upgrade doesn't give you nothing new) is that mintupdate is being slow retrieving the information from the mirror.

you can always test this picking another mirror:

Code: Select all

in the terminal and choose the main server (the speed will be lower but for testing purposes it will do) then update/dist-upgrade (check if there is anything new; most probably not) now check again mintupdate: the information matches?

Re: Pack 4 used, but not Pack 5 ?

Posted: Mon Dec 03, 2012 3:00 pm
by petrusminos
You're right!
Tried the main mirror, and nothing new to update/upgrade from command line, and the mintupdate GUI too...

So, if I've understood informations from the mintupdate GUI, my system is currently using UP4, and inform me UP5 is online ?
No problem if the computer is updated, it's ok for me ;)
May be a little bug in the mintupdate GUI (if I've correctly understood ;))

Thx for your answer, mister.

Re: Pack 4 used, but not Pack 5 ?

Posted: Mon Dec 03, 2012 4:46 pm
by zerozero
your sources.list are fine;
if dist-upgrade says that there is nothing new is because you are using the latest&greatest (meaning UP5 at this time)

what we see there (in the MU gui) is a glitch: MU is not fetching the information from this file to give you the exact reading but fetches this one to give you the "tips" about the upgrade.
and both files are in the server (see the 2 last text files in the list)

(maybe a reboot :shock: will fix it)

Re: Pack 4 used, but not Pack 5 ?

Posted: Tue Dec 04, 2012 6:22 am
by petrusminos
Ok cool.
No problem for the glitch, this is some weeks I saw that...
The most important is to be sure the system is continuing updating fine ;)