Page 1 of 1


Posted: Mon Dec 10, 2012 6:18 pm
by herbie643
Hello all,
Just today I went ti run gnome-system-monitor and nothing happened. I went to a terminal session and received a Segmentation fault. I booted a different kernel (I run Liquorix Kernel Linux 3.6.0-9.dmz.1-liquorix-686) and have been for about 3-4days with no problems. I logged in with Gnome desktop and got same result. I tried something, run as root and gnome-system-monitor works. Kinda strange. No other problems at all. This is on LMDE 201204 Cinnamon.
Hopefully someone can come up with a solution. For now in my .gnome2/nemo-scripts/Gnome System Monitor i inserted gksu so I can at least get it to run.

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 6:28 pm
by Orbmiser
(I run Liquorix Kernel Linux 3.6.0-9.dmz.1-liquorix-686

Isn't that running Bleeding Edge? As packages older and not keeping up?
Sorry no help as trying to educate myself coming back to linux after a long 4 years hiatus.

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 6:37 pm
by cwwgateway
That's odd. It could have something to do with the kernel - liquorix is (as Orbmiser said) bleeding edge, so my guess is it could cause problems, especially since it's meant to run on wheezy/sid, and LMDE has older application versions than wheezy (and therefore sid). I don't know if the problems it would cause would affect gnome-system-monitor, though. Is anything else broken? Is it broken when you boot using the 3.2.x kernel (you can choose in the grub boot menu)?

My only other suggestion is to try an app like lxtask or other system monitor (xfce4-system-monitor, etc).

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 7:52 pm
by herbie643
Everything is running fine, no problems, just the gnome-system-monitor issue. So I installed Kernel Linux 3.2.0-3-686-pae kernel to test. Well, same result, segmentation fault.
I am at a loss as to what the problem is. I have re-installed gnome-system-monitor and gnome-terminal. Same issue.

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 7:57 pm
by zerozero
what is exactly the terminal output when you run it?

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 8:06 pm
by herbie643
(gnome-system-monitor:3267): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:51:1: Expected semicolon

** (gnome-system-monitor:3267): WARNING **: SELinux was found but is not enabled.

The SELinux message shows up a lot. Don't why, but has never caused a problem. I get the same message when I run it in the Root Terminal and the monitor shows up.

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 8:15 pm
by zerozero
this only happen with g-s-m or can you replicate with other gtk3 app?

also what theme(s) are you using (re: gtk2/gtk3?)
herbie643 wrote:This is on LMDE 201204 Cinnamon.
apart from the kernel can we assume that gtk3.x is default?

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 8:28 pm
by herbie643
This is the only app having a problem. I use Cinnamon and the theme is GTK3 and I have been running this particular theme for weeks or derivations thereof since I edit the theme and change the colors to my liking. Like I said, it just started today. I had been using Liquorix kernels for a long time and never had an issue. As you can see I downgraded the kernel and still have same problem. What I find particularly strange is that the if I run g-s-m from a root terminal it works. It is only a user terminal that has the problem or if in a 'zenity script' I precede the command with gksu it works. It appears to be a privilege thing?
The permissions are:

-rwxr-xr-x 1 root root 292624 Apr 18 2012 gnome-terminal

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 9:07 pm
by zerozero
herbie643 wrote: Like I said, it just started today.

so we have to track the changes (even the eventually seen as negligible) that you made in the system since the last time it worked (app installed/removed; theme(s) changes; everything)

Re: gnome-system-monitor

Posted: Mon Dec 10, 2012 9:39 pm
by herbie643
I always create a backup user, so to speak, so I logged on as that user and lo and behold g-s-m works perfectly. So it is definitely user oriented. Now, to track the issue down further. Ought to be lots of fun...

Re: gnome-system-monitor [Solved]

Posted: Tue Dec 11, 2012 3:37 pm
by herbie643
SOLVED - It was in the .gconf folder. No idea what the issue was, just renamed it to .ggconf, logged out and in and g-s-m worked. Just had to set all my settings again. Took about 3mins so no biggie.