Page 1 of 1

Disable Screen Blanking Applications

Posted: Mon Dec 31, 2012 12:01 pm
by WhatUsernameIsFree?
Hi all,

I have a computer that I use to play steaming media. Currently it's using MATE, previously using Cinnamon, under LMDE.

Unfortunately it blanks the screen after about 10 minutes of not being used. I've tried the screen saver settings which are set to two hours (which is as long as I can set it to not blank the screen.)

Can anyone tell me how to completely disable the screen blanking?

Thanks

Re: Disable Screen Blanking Applications

Posted: Mon Dec 31, 2012 2:41 pm
by xenopeek
Steaming media? :lol: Anyway, when you are in the Screensaver Preferences, have you also looked behind the Power Management button at the bottom? There is the setting that controls when the display goes to sleep.

Re: Disable Screen Blanking Applications

Posted: Mon Dec 31, 2012 4:09 pm
by WhatUsernameIsFree?
Hi,

Streaming media. such as when watching YouTube, iPlayer or the likes :?: Not sure what you call it.

Anyway, screensaver is set to two hours and the power settings are both set to 'Never'. This computer persists with blanking the screen every 10 minutes. I've tried removing

Code: Select all

 sudo apt-get remove acpi-support acpid
and

Code: Select all

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Alas, there was no such luck with either of those commands.

Re: Disable Screen Blanking Applications

Posted: Mon Dec 31, 2012 5:11 pm
by WhatUsernameIsFree?
Ok, so it looks like a program called 'caffeine' would work, unfortunately I can't get it to work.

Stupidly I tried to install the .deb, not sure how to uninstall it and building it from source didn't work.

Re: Disable Screen Blanking Applications

Posted: Tue Jan 01, 2013 2:30 pm
by WhatUsernameIsFree?
So far, I've got the screen to stay awake unless I'm playing a video. With the screen on the desktop, idle for hours the screen stays awake. If I play a video, it sleeps every 10 minutes.

Please help. :(

Re: Disable Screen Blanking Applications

Posted: Tue Jan 01, 2013 3:41 pm
by jjaythomas
Don't use Mate or cinamon much...
But

If I remember in the panel you can put a plugin called 'inhibit' I remember doung that to watch hulu 'steaming :mrgreen: media' the inhibit icon disables screensavers, hibernate ect.
I watch a full lenght movie (2-2 1/2 hours. Power saving was default times.

If I remember correctly
J.Jay

Re: Disable Screen Blanking Applications

Posted: Tue Jan 01, 2013 4:00 pm
by WhatUsernameIsFree?
I feel like I've missed a joke or calling it something stupid :oops:

Anyway, I noticed it's only occurring in VLC, so I've switched to XBMC. Now to find a handy XBMC remote control application.

Re: Disable Screen Blanking Applications

Posted: Thu Jan 03, 2013 10:37 am
by deep64blue
WhatUsernameIsFree? wrote:I feel like I've missed a joke or calling it something stupid :oops:

Anyway, I noticed it's only occurring in VLC, so I've switched to XBMC. Now to find a handy XBMC remote control application.

I don't get the joke either - streaming media is exactly what it is!

EDIT: Except you called it "steaming" without the crucial r lol

Re: Disable Screen Blanking Applications

Posted: Fri Jan 04, 2013 3:23 pm
by WhatUsernameIsFree?
deep64blue wrote:EDIT: Except you called it "steaming" without the crucial r lol


:oops: Thanks, how many times did I read and re-read the thread without spotting it? :lol:

Re: Disable Screen Blanking Applications

Posted: Fri Jan 18, 2013 7:42 pm
by trebzgum
I had the same problem, I set screensaver to 2hrs under Screensaver program since the range is 1 min - 2hrs, and set sleep to never under Power Management and also used mateconf-editor but it kept getting the blank screen after 10 mins. I finally found a temporary solution that worked for me, open terminal and type:

Code: Select all

xset s noblank

you will have to do this after every reboot though since the settings don't get saved. Hope this helps.

Re: Disable Screen Blanking Applications

Posted: Sun Jan 20, 2013 10:45 pm
by jjaythomas
you will have to do this after every reboot though since the settings don't get saved. Hope this helps.


make one line script put in auto start. :wink:

I think should work
J.Jay

Re: Disable Screen Blanking Applications

Posted: Sat May 25, 2013 8:13 pm
by nickoct
I've been watching Youtube and had the same annoying problem that the screen keeps going blank after about 10 minutes inactivity. And I think I found the correct settings section. If you click on the Menu button and then on Preferences and then click on Power there should be a Tip at the bottom with a highlighted link to Brightness Settings. Once you click on that it will take you to a section with a lot of settings, one of which is "Turn screen off when inactive for" and a place to change the settings. Change it to never and that should solve the problem. Please let me know if it helps.

Re: Disable Screen Blanking Applications

Posted: Tue May 28, 2013 2:49 pm
by vayu
I imagine that there's a setting in VLC that would change it. I've had times where VLC was the only program that would disable the screensaver, so VLC does play with those settings.

Re: Disable Screen Blanking Applications

Posted: Mon Jul 01, 2013 3:01 am
by bigtreeman
Menu...
All...
Screensaver...
brings up the X screensaver preferences
untick Activate screensaver when computer is idle