LMDE Breakages (Tracking SID)

Archived topics about LMDE 1
GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by GregE » Mon May 27, 2013 8:59 pm

woodsman4 wrote:ia32-crossover doesnt install in sid because it depends on lib32asound2, which is no longer in sid and conflicts/is replaced by libasound2:i386
Hi, I have no direct experience with your problem but it is obviously due to Debian now being multi-arch. My guess would be you need to activate i386 as an alternative in your 64bit system and then install the 32bit version of Crossover. A quick scan of the Crossover forums confirms that the 64bit version is still trying to use the outdated ia32-libs package. Maybe I have made a rash assumption about your system, I am assuming 64bit but that may not be true.

So this is what I would try, remove Crossover and then run this command
sudo dpkg --add-architecture i386
then do an update
sudo apt-get update

then install the 32bit version of Crossover.

If you have a 32bit Debian and a 32bit Crossover then the problem is one of dependencies. if that is true then post back and we can look at different solutions.

I thought that running Wine would be easier once Debian went multi-arch but I have struck more than a few issues.

:)

woodsman4
Level 1
Level 1
Posts: 4
Joined: Sat Apr 06, 2013 4:23 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by woodsman4 » Wed May 29, 2013 1:50 pm

i think that might be why. i tried installing the 64-bit version of crossover.
EDIT: i tried installing 32 bit crossover and it tried to remove my desktop environment
EDIT....again: i modified the .deb so it depends on libasound2:i386 instead of lib32asound2. will post back whether it works
EDIT...the third: i modified it, installed it and i get

Code: Select all

locate_gui.sh:error:  $HOME must be set correctly and be writable for --scope private
locate_gui.sh:error:  try 'locate_gui.sh --help' for more information
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 123.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 52.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 52.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 52.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 52.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXAssocCheck.pm line 52.
locate_gui.sh:error:  $HOME must be set correctly and be writable for --scope private
locate_gui.sh:error:  try 'locate_gui.sh --help' for more information
Use of uninitialized value in string eq at /opt/cxoffice/lib/perl/CXMenuShortcut.pm line 13.
Use of uninitialized value in concatenation (.) or string at /opt/cxoffice/lib/perl/CXMenuShortcut.pm line 287.
EDIT...the IVth: i was using a siduction base, i'll see if i can't get a different result from using lmde

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by GregE » Wed May 29, 2013 10:03 pm

@woodsman4

Did you add the sudo dpkg --add-architecture i386 ? Ubuntu have been multi-arch for nearly two years so Crossover should have multi-arch figured out by now. You should not have to fiddle the dependencies, theoretically it would cause more problems that it might solve.

The wonders of Google............

http://www.codeweavers.com/support/wiki ... eezy_64bit

woodsman4
Level 1
Level 1
Posts: 4
Joined: Sat Apr 06, 2013 4:23 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by woodsman4 » Thu May 30, 2013 2:20 am

yes, i added the i386 architecture and updated my sources.
i was tracking sid, which no longer has certain 32bit compatibility (in this case lib32asound2) libraries, and codeweavers hasn't updated the packages to reflect this

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by GregE » Thu May 30, 2013 3:23 am

Two more thoughts

1 I have no idea if this will work, but give it a try. Create a symlink from lib32asound2 to libasound2:i386. On an AMD64 system running multi-arch in the root tree you will find /lib and /lib64 - so find libasound2:i386 and create a symlink to /lib/i386-linux-gnu/lib32asound2. If you look inside the Crossover deb you can probably work out where it is looking and symlink it there instead. If this does not work remember to remove the symlinks.


2 Find Crossover debs for Ubuntu Quantal. Normally no one here would suggest using Ubuntu debs on a Debian system, but in this case it might work. Or it might cause havoc, make sure you read what it wants to do before pressing Y. Quantal matches Sid reasonably well, or try Raring. You have to match gcc versions which makes it a bit tricky. Ubuntu have been way ahead because of the Wheezy freeze, but now Sid is updating daily.


Good Luck

cwwgateway
Level 5
Level 5
Posts: 839
Joined: Fri Nov 11, 2011 10:44 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by cwwgateway » Thu May 30, 2013 7:06 am

GregE wrote: 2 Find Crossover debs for Ubuntu Quantal. Normally no one here would suggest using Ubuntu debs on a Debian system, but in this case it might work. Or it might cause havoc, make sure you read what it wants to do before pressing Y. Quantal matches Sid reasonably well, or try Raring. You have to match gcc versions which makes it a bit tricky. Ubuntu have been way ahead because of the Wheezy freeze, but now Sid is updating daily.
AFAIK crossover distributes a deb file (downloadable) which *should* work on any Debian-based system. So the Debian package is the same as the Quantal package.
Dell XPS 15 l502x - Debian Testing 64-bit NetInst Xfce, SolydX 64-bit Debian Testing, SolydK 64-bit SolydXK Testing
Old Gateway Pentium 4 Desktop - Arch Linux 64-bit Xfce and SolydX 32-bit Sid

Riko
Level 3
Level 3
Posts: 129
Joined: Fri Dec 09, 2011 9:10 am
Location: Hamburg, Germany

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by Riko » Thu May 30, 2013 7:24 am

Hi,

I'm running the 64-bit deb package just fine under LMDE, but also don't (fully) track SID just upgraded a few specific packages. Did you try the generic installer available on the crossover web page? That is just a shell script which copies all binaries and libs to the defined directories and installs menus and such. At least that will bring you around the dependency problem and it might just run.

Cheers, Riko

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by wayne128 » Fri May 31, 2013 4:59 am

GeneC wrote:Hi Wayne.. :)

If there is an applet that you really need that is now missing, perhaps compile it from source..

Hi Gene,

Got it fully d-u.

Reinstall with apt-get sensors-plugin and it works now :mrgreen:
Did some check and got back volume knob on keyboard working too :mrgreen:

Code: Select all


Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libsnmp-base xfce4 xfce4-appfinder xfce4-session
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
root@debian:/home/wayne# apt-cache policy xfce4-sensors-plugin
xfce4-sensors-plugin:
  Installed: 1.2.5-2
  Candidate: 1.2.5-2
  Version table:
 *** 1.2.5-2 0

User avatar
gcp
Level 1
Level 1
Posts: 27
Joined: Sat Jul 02, 2011 6:24 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by gcp » Tue Jun 04, 2013 1:08 pm

gdm3 does not start after upgrading dconf to 0.16.0-3
BLACK SCREEN, NO CONSOLE

Install: dconf-editor:amd64 (0.16.0-3, automatic), libdconf1:amd64 (0.16.0-3, automatic), dconf-cli:amd64 (0.16.0-3, automatic)
Upgrade: dconf-service:amd64 (0.12.1-3, 0.16.0-3), dconf-gsettings-backend:amd64 (0.12.1-3, 0.16.0-3), dconf-tools:amd64 (0.12.1-3, 0.16.0-3)
Purge: libdconf0:amd64 (0.12.1-3)

I have nvidia 319.17-1 as graphics-driver.
Started Live-CD, downloaded old versions from Debian Website, downgraded with dpgk.
Now waiting for better days... :roll:
<login2 debianSID><sudo apt-get dist-upgrade><DONTTHINK><ENTER><WHOCARES><ENTER><OOHHNOO!><HAVENOBACKUP,IM-A-MAN><reinstalling,Windowslike...>

User avatar
karashata
Level 4
Level 4
Posts: 439
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada
Contact:

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by karashata » Tue Jun 04, 2013 7:04 pm

Looks like they already bumped up to 0.16.0-4, I'm going to give that a try now and hopefully everything will work out fine. If not, I'm holding onto the 0.16.0-2 packages already downloaded from a previous update so I can recover easily enough if things break.

EDIT: Everything seems to be working fine here, I checked the changelog file for the latest package version and it says as follows:

"In dconf 0.13.4 support for some deprecated profile specification syntax was removed which was still in use by gdm3. Add Breaks against unfixed versions of gdm3."

I'm not entirely sure what this means but I'm guessing that older versions of gdm3 may not work correctly with the new dconf packages.

(I'll note I'm using gdm3 version 3.6.1-2 from Experimental.)
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by GregE » Wed Jun 05, 2013 7:41 am

karashata wrote:(I'll note I'm using gdm3 version 3.6.1-2 from Experimental.)
My gdm3 has a strange issue of being "busy" on startup. I cannot just press enter on my username and put in password, I have to click on usename with the mouse circular busy pointer then type in password. It then takes several seconds before Gnome Desktop starts. This problem exists on two machines.

Does yours do a similar thing? It is so annoying I have temporarily switched to lightdm.

Edit: an update to libgdm3 on Jun 27 fixed this issue for me.
Last edited by GregE on Thu Jun 27, 2013 9:25 pm, edited 1 time in total.

User avatar
karashata
Level 4
Level 4
Posts: 439
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada
Contact:

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by karashata » Wed Jun 05, 2013 10:35 pm

I can't say I've ever had that happen, certainly not that I can remember anyway.

I should probably also note that I'm also using systemd (seems to be a requirement for GNOME 3.8 now if you want everything to work correctly, though the only issue I've noticed when not using it is that the power status indicator goes missing...), so my experience may not be typical of most people still running straight-up SID.

EDIT: I had a blurb about something *slightly* related here but decided it wasn't actually similar enough and kind of off-topic for this thread. Sorry!
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by wayne128 » Fri Jun 14, 2013 2:57 am

Fully d-u.

running kernel 3.9-1-686-pae

the d-u went very smooth. all running well.

bonus: fglrx still work after d-u automagically, :mrgreen:
resume from suspend work well.

Code: Select all

wayne@debian:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5450     
OpenGL version string: 4.2.12217 Compatibility Profile Context 8.982.13

wayne@debian:~$ fgl_glxgears
Using GLX_SGIX_pbuffer
5586 frames in 5.0 seconds = 1117.200 FPS
6833 frames in 5.0 seconds = 1366.600 FPS
wayne@debian:~$ aticonfig --odgt

Default Adapter - ATI Radeon HD 5450     
                  Sensor 0: Temperature - 53.00 C
wayne@debian:~$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +39.0°C  (high = +89.0°C, crit = +105.0°C)
Core 2:       +38.0°C  (high = +89.0°C, crit = +105.0°C)

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by wayne128 » Sun Jun 23, 2013 3:33 am

Trying to d-u.

Saw a list of gnome....

As this is xfce, I do not proceed..

wonder what is causing it

Code: Select all

Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  accountsservice alacarte apg cheese-common evolution-data-server
  evolution-data-server-common folks-common gir1.2-accountsservice-1.0
  gir1.2-caribou-1.0 gir1.2-clutter-1.0 gir1.2-clutter-gst-1.0 gir1.2-cogl-1.0
  gir1.2-coglpango-1.0 gir1.2-evince-3.0 gir1.2-folks-0.6 gir1.2-gck-1
  gir1.2-gconf-2.0 gir1.2-gcr-3 gir1.2-gdesktopenums-3.0 gir1.2-gee-1.0
  gir1.2-gkbd-3.0 gir1.2-gmenu-3.0 gir1.2-gst-plugins-base-0.10
  gir1.2-gstreamer-0.10 gir1.2-gtkclutter-1.0 gir1.2-gtksource-3.0
  gir1.2-json-1.0 gir1.2-mutter-3.0 gir1.2-networkmanager-1.0
  gir1.2-panelapplet-4.0 gir1.2-polkit-1.0 gir1.2-soup-2.4
  gir1.2-telepathyglib-0.12 gir1.2-telepathylogger-0.2 gir1.2-upowerglib-1.0
  gir1.2-xkl-1.0 gjs gkbd-capplet gnome-applets gnome-applets-data
  gnome-contacts gnome-control-center gnome-control-center-data
  gnome-desktop3-data gnome-icon-theme-symbolic gnome-media gnome-menus
  gnome-online-accounts gnome-panel gnome-panel-data gnome-power-manager
  gnome-session gnome-session-bin gnome-session-common gnome-session-fallback
  gnome-settings-daemon gnome-shell gnome-shell-common gnome-sushi
  gnome-system-monitor gstreamer0.10-pulseaudio hwdata libaccountsservice0
  libasound2-plugins libcamel-1.2-33 libcanberra-gtk-module libcanberra-gtk0
  libcaribou-common libcaribou0 libcheese-gtk21 libcheese3 libclutter-1.0-0
  libclutter-1.0-common libclutter-gst-1.0-0 libclutter-gtk-1.0-0
  libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin
  libcluttergesture-0.0.2-0 libcogl-common libcogl-pango0 libcogl9 libcpufreq0
  libebackend-1.2-2 libebook-1.2-13 libecal-1.2-11 libedata-book-1.2-13
  libedata-cal-1.2-15 libedataserver-1.2-16 libedataserverui-3.0-1 libexempi3
  libfolks-eds25 libfolks-telepathy25 libfolks25 libgcr-base-3-1 libgcr-ui-3-1
  libgdata-common libgdata13 libgee2 libgjs0b libgnome-bluetooth11
  libgnome-desktop-3-2 libgnome-media-profiles-3.0-0 libgnome-menu-3-0
  libgnomekbd-common libgnomekbd7 libgtkmm-3.0-1 libgtksourceview-3.0-0
  libgtksourceview-3.0-common libgtop2-7 libgtop2-common libgucharmap-2-90-7
  libgweather-3-0 libgweather-common libmetacity-private0a
  libmission-control-plugins0 libmozjs185-1.0 libmusicbrainz5-0 libmutter0
  libmx-1.0-2 libmx-bin libmx-common liboauth0 libpanel-applet-4-0
  libpulse-mainloop-glib0 libpulsedsp libpython-dev libpython-stdlib
  librest-extras-0.7-0 libsocialweb-client2 libsocialweb-common
  libsocialweb-service libsocialweb0 libtasn1-6 libtelepathy-glib0
  libtelepathy-logger2 libtevent0 libwacom-common libwacom2
  libwebrtc-audio-processing-0 libwnck-3-0 libwnck-3-common metacity
  metacity-common mousetweaks mutter-common nautilus nautilus-data p11-kit
  pulseaudio pulseaudio-module-x11 pulseaudio-utils rtkit
  telepathy-mission-control-5 zenity zenity-common
The following packages will be upgraded:
  at-spi2-core binutils cpp-4.6 cpp-4.7 cups cups-bsd cups-client cups-common
  cups-daemon cups-ppdc cups-server-common e2fslibs e2fsprogs evince-gtk
  fonts-opensymbol g++-4.7 gcc-4.6 gcc-4.6-base gcc-4.7 gcc-4.7-base gcr
  gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gnome-bluetooth gnome-icon-theme
  gnome-keyring gnome-user-guide gvfs gvfs-backends gvfs-common gvfs-daemons
  gvfs-libs hostname hyphen-en-us initramfs-tools libatk-bridge2.0-0
  libatspi2.0-0 libc-bin libc-dev-bin libc6 libc6-dev libc6-i686 libcomerr2
  libcommons-compress-java libcups2 libcupscgi1 libcupsimage2 libcupsmime1
  libcupsppdc1 libcurl3-gnutls libdiscid0 libevdocument3-4 libevview3-3
  libfontenc1 libfs6 libgail-3-0 libgcc-4.7-dev libgck-1-0 libgcr-3-1
  libgcr-3-common libglib2.0-0 libglib2.0-bin libglib2.0-data libgtk-3-0
  libgtk-3-bin libgtk-3-common libhyphen0 libjack-jackd2-0 libllvm3.2
  libnm-gtk0 libnspr4 libnspr4-0d libnss3 libnss3-1d libp11-kit0
  libpam-gnome-keyring libpcap0.8 libpulse0 libquvi-scripts
  libreoffice-base-core libreoffice-common libreoffice-core
  libreoffice-emailmerge libreoffice-gtk libreoffice-help-en-us
  libreoffice-java-common libreoffice-math libreoffice-style-galaxy
  libreoffice-style-tango libreoffice-writer libsmbclient libsoup-gnome2.4-1
  libsoup2.4-1 libss2 libstdc++6-4.7-dev libsystemd-login0 libvlc5 libvlccore5
  libwbclient0 libwww-perl libx11-6 libx11-data libx11-xcb1 libxau6 libxaw7
  libxcb-composite0 libxcb-dri2-0 libxcb-glx0 libxcb-randr0 libxcb-render0
  libxcb-shape0 libxcb-shm0 libxcb-xfixes0 libxcb-xv0 libxcb1 libxcomposite1
  libxfce4ui-1-0 libxfce4ui-utils libxml2 linux-headers-3.9-1-686-pae
  linux-headers-3.9-1-common linux-image-3.9-1-686-pae linux-libc-dev locales
  mscompress multiarch-support mutt network-manager-gnome plymouth
  plymouth-drm plymouth-themes-all plymouth-themes-fade-in
  plymouth-themes-glow plymouth-themes-script plymouth-themes-solar
  plymouth-themes-spinfinity plymouth-themes-spinner plymouth-x11
  printer-driver-escpr printer-driver-pxljr python python-dev python-libxml2
  python-minimal python-pycurl python-uno rsyslog samba-common
  samba-common-bin smbclient uno-libs3 ure vlc vlc-data vlc-nox
  vlc-plugin-notify vlc-plugin-pulse xfce-keyboard-shortcuts xfce4-settings
  xfce4-xkb-plugin xfwm4-themes xserver-xorg-video-nouveau
162 upgraded, 155 newly installed, 0 to remove and 0 not upgraded.
Need to get 312 MB of archives.
After this operation, 227 MB of additional disk space will be used.
Do you want to continue [Y/n]? n

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by Brian49 » Sun Jun 23, 2013 4:58 am

wayne128 - I get a similar result, although with different items listed, when I try to upgrade just cpp, gcc or any of their related packages, so I have an idea that is where the trouble lies.

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by mockturtl » Sun Jun 23, 2013 12:27 pm

Anyone know what's holding up the [url=http://packages.qa.debian.org/m/mono.html]Mono 3[/url] transition? Is it [url=http://qa.debian.org/developer.php?login=pkg-mono-group%40lists.alioth.debian.org]just[/url] some arch's?
Image

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by GregE » Mon Jun 24, 2013 7:46 pm

mockturtl wrote:Anyone know what's holding up the [url=http://packages.qa.debian.org/m/mono.html]Mono 3[/url] transition? Is it [url=http://qa.debian.org/developer.php?login=pkg-mono-group%40lists.alioth.debian.org]just[/url] some arch's?
I do not use mono myself, but if you are keen .....

https://www.meebey.net/posts/mono_3.0_p ... _packages/

autocrosser
Level 4
Level 4
Posts: 436
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by autocrosser » Tue Jun 25, 2013 9:46 am

Anyone seen this one?

serious bugs of binutils (2.23.52.20130522-1 -> 2.23.52.20130620-1) <forwarded>
#712081 - ld ignores used libraries (especially libc) with --as-needed
Summary:
binutils(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...]
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230

User avatar
SirSelim
Level 1
Level 1
Posts: 22
Joined: Thu Nov 01, 2012 5:34 pm

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by SirSelim » Tue Jun 25, 2013 4:43 pm

autocrosser wrote:Anyone seen this one?

serious bugs of binutils (2.23.52.20130522-1 -> 2.23.52.20130620-1) <forwarded>
#712081 - ld ignores used libraries (especially libc) with --as-needed
Summary:
binutils(1 bug)
Are you sure you want to install/upgrade the above packages? [Y/n/?/...]
Strange, I didn't receive that message. Upon checking I've had that version of binutils installed since the 21st and no issues.

Code: Select all

cat /var/log/dpkg.log | grep 'binutils'
...
2013-06-21 08:27:14 status installed binutils:amd64 2.23.52.20130620-1

User avatar
karashata
Level 4
Level 4
Posts: 439
Joined: Tue May 10, 2011 2:53 pm
Location: Stratford, Ontario, Canada
Contact:

Re: LMDE Breakages (Tracking SID) May 7, 2013

Post by karashata » Tue Jun 25, 2013 6:24 pm

I saw that error a while ago and avoided installing it the first time around, the next time I updated my packages I installed that update as well, and nothing ill seems to have come from it.
Linux Mint user since 2010, fluffy dragon forever!
Registered Linux User #473695
Image

Locked

Return to “LMDE 1 Archive”