Page 1 of 1

vokoscreen needs libc6 upgrade, how do I install vokoscreen?

Posted: Sun May 12, 2013 1:38 pm
by Drake
The current version of Libc6 used by LMDE is old, some software needs the newer versions, like I am getting unsatisfied dependencies libc6 = 2.14 needed, I think the latest stable is even 2.15, LMDE (MATE) has 2.13.

Re: Upgrade Libc6

Posted: Sun May 12, 2013 1:47 pm
by zerozero
the question is: which software is requiring a higher version of libc6 than the one lmde has? and also: do you understand the role libc6 has in the system?

Re: Upgrade Libc6

Posted: Sun May 12, 2013 1:50 pm
by xenopeek
Searching for libc6 on Debian shows 2.13-38 is the newest version available on wheezy (on which LMDE is currently based), or even jessie (to which the next LMDE UP will shift). You'll have to go to sid (unstable) to get a newer version on Debian. http://packages.debian.org/search?keywo ... ection=all

As other packages in wheezy/jessie are built against 2.13-38 I don't think Linux Mint developers will upgrade libc6 the the version from sid, or any other. The upgrade of this package will come from jessie with a future LMDE UP.

Re: Upgrade Libc6

Posted: Sun May 12, 2013 1:52 pm
by GeneC
Hi Drake

libc6 is controlled upstream by Debian, not Mint. If you definitely do need a newer version, it would have to come from Debian SID. It will not come down to LMDE with Update Packs for some time.
Upgrading to Debian SID is a whole other issue, and fraught with many risks. :arrow: http://forums.linuxmint.com/viewtopic.p ... 8&t=133211


I have LMDE tracking Debian SID

http://packages.debian.org/search?suite ... ords=libc6

Code: Select all

gene@lmdeup6:~$ apt-cache policy libc6
libc6:
  Installed: 2.17-1
  Candidate: 2.17-1
  Version table:
 *** 2.17-1 0
        100 /var/lib/dpkg/status
     2.13-38 0
        500 http://ftp.us.debian.org/debian/ testing/main amd64 Packages
==============================

OOPS: xenopeek (and 'zz') beat me to it..... :lol:

Re: Upgrade Libc6

Posted: Sun May 12, 2013 2:01 pm
by Drake
Well I wanted to use this but if I force an upgrade of libc6 I am pretty sure it will break things in my system:

http://www.kohaupt-online.de/hp/

Re: vokoscreen needs libc6 upgrade, how do I install vokoscr

Posted: Sun May 12, 2013 2:53 pm
by xenopeek
Moved your topic here and updated the subject to reflect your underlaying question to the suggestion. Hopefully others here can help you install vokoscreen.

Re: vokoscreen needs libc6 upgrade, how do I install vokoscr

Posted: Sun May 12, 2013 7:26 pm
by Drake
xenopeek wrote:Moved your topic here and updated the subject to reflect your underlaying question to the suggestion. Hopefully others here can help you install vokoscreen.
Installing it is easy if dependencies can be satisfied, the problem is that other things rely specifically on the LMDE version of libc6 installed, if I uninstall the current version, the chances are it would break some things on my system.

Re: vokoscreen needs libc6 upgrade, how do I install vokoscr

Posted: Sun May 12, 2013 8:10 pm
by zerozero
Drake,
the tricky part is that you can't uninstall libc6 2.13, what you can (although dangerous to your system is install the new version alongside the old one, or at least try)

libc6 is a fundamental lib on the system
do the follow in the terminal, it will tell all the packages, libraries and applications that depend on libc6

Code: Select all

apt rdepends libc6
(you don't need to share the list with us, just look at it)

====
now which arch of libc6 vokoscreen needs? amd64 or i386?

Re: vokoscreen needs libc6 upgrade, how do I install vokoscr

Posted: Mon May 13, 2013 5:02 am
by Drake
Hi zerozero, yes a lot depend on libc6, although they might not specifically all cease to function if a new version of libc6 was installed but yes from what I have read it would definitely break some programmes and so the risk is not worth it with this version of LMDE.

Vokoscreen is for 32bit and 64bit Linux distributions of Debian, OpenSuSE and that Ubuntu stuff :lol:

It's fairly new and is the closest thing to FRAPS for Linux, what makes this different is the gui and capability to have sound included.

Vokoscreen needs V4l-utils

Posted: Mon May 13, 2013 2:29 pm
by danbar
I'm using Mate in LMDE. I'm trying to install vokoscreen but it's telling me that I need V4l-utils.

Re: Upgrade Libc6

Posted: Tue Sep 17, 2013 8:05 am
by Packa
zerozero wrote:the question is: which software is requiring a higher version of libc6 than the one lmde has?
Hello,

Just ran across the same issue (old version of libc6).

In my case I need to run LightWorks (a long standing, professional video/film editing suite - http://www.lkws.com - Free version available.).

LightWorks was running out of the box on Ubuntu 12.04. After using LMDE in addition to Ubuntu -- and with a desire to move away from Ubuntu -- changed over for daily ops to LMDE.