Liquorix Kernel and Virtualbox (non-repo)

Archived topics about LMDE 1
Locked
timbo
Level 1
Level 1
Posts: 47
Joined: Sun Oct 09, 2011 5:06 pm

Liquorix Kernel and Virtualbox (non-repo)

Post by timbo » Sun Sep 01, 2013 9:04 am

Hey guys,

following problem: I run LMDE on the Liquorix kernels, at the moment that is 3.10-9.dmz.1-liquorix-amd64 and it seems it's not possible to use Virtualbox (neither repo nor from the website). When on standard 3.2 kernel, everything is fine, however.

What I get when trying to run Virtualbox on Liquorix kernel is the following:

Code: Select all

Failed to open a session for the virtual machine xp.
The virtual machine 'xp' has terminated unexpectedly during startup with exit code 1.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Machine
Interface: IMachine {22781af3-1c96-4126-9edf-67a020e0e858}
And I'm told to install DKMS and then run:

Code: Select all

/etc/init.d/vboxdrv setup
DKMS is installed, but I'm guessing that it doesn't work the same way with the Liquorix kernels as it does with the standard image?

Further output

Code: Select all

 timbo@x220:~$ sudo /etc/init.d/vboxdrv setup
[sudo] password for timbo: 
[ ok ] Stopping VirtualBox kernel modules:.
[ ok ] Uninstalling old VirtualBox DKMS kernel modules:.
[....] Trying to register the VirtualBox kernel modules using DKMS:Error! Bad return status for module build on kernel: 3.10-9.dmz.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/vboxhost/4.2.16/build/make.log for more information.

[FAIL] Failed, trying without DKMS ... failed!
[....] Recompiling VirtualBox kernel modules:
[FAIL] Look at /var/log/vbox-install.log to find out what went wrong ... failed!
timbo@x220:~$

Code: Select all

DKMS make.log for vboxhost-4.2.16 for kernel 3.10-9.dmz.1-liquorix-amd64 (x86_64)
Sun Sep  1 14:58:16 CEST 2013
make: Entering directory `/usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64'
  LD      /var/lib/dkms/vboxhost/4.2.16/build/built-in.o
  LD      /var/lib/dkms/vboxhost/4.2.16/build/vboxdrv/built-in.o
  CC [M]  /var/lib/dkms/vboxhost/4.2.16/build/vboxdrv/linux/SUPDrv-linux.o
scripts/genksyms/genksyms: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by scripts/genksyms/genksyms)
make[2]: *** [/var/lib/dkms/vboxhost/4.2.16/build/vboxdrv/linux/SUPDrv-linux.o] Error 1
make[1]: *** [/var/lib/dkms/vboxhost/4.2.16/build/vboxdrv] Error 2
make: *** [_module_/var/lib/dkms/vboxhost/4.2.16/build] Error 2
make: Leaving directory `/usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64'

Code: Select all

Uninstalling modules from DKMS
  removing old DKMS module vboxhost version  4.2.16

------------------------------
Deleting module version: 4.2.16
completely from the DKMS tree.
------------------------------
Done.
Attempting to install using DKMS

Creating symlink /var/lib/dkms/vboxhost/4.2.16/source ->
                 /usr/src/vboxhost-4.2.16

DKMS: add completed.

Kernel preparation unnecessary for this kernel.  Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.10-9.dmz.1-liquorix-amd64 -C /lib/modules/3.10-9.dmz.1-liquorix-amd64/build M=/var/lib/dkms/vboxhost/4.2.16/build....(bad exit status: 2)
Failed to install using DKMS, attempting to install without
make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/3.10-9.dmz.1-liquorix-amd64/build modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
	echo >&2;							\
	echo >&2 "  ERROR: Kernel configuration is invalid.";		\
	echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
	echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\
	echo >&2 ;							\
	/bin/false)
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f scripts/Makefile.build obj=/tmp/vbox.0
   gcc-4.7 -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d  -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/4.7/include -I/usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64/arch/x86/include -Iarch/x86/include/generated  -Iinclude -I/usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64/arch/x86/include/uapi -Iarch/x86/include/generated/uapi -I/usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64/include/uapi -Iinclude/generated/uapi -include /usr/src/linux-headers-3.10-9.dmz.1-liquorix-amd64/include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -fstack-protector -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -Wframe-larger-than=2048 -Wno-unused-but-set-variable -fomit-frame-pointer -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/3.10-9.dmz.1-liquorix-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS  -DMODULE  -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)"  -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/.tmp_SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
scripts/genksyms/genksyms: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by scripts/genksyms/genksyms)
make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
make[1]: *** [_module_/tmp/vbox.0] Error 2
make: *** [vboxdrv] Error 2
Any help is greatly appreciated, in the meantime I'll work on the standard kernel.

User avatar
eanfrid
Level 7
Level 7
Posts: 1859
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Liquorix Kernel and Virtualbox (non-repo)

Post by eanfrid » Sun Sep 01, 2013 11:42 am

scripts/genksyms/genksyms: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required
LMDE and Debian Wheezy are at version 2.13. So this kernel cannot be used unless you follow testing (Jessie) or Sid which have 2.17.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

timbo
Level 1
Level 1
Posts: 47
Joined: Sun Oct 09, 2011 5:06 pm

Re: Liquorix Kernel and Virtualbox (non-repo)

Post by timbo » Tue Sep 03, 2013 11:08 am

Alright, I appreciate your help. The laptop is just so much warmer on the older kernel, but it is what it is.

kioan
Level 1
Level 1
Posts: 8
Joined: Sun Nov 04, 2012 6:40 pm

Re: Liquorix Kernel and Virtualbox (non-repo)

Post by kioan » Tue Sep 17, 2013 12:51 pm

timbo wrote:The laptop is just so much warmer on the older kernel, but it is what it is.
I wish I was that lucky... My PC is [url=http://forums.linuxmint.com/viewtopic.php?f=200&t=116274&p=765315]unusable with the LMDE kernel[/url] so I ended up using the liquorix kernels.

Now I'm facing the same problems with Virtualbox :(

Locked

Return to “LMDE 1 Archive”