Caja causing eratic high CPU usage

Archived topics about LMDE 1
Locked
User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Caja causing eratic high CPU usage

Post by Fornhamfred » Wed Sep 25, 2013 2:14 pm

Since I updated LMDE to pack 7 this morning,whenever caja is running the four cores run up to 70% but alternating between the four from 15% to 70%. The cpu is AMD FX-4100

Can anyone suggest a fix please.

Monsta
Level 10
Level 10
Posts: 3027
Joined: Fri Aug 19, 2011 3:46 am

Re: Caja causing eratic high CPU usage

Post by Monsta » Wed Sep 25, 2013 2:24 pm

Looks like you'll have to turn off the thumbnails:

http://forums.linuxmint.com/viewtopic.php?f=198&p=767562#p767562
http://forums.linuxmint.com/viewtopic.php?f=143&p=767764#p767445

Monsta
Level 10
Level 10
Posts: 3027
Joined: Fri Aug 19, 2011 3:46 am

Re: Caja causing eratic high CPU usage

Post by Monsta » Wed Sep 25, 2013 11:39 pm

It turned out that the bug is quite old and is caused by glib 2.36: https://github.com/mate-desktop/mate-fi ... /issues/38
There's a workaround in the comments, but I don't know if it still works.

cjorsinger
Level 1
Level 1
Posts: 10
Joined: Mon Mar 11, 2013 6:59 pm

Re: Caja causing eratic high CPU usage

Post by cjorsinger » Thu Sep 26, 2013 5:28 am

Thanks for finding that, Monsta. The link between the directories was one of the things I tried that didn't work. I think we'll have to wait for a rebuilt caja package.

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Caja causing eratic high CPU usage

Post by Fornhamfred » Fri Sep 27, 2013 4:46 am

The link relates to Caja 1.4 and states that the problem was fixed before version 1.6 was issued. My system ran perfectly before the update pack and Caja was not updated in the pack. Having said that the problem is being caused by icon view. There must be some other change in the 1500 updates which has caused the problem.
I am running 64bit version of PclinuxOS Mate on a different machine with Caja 1.6 and have no problem with icon view.

Edit: Checking Caja I have found that the only file that causes this highly erratic usage is the home file although other places do show higher than normal cpu usage. Also if you set the view of icons to list it does not default to all places some show in list view and others in icon.

Monsta
Level 10
Level 10
Posts: 3027
Joined: Fri Aug 19, 2011 3:46 am

Re: Caja causing eratic high CPU usage

Post by Monsta » Fri Sep 27, 2013 7:27 am

Have you read all the comments there?
The problem is caused by glib 2.36 which came with UP7. Caja from the Mint repo is affected, so the package needs to be rebuilt. I've emailed this issue to Clem BTW (not sure if the forum's email function works as intended though, there was no answer yet).

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Caja causing eratic high CPU usage

Post by Fornhamfred » Fri Sep 27, 2013 2:27 pm

Thanks

You are correct I did not follow the complete thread. Have just installed the latest mate-desktop update but the erratic cpu usage is still present only to a lower degree cores maxing out to 20%.

Monsta
Level 10
Level 10
Posts: 3027
Joined: Fri Aug 19, 2011 3:46 am

Re: Caja causing eratic high CPU usage

Post by Monsta » Fri Sep 27, 2013 2:40 pm

Can you please post a comment on github about that? Or better, email directly to Clem. I suspect mate-desktop rebuilding is not enough; the package named "caja" (where Caja itself is) should probably be rebuilt too.

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Caja causing eratic high CPU usage

Post by Fornhamfred » Sat Sep 28, 2013 2:50 am

Have emailed the thread to Clem, Caja on my system is version 1.6.1-2 updated from 1.6.0-2 with new Mate-Desktop yesterday.

grizzler
Level 5
Level 5
Posts: 657
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Caja causing eratic high CPU usage

Post by grizzler » Sat Sep 28, 2013 5:04 am

The most recent version of the caja packages is 1.6.1-4.1+8.jessie, available from the MATE repository at repo.mate-desktop.org (which I had to use to get MATE installed on my system because the import section of the LMDE repository is outdated). Even with this, caja's CPU usage will occasionally go through the roof. As I have thumbnails switched off, I'm not convinced this is the root cause of the problem. I remember the same thing happening with nautilus before UP6 or 5.

User avatar
Zill
Level 3
Level 3
Posts: 168
Joined: Tue Sep 20, 2011 11:15 am
Location: Lincolnshire, UK

Re: Caja causing eratic high CPU usage

Post by Zill » Sat Sep 28, 2013 11:21 am

Fesiitis wrote:...Yes, I had other problems with MATE but after install all remaining packages problems disappeared.
I would not recommend trying to divide upgradeable packages into primary, secondary groups etc and then installing them separately. This is because each package will have its own dependencies that often require specific versions of other packages. The great advantage of the apt package management system is that it can upgrade many packages simultaneously, thereby eliminating these dependency problems by ensuring that everything is upgraded together. Trying to split these related packages up is just inviting breakage IMHO. :(

grizzler
Level 5
Level 5
Posts: 657
Joined: Wed Jun 15, 2011 5:19 pm
Location: The Hague, NL

Re: Caja causing eratic high CPU usage

Post by grizzler » Sat Sep 28, 2013 1:17 pm

Of course it's possible other packages also cause high CPU usage, but this thread is about caja doing that. There's absolutely no doubt whatsoever that it is caja on my system. The system monitor shows it and killing caja so it restarts will temporarily cure the problem. Actually, it's become such a nuisance I have now reinstalled nautilus for file browsing. Haven't had CPU usage problems since.

cjorsinger
Level 1
Level 1
Posts: 10
Joined: Mon Mar 11, 2013 6:59 pm

Re: Caja causing eratic high CPU usage

Post by cjorsinger » Sat Sep 28, 2013 4:16 pm

The update discussed here:

http://forums.linuxmint.com/viewtopic.php?f=198&t=145884

solved the Caja problem for me (thanks to the LMDE team, BTW). If Firefox and mate-system-monitor weren't running, I doubt I'd see any CPU use at all.

It looks like updating libmatedesktop did the trick. At least, that's my uninformed guess. I'm running LMDE on an old computer system (3.0 GHz Pentium 4), but it was a clean install. Maybe that explains the difference.

User avatar
xfrank
Level 5
Level 5
Posts: 609
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: Caja causing eratic high CPU usage

Post by xfrank » Sat Sep 28, 2013 6:43 pm

I just noticed the same problem: with few windows open (caja, firefox), cpu usage is around 30-40%
----------

update: caja is now behaving normally. Problem fixed.
Last edited by xfrank on Sat Sep 28, 2013 7:46 pm, edited 1 time in total.
Linux everywhere. Active Distros in my many computers: LM17.3 (Cinnamon, Xfce); LM18.1 (Cinnamon,Xfce); LMDE 2 (Mate), MXLinux (Xfce), Debian 9 (Xfce).

User avatar
Zill
Level 3
Level 3
Posts: 168
Joined: Tue Sep 20, 2011 11:15 am
Location: Lincolnshire, UK

Re: Caja causing eratic high CPU usage

Post by Zill » Sun Sep 29, 2013 5:39 am

Fesiitis: Thanks for the explanation and I am pleased that you finally got UP7 installed and LMDE working again.

I was just concerned that newbies reading this thread may have tried to upgrade subsets of packages without realising that they also had to upgrade related dependencies.

Locked

Return to “LMDE 1 Archive”