Printer stopped working after UP7

Archived topics about LMDE 1
Locked
User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

After Update printer stopped working

Post by Sleven » Sun Sep 29, 2013 3:26 pm

I updated to 7 and had a few problems.
The update crashed and I had to use

sudo dpkg --configure -a

to continue. This seems to have worked.
Today I needed to print a page and it just would not print.
This is a shared network printer (Canon Pixma 5300)
My wife can still print pages from her Windows machine,
the only thing that has changed is the update.

I used http://localhost:631/ to see what the printer is doing.
The OS sends the job okay and cupps receives it okay,
but after a while says that it is not connected.
I deleted the printer and reinstalled it and the same thing is happening.

Can anyone help please?
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

User avatar
xfrank
Level 5
Level 5
Posts: 609
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: After Update printer stopped working

Post by xfrank » Sun Sep 29, 2013 8:09 pm

Have you tried this? (I had the same problem, printer don't work after UP 7)
1 - go to printer manager
2 - select your printer, click properties
3 - go to politics
4 - check the box "activate"
Stupidly simple, but in my case, worked.
Linux everywhere. Active Distros in my many computers: LM17.3 (Cinnamon, Xfce); LM18.1 (Cinnamon,Xfce); LMDE 2 (Mate), MXLinux (Xfce), Debian 9 (Xfce).

rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: After Update printer stopped working

Post by rudar » Mon Sep 30, 2013 5:43 am

It' s a good and concrete advice, with one little correction: it's policies, not politics. I've found the same solution with my printer (although it doesn't make me too proud to say!). But what about DVD/CD player?
LMDE Mate

User avatar
xfrank
Level 5
Level 5
Posts: 609
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Re: After Update printer stopped working

Post by xfrank » Mon Sep 30, 2013 8:58 am

glad to know this issue is solved, for the DVD/CD player I don't know because I haven't one in my PC, sorry.

About "politics" is my fault because I translate from spanish "políticas". :lol:
Linux everywhere. Active Distros in my many computers: LM17.3 (Cinnamon, Xfce); LM18.1 (Cinnamon,Xfce); LMDE 2 (Mate), MXLinux (Xfce), Debian 9 (Xfce).

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: After Update printer stopped working

Post by Sleven » Mon Sep 30, 2013 9:04 am

I can not find an activate switch under policies.
There is an Enable switch which is ticked.
Just curious, when you say go to the printer manager,
how are you getting there?
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: After Update printer stopped working

Post by Sleven » Mon Sep 30, 2013 9:08 am

Xfrank, I don't have a DVD/CD issue, and the printer issue is not solved.
The computer says it is trying to print, then after a while (30 seconds or so)
notifications says it is not connected.
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

rudar
Level 2
Level 2
Posts: 60
Joined: Thu Sep 27, 2012 7:34 am

Re: After Update printer stopped working

Post by rudar » Mon Sep 30, 2013 2:13 pm

Sleven, as far as printing is concerned, try this sequence:

Menu-Control Center-Print Settings-Properties (i.e. right click on your printer)-Policies-check Enabled

This is how it worked for me, a day before I read the message posted by Xfrank. Besides, I had an issue with my printer before, with UP-6. At last, Monsta gave a solution. I had to enter in terminal this line:

sudo apt-get install --reinstall libgs9

I wish it were so simple for CD/DVD player now!
LMDE Mate

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: After Update printer stopped working

Post by Sleven » Mon Sep 30, 2013 6:31 pm

Thanks rudar, the printer is enabled under policies and
libgs9 is already installed. If you or anyone has any more
suggestions it would be greatly appreciated.
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Printer stopped working after UP7

Post by Sleven » Sun Oct 06, 2013 7:27 pm

Can anyone help? After UP7 my printer stopped printing.
It still works with the Windows machine. I have deleted
the printer and re-installed it but it still does not work.
It tries to print but after a few minutes it says it is not connected.
I have made sure the printer was enabled under properties>policies.
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Printer stopped working after UP7

Post by Fornhamfred » Mon Oct 07, 2013 12:19 pm

What is your printer?

User avatar
Sleven
Level 4
Level 4
Posts: 397
Joined: Sun Oct 03, 2010 9:03 am
Location: Central Florida

Re: Printer stopped working after UP7

Post by Sleven » Tue Oct 08, 2013 12:59 pm

Canon-MG5300-series
LMDE 64 running Cinnamon on an HP Compaq Core2 Duo 4G Ram

User avatar
Fornhamfred
Level 6
Level 6
Posts: 1241
Joined: Wed Oct 31, 2007 3:38 pm
Location: Suffolk UK

Re: Printer stopped working after UP7

Post by Fornhamfred » Tue Oct 08, 2013 1:45 pm

Sounds like a printer driver problem.

This link may help.

http://askubuntu.com/questions/124275/installation-of-drivers-for-canon-mg5300-series-fails

Good Luck

Locked

Return to “LMDE 1 Archive”