Compiling latest WINE: how do I resolve OpenGL dependency?

Archived topics about LMDE 1
Forum rules
Locked
lecterror
Level 1
Level 1
Posts: 24
Joined: Mon Dec 17, 2012 3:12 pm
Location: Split, Croatia
Contact:

Compiling latest WINE: how do I resolve OpenGL dependency?

Post by lecterror » Sat Dec 07, 2013 9:09 am

I'm trying to compile the latest development wine (1.7.8 ) on my LMDE 32bit. I managed to get most of the required dependencies by googling around and now I've come to a point where I have no idea what to do. Running ./configure ends with this:

Code: Select all

configure: WARNING: No OpenGL library found on this system.
OpenGL and Direct3D won't be supported.
Of course, the whole point of doing this is to have OpenGL for Steam games... :(

So what can I do to resolve this? I even managed to build wine on my old Ubuntu 10.10 but for some reason LMDE is resisting me... :-\

(I'm using Nvidia drivers from the repos, in case that matters.)

User avatar
gryphon
Level 1
Level 1
Posts: 31
Joined: Fri Nov 01, 2013 12:05 pm

Re: Compiling latest WINE: how do I resolve OpenGL dependenc

Post by gryphon » Sat Dec 07, 2013 9:23 am

This should manage your dependencies automatically: sudo apt-get build-dep wine

You can also install the latest precompiled wine debs from http://wine.psy-q.ch

lecterror
Level 1
Level 1
Posts: 24
Joined: Mon Dec 17, 2012 3:12 pm
Location: Split, Croatia
Contact:

Re: Compiling latest WINE: how do I resolve OpenGL dependenc

Post by lecterror » Sat Dec 07, 2013 10:46 am

Hi there!

I've already tried `sudo apt-get build-dep wine` and it did install some missing things, but I'm still getting the same error.

I just tried installing the list of dependencies given in the psy-q repo, and the error is still there.

For now I've installed his .deb package (and it works properly!), but I'd still like to get to the bottom of this and be able to build wine myself.

Locked

Return to “LMDE 1 Archive”