Installing Scribus 1.4.3 on LMDE 201403 MATE? [SOLVED]

Archived topics about LMDE 1
Locked
Transistor
Level 1
Level 1
Posts: 24
Joined: Fri Apr 25, 2014 5:52 am

Installing Scribus 1.4.3 on LMDE 201403 MATE? [SOLVED]

Post by Transistor » Sat May 10, 2014 2:48 pm

Hi all,

I'm running LMDE 201403 MATE 64bits on my Laptop.

I want to install Scribus (Open Source Desktop Publishing). I'd like to install the latest stable release, 1.4.3, but in Synaptic, the latest version I can install is 1.4.0.

I found an installation tutorial here (http://linuxg.net/how-to-install-scribu ... nd-debian/) and want to ask if this is applicable to LMDE, too.

Here's my current apt sources list (/etc/apt/sources.list.d/official-package-repositories.list):

Code: Select all

deb http://packages.linuxmint.com debian main upstream import 

deb http://debian.linuxmint.com/latest/ testing main contrib non-free
deb http://debian.linuxmint.com/latest/security testing/updates main contrib non-free
deb http://debian.linuxmint.com/latest/multimedia testing main non-free

deb http://extra.linuxmint.com debian main
On the Scribus website, the repositories for Debian are mentioned:
http://wiki.scribus.net/canvas/Debian
So, could I simple add the Debian wheezy repository

Code: Select all

deb http://debian.scribus.net/debian/ testing main
to my sources list?

Or, if not, what's the right way to install Scribus 1.4.3 on LMDE?

Thanks for your responses.
Last edited by Transistor on Mon May 12, 2014 6:40 am, edited 1 time in total.

py-thon
Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Installing Scribus 1.4.3 on LMDE 201403 MATE?

Post by py-thon » Sun May 11, 2014 10:58 am

Transistor wrote: So, could I simple add the Debian wheezy repository

Code: Select all

deb http://debian.scribus.net/debian/ testing main
to my sources list?
Actually this is the repository for Jessie ("testing" right now), which is the correct version for LMDE. Wheezy is already "stable" for some time and currently contains the same version as LMDE, the wiki for Scribus is outdated in this respect.

I would not just add this line to /etc/apt/sources.list.d/official-package-repositories.list as sources handling has been changed since UP 8. Start the new program to handle sources (software-sources) and add the scribus repository. I suppose this repo will automatically rank higher than LMDE (otherwise you would get 1.4.0 from LMDE-repo which would make no sense). You should be able to download the signature key with software-sources as well (step 2 of the wiki), but I haven't had the necessity to use this so far, so I can't tell whether and how it works. Continue with step 3 of the wiki.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

Transistor
Level 1
Level 1
Posts: 24
Joined: Fri Apr 25, 2014 5:52 am

Re: Installing Scribus 1.4.3 on LMDE 201403 MATE?

Post by Transistor » Sun May 11, 2014 1:32 pm

Thanks, I will try it.
Since testing is already Jessie, is it better to add

Code: Select all

deb http://debian.scribus.net/debian/ wheezy main
or

Code: Select all

deb http://debian.scribus.net/debian/ stable main
to the software-sources? I think "wheezy" is better since the current LMDE is based on it, right?

py-thon
Level 4
Level 4
Posts: 317
Joined: Fri Sep 27, 2013 2:24 pm
Location: Paraguay

Re: Installing Scribus 1.4.3 on LMDE 201403 MATE?

Post by py-thon » Sun May 11, 2014 2:55 pm

Transistor wrote:I think "wheezy" is better since the current LMDE is based on it, right?
No. LMDE is based on Debian testing, so you should use the line from your first post.

If you use wheezy instead you will get the version intended for wheezy, which is 1.4.0-something.
The names used in scribus's wiki are outdated. For about a year now Wheezy is stable, Squeeze is old stable and testing got the name Jessie. Only unstable always keeps the name Sid.
Tower: Sparky 64 bit Mate+mintmenu - Netbook: Sparky 32 bit Mate+mintmenu

Transistor
Level 1
Level 1
Posts: 24
Joined: Fri Apr 25, 2014 5:52 am

Re: Installing Scribus 1.4.3 on LMDE 201403 MATE?

Post by Transistor » Mon May 12, 2014 6:40 am

Thanks! Works as described.

Locked

Return to “LMDE 1 Archive”