Some extensions won't load in Libre Office

Archived topics about LMDE 1
Locked
lake_wrangler
Level 1
Level 1
Posts: 4
Joined: Fri Oct 24, 2014 11:02 pm

Some extensions won't load in Libre Office

Post by lake_wrangler » Sat Oct 25, 2014 1:08 am

Hi there. I am fairly new to Linux, but not to computers.

I installed LMDE 32-bit Cinnamon edition on my Acer TravelMate 2420 laptop, this week. When trying to add some extensions into Libre Office (Version: 4.1.3.2, Build ID: 410m0(Build:2), some install fine, but others give me an error message, like this one:
(com.sun.star.lang.DisposedException) { { { Message = "Binary URP bridge disposed during call", Context = (com.sun.star.uno.XInterface) @-4eb86870 } } }
The same extensions worked just fine when I had Lubuntu 14.04 installed on the same laptop.

Has anyone seen this before? Any idea how to fix this?

The extensions that cause this problem are as follow:
Grammalecte(pack) 5.2 (A dictionary and grammar checker for French language text)
Linguist 1.5.1
Openclipart.org integration 0.1.4
Pyton Calender for Calc 4.0.1

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Some extensions won't load in Libre Office

Post by cwsnyder » Fri Nov 28, 2014 8:42 am

What version of LibreOffice did you have installed under Lubuntu 14.04? I believe that LMDE has an older version of LibreOffice from the repositories.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

lake_wrangler
Level 1
Level 1
Posts: 4
Joined: Fri Oct 24, 2014 11:02 pm

Re: Some extensions won't load in Libre Office

Post by lake_wrangler » Mon Dec 01, 2014 12:35 am

cwsnyder wrote:What version of LibreOffice did you have installed under Lubuntu 14.04? I believe that LMDE has an older version of LibreOffice from the repositories.
I cross-posted this question on the LinuxQuestions forum, and someone mentioned that the problem might be, indeed, that LMDE uses too old a version of Libre Office. So I have now uninstalled the version of Libre Office which came with Linux Mint Debian Edition (4.1.3.2), and installed the latest still version from the libreoffice.org website (4.3.4.1), using the .deb files provided there. All my extensions now work.

I am guessing that now, I have to manually update the program? I looked at the possibility of adding the Libre Office PPA to my source of repositories using

Code: Select all

sudo add-apt-repository ppa:libreoffice/ppa
but every web page I see on the subject mentions that method being suited for Ubuntu, not Debian, and I don't know if that would mess things up. I would have liked to have Libre Office included in the automatic software updates in LMDE... Any idea if it would work anyway?

kurotsugi
Level 6
Level 6
Posts: 1038
Joined: Fri Jan 25, 2013 3:54 am

Re: Some extensions won't load in Libre Office

Post by kurotsugi » Tue Dec 02, 2014 2:40 pm

it certainly will...the fastest and easiest solution would be reinstall your system and use mint main version or debian. LMDE latest UP was on Feb 2014 and 'only god know when' will it got next update. it might rash but I can say that LMDE is currently on abandoned state. don't use it until LMDE2 got released.

lake_wrangler
Level 1
Level 1
Posts: 4
Joined: Fri Oct 24, 2014 11:02 pm

Re: Some extensions won't load in Libre Office

Post by lake_wrangler » Wed Dec 03, 2014 3:38 pm

I just happened to look at the Grammalecte website, and it turns out that it is compatible with Libre Office 3.3.1+, so it should have worked just fine with the version that came with LMDE... So I don't know what was causing the problem, after all...

But hey, it's working, now, so I won't make waves... :wink:

cwsnyder
Level 6
Level 6
Posts: 1242
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Some extensions won't load in Libre Office

Post by cwsnyder » Wed Dec 03, 2014 5:10 pm

You can add the repository for Debian stable and use it with LMDE, using the methods outlined for Debian on the LibreOffice site.
LMDE Mate 64-bit, LM17.3 Cinnamon 64-bit
Debian Mate 64-bit, Xubuntu xenial 64-bit, Ubuntu-Mate 14.04 64-bit, Antergos Xfce 64-bit, PCLinuxOS Mate 64-bit

lake_wrangler
Level 1
Level 1
Posts: 4
Joined: Fri Oct 24, 2014 11:02 pm

Re: Some extensions won't load in Libre Office

Post by lake_wrangler » Thu Dec 04, 2014 1:44 pm

I have to admit, now that I know that the extensions should have worked with the Libre Office that came with LMDE, that I am tempted to uninstall the version I downloaded from the LO website, to reinstall the older, LMDE-supplied version, to see if it would work after such a reinstallation...

(And yes, I am quite aware of the saying according to which one is a fool to keep doing the same thing, yet expect a different result... :wink: )

Locked

Return to “LMDE 1 Archive”