"Software rendering mode" after i915.modeset=0 boot

Archived topics about LMDE 1
Locked
mblum
Level 1
Level 1
Posts: 1
Joined: Sat Nov 22, 2014 5:57 pm

"Software rendering mode" after i915.modeset=0 boot

Post by mblum » Sat Nov 22, 2014 7:57 pm

Thank you in advance for any help you can give.

Background:
I am a grudging Windows user, wanting to be a full-time Linux user. My work laptop is Windows and my personal laptop has been running a Debian system for the past three years. I would like to try LMDE and potentially switch. I am not interested in Ubuntu or Ubuntu-based systems.

Problem summary:
I had the problem of the screen going black upon boot. Searched the issue and finally got it to boot into Cinnamon after appending i915.modeset=0 to the kernel parameters, but only in "Software rendering mode" which uses up a lot of the CPU because it is running without hardware acceleration. I want to figure out how I can get it to run not in this mode.

Some bits of inxi -Fxz:

Code: Select all

System:
     Kernel: 3.11-2-amd64 x86-64 (64_bit, gcc: 4.8.1)
     Desktop: Cinnamon 2.0.14
     Distro: LinuxMint 1 debian
Machine:
     System: Gateway
     product: EG40_HC
     version: Type2 - A01 Board Version
     Bios: Insyde
     version: V2.17
CPU:
     Dual core Intel Celeron CPU 1005M (-MCP-)
Graphics:
     Card: Intel 3rd Gen Core processor Graphics Controller
     X.org: 1.14.3
     drivers: vesa, intel (unloaded: fbdev)
     tty size: 168x46
     Advanced Data: N/A for root
I tried to make sure that my drivers were updated by using the following:

Code: Select all

$ sudo apt-get install xserver-xorg-video-intel
and I get:

Code: Select all

Reading package lists... Done
Building dependency tree
Reading state information... Done
xserver-xorg-video-intel is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded
.

I think my problem is with my drivers for my integrated graphics, but I am pretty lost as to what to try next. If there are further readouts that would be helpful, I can provide them.

kurotsugi
Level 6
Level 6
Posts: 1038
Joined: Fri Jan 25, 2013 3:54 am

Re: "Software rendering mode" after i915.modeset=0 boot

Post by kurotsugi » Mon Nov 24, 2014 12:11 pm

the easiest way...don't use cinnamon until you got cinnamon 2.4. I'd suggest to install xfce as a replacement for your desktop. the good news is that cinnamon 2.4 is now available on betsy and a user reported that it now work on debian jessie. your other option would be:
1. install a debian jessie and use cinnamon 2.2 from debian
2. install a debian jessie and use cinnamon 2.4 from mint

you can also try to upgrade your LMDE to jessie by following this thread but the risk is quite high http://forums.linuxmint.com/viewtopic.p ... 8&t=183280

Locked

Return to “LMDE 1 Archive”