Can i upgrade LMDE to Kernel 3.19?

Archived topics about LMDE 1
Forum rules
zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Thu Feb 26, 2015 6:35 pm

i want to install LMDE on my Surface and the 3.19 kernal has the necessary hardware support for the power button, the keyboard, and a few other things.

I was wondering if I had to go with Ubuntu or if I could upgrade to 3.19 on Debian?

Thank you.

Mute Ant
Level 13
Level 13
Posts: 4902
Joined: Tue Sep 03, 2013 7:45 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Mute Ant » Thu Feb 26, 2015 7:24 pm

''Linux kernel 3.19 has been officially announced by none other than its father, Linus Torvalds, on February 8, 2015.''

Experts in this field....[0].

Your chance to be the first penguin in the water :? with everyone else watching to see what happens.
Data stored in an encrypted volume will only be accessible with the original password. Without this key, all the data will remain scrambled beyond hope of recovery.

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Thu Feb 26, 2015 8:35 pm

I'll try it in a few minutes and let you know.
Wish me luck?
https://packages.debian.org/experimental/kernel/
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by WharfRat » Thu Feb 26, 2015 8:39 pm

Linux mint's latest kernel is 3.13.0-46-generic. I doubt LMDE is much further along.

Whatever version of linux you decide to install there's always the option of downloading and compiling 3.19.

Good luck :wink:

UPDATE:

I just viewed Fred Barclay's post. I stand corrected :oops:
ImageImage

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Thu Feb 26, 2015 9:01 pm

Try one: FAIL.
My first hint something was wrong was that the Linux Mint icon seemed larger than normal. It hung longer than normal, so I ctrl+alt+f4 and sure enough, it was having trouble booting.

Code: Select all

Loading, please wait...
/scripts/init-top/udev: 14: /scripts/init-top/udev: cannot create /sys/kernel/ue
vent_helper: Permission denied.
I downloaded linux-image-3.19.0-trunk-686-pae (3.19-1~exp1) from the link in my first post and installed it with GDebi (which I had used earlier to install 3.16--successfully :)).
Restarted and found that nice little error message just waiting for me.
I'll probably try a little bit more in the next few days, but my call would be to use a different kernel if at all possible. For one, LMDE ships with 3.11; 3.19 is probably a bit out of its league.
Second, the package wasn't even in Debian Unstable repos, but rather in Debian Experimental. Breakages are expected--and wanted. This is how Linux tests itself.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Thu Feb 26, 2015 9:21 pm

Update 2:
I removed the 3.19 kernel using GDebi and decided to try the reinstallation after installing linux-headers-3.19.0-trunk-686-pae. Unfortunately, (at least) one of the header's dependencies, linux-kbuild-3.19, is not available at the moment. So it might be a few before I can try installing 3.19 again.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Wed Mar 25, 2015 9:04 am

If you are willing to not use the stock Debian kernel, then you should be able to use 3.19. In fact, I'm typing this right now on a 3.19 kernel, distributed by Liquorix

HOWEVER: I installed the Liquorix 3.19 kernel on LMDE Betsy and Debian Sid. I have not installed it on the old LMDE, but I suspect it will do fine.

If you want to install it, do the following:

Code: Select all

sudo touch /etc/apt/sources.list.d/liquorix.list
sudo gedit /etc/apt/sources.list.d/liquorix.list
and add the following lines:

Code: Select all

deb http://liquorix.net/debian sid main
deb-src http://liquorix.net/debian sid main
Save the file.
Now verify that the lines were saved.

Code: Select all

sudo cat /etc/apt/sources.list.d/liquorix.list
Prepare LMDE to install the kernel.

Code: Select all

sudo apt-get update

sudo apt-get install liquorix-keyring

sudo apt-get update
Now it is ready to install, however, you will need to decide what kernel architecture you want. You have 3 options: 32-bit without PAE, 32-bit with PAE, or 64-bit. If you are unsure which to choose, see here.

For 32-bit without PAE, run

Code: Select all

sudo apt-get install linux-image-liquorix-686 linux-headers-liquorix-686
For 32-bit with PAE

Code: Select all

sudo apt-get install linux-image-liquorix-686-pae linux-headers-liquorix-686-pae
For 64-bit

Code: Select all

sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64
Reboot after the process completes.

That's it! You will now be running the 3.19 kernel on LMDE. On Betsy, I'm getting Liquorix updates through the Update Manager, just like for other software, but they are level 5 and you will have to manually select them if you have not chosen to automatically install level 5 updates. Also, you will not be able to see them if you haven't chosen for level 4 and 5 updates to be visible. So in a nutshell, if you don't choose for level 4 and 5 updates to be visible in Update Manager, you will not see (and therefore not install) updates for Liquorix.
Keep in mind this is for Betsy. I'm not sure how it would look in the old LMDE.

Special thanks to richyrich for making me aware of the liquorix kernel. :)
Attachments
liquorix.png
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Thu Mar 26, 2015 7:39 pm

i get this error while following the instructions above.

# sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-headers-liquorix-amd64 : Depends: linux-headers-3.19-2.dmz.2-liquorix-amd64 (= 3.19-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
#

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Thu Mar 26, 2015 9:26 pm

Can you post the output of

Code: Select all

sudo ls -a /etc/apt/sources.list.d
sudo cat /etc/apt/sources.list.d/liquorix.list
Thanks!
Is this on the old LMDE or on LMDE Betsy?
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4144
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can i upgrade LMDE to Kernel 3.19?

Post by Fred Barclay » Thu Mar 26, 2015 9:29 pm

Also, can you run

Code: Select all

 sudo apt-get -f install
.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Sun Mar 29, 2015 1:20 pm

$ sudo ls -a /etc/apt/sources.list.d
. .. liquorix.list official-package-repositories.list

$ sudo cat /etc/apt/sources.list.d/liquorix.list

# LiquidX Kernel
deb http://liquorix.net/debian sid main
deb-src http://liquorix.net/debian sid main


$

User avatar
killer de bug
Level 14
Level 14
Posts: 5392
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Can i upgrade LMDE to Kernel 3.19?

Post by killer de bug » Sun Mar 29, 2015 3:55 pm

Stupid question: did you run apt update before attempting the install?
Image
If it ain't broke, fix it until it is.

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Sun Mar 29, 2015 4:51 pm

I did run apt-get update i did it again and posted results below.

Oh i failed to answer your previous question. Im using the LMDE 3/2014. LMDE-2 has dependency problems installing Compiz Which makes my home theater system look awesome. :wink:


$ sudo apt-get update
[sudo] password for xxxxx:
Ign http://packages.linuxmint.com debian InRelease
Ign http://extra.linuxmint.com debian InRelease
Get:1 http://packages.linuxmint.com debian Release.gpg [198 B]
Hit http://liquorix.net sid InRelease
Get:2 http://packages.linuxmint.com debian Release [16.7 kB]
Ign http://extra.linuxmint.com debian Release.gpg
Hit http://liquorix.net sid/main Sources
Hit http://liquorix.net sid/main amd64 Packages
Hit http://liquorix.net sid/main i386 Packages
Get:3 http://extra.linuxmint.com debian Release [2,275 B]
Get:4 http://packages.linuxmint.com debian/main amd64 Packages [26.1 kB]
Ign http://extra.linuxmint.com debian/main amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing InRelease
Get:5 http://packages.linuxmint.com debian/upstream amd64 Packages [16.1 kB]
Ign http://extra.linuxmint.com debian/main i386 Packages/DiffIndex
Get:6 http://packages.linuxmint.com debian/import amd64 Packages [55.4 kB]
Ign http://liquorix.net sid/main Translation-en_US
Ign http://liquorix.net sid/main Translation-en
Hit http://debian.linuxmint.com testing/updates InRelease
Get:7 http://packages.linuxmint.com debian/main i386 Packages [26.1 kB]
Get:8 http://packages.linuxmint.com debian/upstream i386 Packages [16.1 kB]
Get:9 http://packages.linuxmint.com debian/import i386 Packages [55.4 kB]
Hit http://debian.linuxmint.com testing InRelease
Hit http://debian.linuxmint.com testing/main amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/contrib amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/non-free amd64 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/main i386 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/contrib i386 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/non-free i386 Packages/DiffIndex
Hit http://debian.linuxmint.com testing/contrib Translation-en/DiffIndex
Get:10 http://extra.linuxmint.com debian/main amd64 Packages [20 B]
Hit http://debian.linuxmint.com testing/main Translation-en/DiffIndex
Hit http://debian.linuxmint.com testing/non-free Translation-en/DiffIndex
Get:11 http://extra.linuxmint.com debian/main i386 Packages [20 B]
Ign http://extra.linuxmint.com debian/main Translation-en_US
Ign http://extra.linuxmint.com debian/main Translation-en
Hit http://debian.linuxmint.com testing/updates/main amd64 Packages
Ign http://packages.linuxmint.com debian/import Translation-en_US
Ign http://packages.linuxmint.com debian/import Translation-en
Ign http://packages.linuxmint.com debian/main Translation-en_US
Hit http://debian.linuxmint.com testing/updates/contrib amd64 Packages
Ign http://packages.linuxmint.com debian/main Translation-en
Ign http://packages.linuxmint.com debian/upstream Translation-en_US
Ign http://packages.linuxmint.com debian/upstream Translation-en
Hit http://debian.linuxmint.com testing/updates/non-free amd64 Packages
Hit http://debian.linuxmint.com testing/updates/main i386 Packages
Hit http://debian.linuxmint.com testing/updates/contrib i386 Packages
Hit http://debian.linuxmint.com testing/updates/non-free i386 Packages
Hit http://debian.linuxmint.com testing/updates/contrib Translation-en
Hit http://debian.linuxmint.com testing/updates/main Translation-en
Hit http://debian.linuxmint.com testing/updates/non-free Translation-en
Hit http://debian.linuxmint.com testing/main amd64 Packages
Hit http://debian.linuxmint.com testing/non-free amd64 Packages
Hit http://debian.linuxmint.com testing/main i386 Packages
Hit http://debian.linuxmint.com testing/non-free i386 Packages
Ign http://debian.linuxmint.com testing/main Translation-en_US
Ign http://debian.linuxmint.com testing/main Translation-en
Ign http://debian.linuxmint.com testing/non-free Translation-en_US
Ign http://debian.linuxmint.com testing/non-free Translation-en
Fetched 214 kB in 7s (27.6 kB/s)
Reading package lists... Done


$ sudo apt-get install linux-image-liquorix-amd64 linux-headers-liquorix-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-image-liquorix-amd64 is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-headers-liquorix-amd64 : Depends: linux-headers-3.19-2.dmz.2-liquorix-amd64 (= 3.19-2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$


When i try to install the missing dependency using package manager the results are attached in the screenshots
Attachments
Screenshot-2.png
Screenshot-1.png
Screenshot.png

User avatar
killer de bug
Level 14
Level 14
Posts: 5392
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Can i upgrade LMDE to Kernel 3.19?

Post by killer de bug » Sun Mar 29, 2015 5:00 pm

Can you post the output of

Code: Select all

apt policy linux-headers-3.19-2.dmz.2-liquorix-amd64
and

Code: Select all

apt install linux-headers-3.19-2.dmz.2-liquorix-amd64
Image
If it ain't broke, fix it until it is.

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Sun Mar 29, 2015 5:06 pm

$ apt policy linux-headers-3.19-2.dmz.2-liquorix-amd64
linux-headers-3.19-2.dmz.2-liquorix-amd64:
Installed: (none)
Candidate: 3.19-2
Version table:
3.19-2 0
500 http://liquorix.net/debian/ sid/main amd64 Packages
$


and


$ apt install linux-headers-3.19-2.dmz.2-liquorix-amd64
[sudo] password for xxxxx:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
linux-headers-3.19-2.dmz.2-liquorix-amd64 : Depends: gcc-4.9 but it is not installable
E: Unable to correct problems, you have held broken packages.
$

User avatar
killer de bug
Level 14
Level 14
Posts: 5392
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Can i upgrade LMDE to Kernel 3.19?

Post by killer de bug » Sun Mar 29, 2015 5:10 pm

zaileion wrote: linux-headers-3.19-2.dmz.2-liquorix-amd64 : Depends: gcc-4.9 but it is not installable
E: Unable to correct problems, you have held broken packages.
$
Arg I was afraid of something like this... :(
https://packages.debian.org/fr/jessie/gcc-4.9

If you want this liquorix kernel, you need to upgrade to Betsy.
Image
If it ain't broke, fix it until it is.

User avatar
killer de bug
Level 14
Level 14
Posts: 5392
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Can i upgrade LMDE to Kernel 3.19?

Post by killer de bug » Sun Mar 29, 2015 5:13 pm

Maybe you should compile this kernel:

http://debian-handbook.info/browse/stab ... ation.html
Image
If it ain't broke, fix it until it is.

User avatar
valasudurai
Level 1
Level 1
Posts: 14
Joined: Mon Aug 25, 2014 3:56 am
Location: India

Re: Can i upgrade LMDE to Kernel 3.19?

Post by valasudurai » Mon Apr 06, 2015 9:12 am

i am also failed to upgrade the latest version of kernal because i got lot of error so i decided to download the latest version of linuxmint os thanks for your support

i was done to update the new kernal 3.13 to 3.19 but it was not go the graphical interface it shows only error promt to fix this

zaileion
Level 3
Level 3
Posts: 147
Joined: Sun Jan 25, 2015 6:01 pm

Re: Can i upgrade LMDE to Kernel 3.19?

Post by zaileion » Fri Jul 31, 2015 9:56 pm

killer de bug wrote:Maybe you should compile this kernel:

http://debian-handbook.info/browse/stab ... ation.html

I followed these instructions. and was successful in compiling kernel 4.2-RC4 as well as kernel 4.1.3 Thank you for the guide. It worked!

But now i cannot install my ATI catalyst drivers. I do not use the repo drivers, i download the drivers from ATI and install them. So when i try to install the ATi drivers i get an error stating missing dependencies. The log says there aren't any "linux-headers" installed. but i know they are because the kernel build procedure built 5 .deb packages and 2 of them were titled "linux-headers"

Any ideas?

ddurdle
Level 3
Level 3
Posts: 131
Joined: Sat Dec 17, 2011 10:03 am

Re: Can i upgrade LMDE to Kernel 3.19?

Post by ddurdle » Wed Sep 02, 2015 7:28 pm

zaileion wrote:
killer de bug wrote:Maybe you should compile this kernel:

http://debian-handbook.info/browse/stab ... ation.html

I followed these instructions. and was successful in compiling kernel 4.2-RC4 as well as kernel 4.1.3 Thank you for the guide. It worked!

But now i cannot install my ATI catalyst drivers. I do not use the repo drivers, i download the drivers from ATI and install them. So when i try to install the ATi drivers i get an error stating missing dependencies. The log says there aren't any "linux-headers" installed. but i know they are because the kernel build procedure built 5 .deb packages and 2 of them were titled "linux-headers"

Any ideas?
Looks like their drivers are not updated for the new kernel yet. The open source radeon drivers worked out-of-the-box for me.

Locked

Return to “LMDE 1 Archive”