Automatic login does not work with LMDE2

Archived topics about LMDE 1
Forum rules
ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Automatic login does not work with LMDE2

Postby ron_h » Tue Jul 14, 2015 1:53 am

LMDE2 Cinnamon 64bit after upgrade from LMDE1 201403 Cinnamon 64bit

In LMDE1 I had the system set to auto-login, that is System settings-Administration-Login window-Login window preferences with Auto login set to Automatic login for user ron. As far as I can see, if I go through the same dialog on LMDE2 it is still set that way. HOWEVER it doesn't work, I no longer get an uninterrupted login process. When I boot LMDE2, first I get a Login box asking for a username,
UPDATE I have to enter ron as user name
and I have to hit enter to get the bootup to continue. I then get a login box for ron asking for password which I have to supply then hit enter to get the bootup to continue.

Has Automatic login been removed from LMDE2 ? If so, why do I still see it in System settings ? If not, how do I get it to work ?

Ron
Last edited by ron_h on Sat Jul 18, 2015 6:35 am, edited 3 times in total.

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2 UPDATED

Postby ron_h » Thu Jul 16, 2015 6:47 pm

I set Automatic login off and rebooted. Interestingly, the new login was faster as I was not presented with the first dialog box to specify username, just the second dialog box to specify password for username ron. So I set Automatic login on again and rebooted. This time, it did perform Automatic login.

UPDATE But when I powered on this morning, it's back to the 2 dialog boxes.

Somehow in the upgrade from LMDE1 to LMDE2 something related to Automatic login gets screwed up.
UPDATE and it does not appear to be consistent

I suppose I'll have to mark this thread as SOLVED
UPDATE I've removed the SOLVED because there is definitely a bug, at least on my system

UPDATE Is there a specific package that supports automatic login ? If so, I'll remove it and re-install

Ron

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Sat Jul 18, 2015 6:33 am

As best I can determine, automatic login in LMDE1 and LMDE2 is handled by the MDM package.

I've looked at /etc/mdm/mdm.conf on both my LMDE1 system and on my LMDE2 system. They both contain the following

Code: Select all

[daemon]

AutomaticLoginEnable=true

AutomaticLogin=ron



A difference between the systems is the level of the MDM package
- LMDE1 the MDM package is at level 1.4.11+lmde and automatic login does work
- LMDE2 the MDM package is at level 2.0.4+betsy and automatic login does NOT work at least for me

What would be the consequences of removing and reinstalling the MDM package ? If it's going to give me grief, I'll hold off for a while in the hope someone can come up with a solution to my problem. :-)

Ron

TomRoche
Level 4
Level 4
Posts: 248
Joined: Thu Jan 13, 2011 2:52 pm

display metaquestion

Postby TomRoche » Sat Jul 18, 2015 12:15 pm

@forumadmins (since this probably won't help ron_h much): I notice that


So should LMDE2 users continue to ask {desktop environment, display manager, window manager}-related questions in the LMDE1 subforum?

(Note that I'm not claiming ron_h's question should necessarily be relocated--it definitely seems upgrade-related.)

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Sat Jul 18, 2015 6:10 pm

Something is definitely screwed up.

This morning I booted up the LMDE2 system, and autologin worked. So I shut the system down making no changes of any kind and rebooted. This time I had the 2 dialog boxes and had to specify my user name and password, autologin did not work. I'm just shutting it down again to see what happens third time this morning. Please note I am shutting down, not restarting, in each case. Third time I get the 2 dialog boxes that is it didn't autologin.

Ron

TomRoche
Level 4
Level 4
Posts: 248
Joined: Thu Jan 13, 2011 2:52 pm

boottime debugging

Postby TomRoche » Sat Jul 18, 2015 7:04 pm

Does

Code: Select all

dmesg | fgrep -ie 'error'
or

Code: Select all

dmesg | less
show anything interesting?

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Sun Jul 19, 2015 5:25 am

Code: Select all

dmesg | fgrep -ie 'error'


results in

Code: Select all

[   11.340956] Error: Driver 'pcspkr' is already registered, aborting...
[   20.087915] EXT4-fs (sda8): re-mounted. Opts: errors=remount-ro
[   50.436132] [drm:intel_pipe_config_compare] *ERROR* mismatch in adjusted_mode.flags (expected 1, found 0)


Code: Select all

dmesg | less


UPDATE What interesting things should I be looking for in dmesg ? I've looked for any instances of 'login', 'automatic' and 'mdm' and nothing to my eye looks of interest :-)

Ron

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Wed Jul 29, 2015 6:08 am

The only mention of user ron in dmesg is :

Code: Select all

In dmesg when username and password required in bootup
[   40.588310] systemd-logind[2891]: New seat seat0.
[   40.616910] systemd-logind[2891]: Failed to start user service: Unknown unit: user@1000.service
[   40.629608] systemd-logind[2891]: New session c1 of user ron.
In dmesg when bootup does not require username and password
[   40.262632] systemd-logind[2815]: New seat seat0.
[   40.312557] systemd-logind[2815]: Failed to start user service: Unknown unit: user@1000.service
[   40.326060] systemd-logind[2815]: New session c1 of user ron.


Ron

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Sat Aug 01, 2015 9:32 pm

I really don't like intermittent faults. The last 4 or 5 times I've booted the LMDE2 system, automatic login has worked each time. And AFAIK, I have changed nothing. Previous to this, automatic login worked about 1 time in 3.

Ron

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Tue Aug 04, 2015 10:09 pm

The last 5 times I've booted, no auto login. Had to specify user name and password each time. No changes made to the system.

Ron

ron_h
Level 4
Level 4
Posts: 270
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: Automatic login does not work with LMDE2

Postby ron_h » Tue Aug 04, 2015 10:57 pm

Well, I booted LMDE2 from a USB stick, and auto-login worked fine for user 'mint'.

Ron

User avatar
jtarin
Level 3
Level 3
Posts: 124
Joined: Sat Jun 08, 2013 8:14 am

Re: Automatic login does not work with LMDE2

Postby jtarin » Fri Nov 13, 2015 11:44 pm

Continuing problem, as of this date.......Solutions???
Former Slackware user breaking bad.

User avatar
Crewp
Level 9
Level 9
Posts: 2522
Joined: Sat Dec 01, 2012 8:36 pm
Location: Connecticut,USA

Re: Automatic login does not work with LMDE2

Postby Crewp » Sat Nov 14, 2015 8:28 am

Have you tried: Menu/ Administration/Login Window then on left panel click Auto Login, then make sure Enable Auto Login is checked, and your user name appears in the box below.
Image

User avatar
jtarin
Level 3
Level 3
Posts: 124
Joined: Sat Jun 08, 2013 8:14 am

Re: Automatic login does not work with LMDE2

Postby jtarin » Sat Nov 14, 2015 11:28 am

Crewp wrote:Have you tried: Menu/ Administration/Login Window then on left panel click Auto Login, then make sure Enable Auto Login is checked, and your user name appears in the box below.

I don't know about the OP but the obvious is not my nature. :P
Actually that only worked about half the time for me. My method was to edit the "daemon" section of /etc/mdm/mdm.conf , as root after making a backup.
Former Slackware user breaking bad.


Return to “Archive”