Latest updates broke Samba

Archived topics about LMDE 1
Forum rules
LMDE 2 support ends on 1-1-2019
DarkNova
Level 1
Level 1
Posts: 10
Joined: Fri Sep 28, 2012 3:44 pm

Latest updates broke Samba

Post by DarkNova » Fri Apr 15, 2016 3:09 pm

LMDE 2 informed me that it had package updates on 4/13 and 4/14 for Samba packages. I see in my apt history that it upgraded both on 4/13 and 4/14. It is currently running samba-common:amd64 (4.2.10+dfsg-0+deb8u1, 4.2.10+dfsg-0+deb8u2).

I first noticed the problem when I went to print a document on a printer that is shared by a Windows 7 machine. It normally prompts me for my password but it would not accept the password -- it kept asking for it over and over. In the CUPS error log I see:

Code: Select all

E [15/Apr/2016:13:51:42 -0500] [Job 3440] Session setup failed: NT_STATUS_ACCESS_DENIED
E [15/Apr/2016:13:51:42 -0500] [Job 3440] Session setup failed: NT_STATUS_ACCESS_DENIED
E [15/Apr/2016:13:51:42 -0500] [Job 3440] Session setup failed: NT_STATUS_ACCESS_DENIED
E [15/Apr/2016:13:51:42 -0500] [Job 3440] Tree connect failed (NT_STATUS_ACCESS_DENIED)
Then I tried accessing the computer's shares under Network->Browse Network and navigated to this computer. Again, it prompted me for the password over and over, and would not accept it.

I then tried:

Code: Select all

smbclient -L //WINPC -U myuser
and it gives me the error:

Code: Select all

NTLMSSP packet check failed due to short signature (0 bytes)!
NTLMSSP NTLM2 packet check failed due to invalid signature!
session setup failed: NT_STATUS_ACCESS_DENIED

So it looks like something in Samba broke in this latest update. I have a Solaris box that I can still connect to fine, so Samba isn't totally broken, but it appear to be for connecting to Windows 7 at least. Can someone else test this on their network to a Windows 7 box? Does anyone know what changed in Samba for this latest update? Thanks.

Penn
Level 5
Level 5
Posts: 752
Joined: Tue Jun 10, 2014 1:12 pm

Re: Latest updates broke Samba

Post by Penn » Fri Apr 15, 2016 6:22 pm

When I first applied that most recent update it gave me an install error (sorry, don't remember what the error was). I tried to install a second time since that worked with one update that failed on first attempt not long after I first started using Mint. The second attempt informed me of broken packages. I just went to synaptic package manager and chose "Fix Broken Packages" under the edit menu and all seems to be working now but I don't use my LMDE install as a host (only only once in a while as a client).

If you have broken packages this might be of help, but if not at least maybe someone who needs to know is now aware 2 people had issues with that update in LMDE. The recent Samba update on my 17.3 machine didn't have issues.

DarkNova
Level 1
Level 1
Posts: 10
Joined: Fri Sep 28, 2012 3:44 pm

Re: Latest updates broke Samba

Post by DarkNova » Fri Apr 15, 2016 6:25 pm

Thanks. In my case the packages installed fine, so Samba isn't really broken in that sense, more in the sense that there may have been a bug introduced with this update.

Jugene
Level 1
Level 1
Posts: 9
Joined: Mon Apr 11, 2016 3:42 am

Re: Latest updates broke Samba

Post by Jugene » Mon Apr 18, 2016 12:02 pm

Updated samba. Conf left old. Now there is no access to folders on the network. It requires a password that was not there. Maybe there is a solution how to get to work without having to reinstall the previous version? :?:

DrM
Level 2
Level 2
Posts: 80
Joined: Sun Feb 23, 2014 4:03 pm

Re: Latest updates broke Samba

Post by DrM » Mon Apr 18, 2016 1:05 pm

When the entry security = share is present in the /etc/samba/smb.conf file, the system-config-samba crashes when I want to launch that util. Very strange. This has happened since the latest samba update which seems to have a bug.

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Mon Apr 18, 2016 1:17 pm

DarkNova wrote:Thanks. In my case the packages installed fine, so Samba isn't really broken in that sense, more in the sense that there may have been a bug introduced with this update.
Yes, I think so.
--Ben

Jugene
Level 1
Level 1
Posts: 9
Joined: Mon Apr 11, 2016 3:42 am

Re: Latest updates broke Samba

Post by Jugene » Tue Apr 19, 2016 2:22 am

Everything works if administered Root password. :D

DarkNova
Level 1
Level 1
Posts: 10
Joined: Fri Sep 28, 2012 3:44 pm

Re: Latest updates broke Samba

Post by DarkNova » Tue Apr 19, 2016 8:26 am

Jugene wrote:Everything works if administered Root password. :D
Not in my case.

Jugene
Level 1
Level 1
Posts: 9
Joined: Mon Apr 11, 2016 3:42 am

Re: Latest updates broke Samba

Post by Jugene » Tue Apr 19, 2016 9:28 am

My conf

[global]
netbios name = Jugene
workgroup = TVMED
server string = %h server (Samba, Linux Mint)
security = user
dns proxy = no
log file = /var/log/samba/log.%m
max log size = 1000
syslog = 0
panic action = /usr/share/samba/panic-action %d
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user
usershare allow guests = yes

[printers]
comment = All Printers
browseable = no
path = /var/spool/samba
printable = yes
guest ok = no
read only = yes
create mask = 0700

[Shared]
path = /home/jugene/Shared
comment = No comment
read only = no
available = yes
browseable = yes
writable = yes
guest ok = yes
public = yes
printable = no
locking = no
strict locking = no

[print$]
path = /var/lib/samba/printers
comment = Printer Drivers
read only = yes
available = yes
browseable = yes
writable = no
guest ok = yes
public = yes
printable = yes
locking = no
strict locking = no

[Distrib]
path = /mnt/D484A60D84A5F262/Distr
comment = No comment
directory mask = 777
create mode = 777
read only = no
available = yes
browseable = yes
writable = no
guest ok = yes
public = yes
printable = no
locking = no
strict locking = no

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Tue Apr 19, 2016 2:13 pm

On my work machine, I connect to two CIFS shares on a regular basis.
After the update last week, one of them still works and one of them doesn't. I am still looking into this.
--Ben

Polymorph
Level 1
Level 1
Posts: 24
Joined: Tue Jan 31, 2012 8:11 pm
Location: NSW, Australia

Re: Latest updates broke Samba

Post by Polymorph » Tue Apr 19, 2016 9:07 pm

I have two computers running LinuxMint 17.3. On both, if I try to open Samba (Menu > system > Samba) I get a window asking for my password - after that nothing. I tried uninstalling samba and system-config-samba and reinstalling but the problem remained.

Yesterday I reinstalled LinuxMint 17.2 on one computer, updated it then upgraded to 17.3. I was able to open the Samba GUI and set shared directories once. But the two computers were not networking at all. The WORKGROUP did not show up. Neither Linux computer showed up on a Windows 10 computer either. When I tried to reopen the Samba GUI a second time nothing happened after entering my password

Until the last few days everything has worked very well

I guess that a recent update has broken samba and networking.

Any suggestions

TIA

Polymorph
Level 1
Level 1
Posts: 24
Joined: Tue Jan 31, 2012 8:11 pm
Location: NSW, Australia

Re: Latest updates broke Samba

Post by Polymorph » Wed Apr 20, 2016 1:12 am

I have just tested a third LinuxMint 17.3 computer. Samba worked OK on it.

Then I updated the computer. Afterwards Samba did not work!!

The update included:
samba 2:4.3.8+dfsg-0ubuntu0.14.04.2
Also samba-libs; samba-common; samba-common-bin; smbclient with the same version details

This update definitely crashed the network.

Do we just wait for a correction??

TIA

Jugene
Level 1
Level 1
Posts: 9
Joined: Mon Apr 11, 2016 3:42 am

Re: Latest updates broke Samba

Post by Jugene » Wed Apr 20, 2016 3:18 am

I'm still working. :D

The previous version was also a bug. It was necessary to prescribe the most netbiosname

Polymorph
Level 1
Level 1
Posts: 24
Joined: Tue Jan 31, 2012 8:11 pm
Location: NSW, Australia

Re: Latest updates broke Samba

Post by Polymorph » Wed Apr 20, 2016 3:50 am

It was necessary to prescribe the most netbiosname
Would you please explain. What do I have to do?

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Wed Apr 20, 2016 8:19 am

Polymorph wrote:I have just tested a third LinuxMint 17.3 computer. Samba worked OK on it.

Then I updated the computer. Afterwards Samba did not work!!

The update included:
samba 2:4.3.8+dfsg-0ubuntu0.14.04.2
Also samba-libs; samba-common; samba-common-bin; smbclient with the same version details
Yeah, my Xubuntu and Ubuntu MATE machines did the same thing.
--Ben

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Wed Apr 20, 2016 3:25 pm

OK, I at least got smbclient working so I can get on with life in the office.

Turning debugging up to ludicrous levels and googling for errors was unproductive, but the timing suggests that this is related to the badlock-related patches from security.debian.org of last week. Fedora, Ubuntu, and Debian all seem to be having similar issues, but openSUSE Leap (yay for VMs) is not.
So I got out the downgrade hammer for my LMDE2 workstation.

Standard warnings and disclaimers about downgrading packages go here. Especially downgrading security packages.

Code: Select all

cd /var/cache/apt/archives
sudo dpkg -i samba_2%3a4.1.17+dfsg-2+deb8u2_amd64.deb smbclient_2%3a4.1.17+dfsg-2+deb8u2_amd64.deb samba-common_2%3a4.1.17+dfsg-2+deb8u2_all.deb samba-common-bin_2%3a4.1.17+dfsg-2+deb8u2_amd64.deb samba-libs_2%3a4.1.17+dfsg-2+deb8u2_amd64.deb
sudo apt hold samba 
sudo apt hold samba-common
sudo apt hold smbclient
sudo apt hold samba-common-bin
sudo apt hold samba-libs
Still isn't working from caja, but smbclient is working so I can get files off of the offending share. I probably need to downgrade cifs-utils also to get caja working, but I didn't get that far.

Once the next round of Samba updates comes out, I will probably unhold the packages and upgrade them and see if things change.
--Ben

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4152
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Latest updates broke Samba

Post by Fred Barclay » Wed Apr 20, 2016 4:29 pm

If it's worth anything, I just upgraded my Debian Sid machine and got a message about a samba upgrade that fixed several serious security issues, but also was likely to break existing samba configs (which I don't use, so no worries there).

I can try to dig that message up if needed and post it here.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Wed Apr 20, 2016 5:13 pm

Fred Barclay wrote:If it's worth anything, I just upgraded my Debian Sid machine and got a message about a samba upgrade that fixed several serious security issues, but also was likely to break existing samba configs (which I don't use, so no worries there).

I can try to dig that message up if needed and post it here.
I'd love to see it, especially if it makes a suggestion on fixing said configurations.
--Ben

User avatar
Tomgin5
Level 5
Level 5
Posts: 817
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Latest updates broke Samba

Post by Tomgin5 » Wed Apr 20, 2016 6:36 pm

I noted the Samba upgrade a couple of days ago and installed it OK. I had not needed any printouts since so I tried it here. It printed but not before there was a warning flashed on the screen about"Samba broken". A moment after the flash the Xerox printer printed the 1 page like it was supposed to.
It might be broken but it is still working. :?

bigbenaugust
Level 3
Level 3
Posts: 107
Joined: Wed Dec 07, 2011 2:46 pm
Location: the 919

Re: Latest updates broke Samba

Post by bigbenaugust » Wed Apr 20, 2016 9:10 pm

Tomgin5 wrote:I noted the Samba upgrade a couple of days ago and installed it OK. I had not needed any printouts since so I tried it here. It printed but not before there was a warning flashed on the screen about"Samba broken". A moment after the flash the Xerox printer printed the 1 page like it was supposed to.
It might be broken but it is still working. :?
Yeah, after the update it was still working on one of the shares I use at work, but not the other. Since the chief difference between the two is their security models, the difference must be in the protocol or auth mechanism somewhere.
--Ben

Locked

Return to “LMDE 1 Archive”