Mult. erratic probs, stuck for good at caja / engrampa

Archived topics about LMDE 1
Forum rules
Locked
Sydney
Level 2
Level 2
Posts: 66
Joined: Mon Oct 28, 2013 8:31 am

Mult. erratic probs, stuck for good at caja / engrampa

Post by Sydney » Mon Apr 18, 2016 8:52 pm

Every time I try to update from LMDE1 to LMDE2 I seem to encounter different issues.
I have no idea if they are important or can be ignored. Also, I got stuck for good on my 3rd try (caja / engrampa - see below). Help please ?? Thank you.

The first time around this was the problem:
A1
G-Conf-WARNING **: Client failed to connect to the D-BUS daemon: ...GConf Error: No D-BUS daemon running
for details, see this link:
viewtopic.php?f=234&t=220505&p=1156839#p1156839


After posting this problem and not having received any input, I restored LMDE1 and tried updating again. This time around I had the following problems:

B1. Processing triggers for gconf2 (3.2.6-1)...
WARNING: node <gettext_domain> not understood below <schema>
(the WARNING was listed 32 times and the note popped up twice).

B2. Preparing to unpack ... /packagekit_1.0.1-2_amd64.deb ...
Unpacking packagekit (1.0.1-2) over (0.0.12-1) ...
dpkg: warning: unable to delete old directory '/etc/PackageKit/events/pre-transaction.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/PackageKit/events/post-transaction.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/PackageKit/events': Directory not empty

B3. dpkg: warning: unable to delete old directory '/etc/systemd/system/multi-user.target.wants': Directory not empty

B4. No such key 'menus-have-icons' in scheme 'org.gnome.desktop.interface' as specified in override file 'usr/share/glib-2.0/schemas/debian-system-adjustments-gschema.override': ignoring override for this key.
No such key 'menus-have-icons' in scheme 'org.gnome.desktop.interface' as specified in override file 'usr/share/glib-2.0/schemas/mint-artwork-mate.gschema.override': ignoring override for this key.

B5. libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 2: ingoring bad line starting with 'sudo"
libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 3: ingoring bad line starting with 'sudo"
libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 4: ingoring bad line starting with 'sudo"

B6. this is not an error, but confusing:
Configuration file '/etc/plymouth/plymouthd.conf' == > Modified (by you or by a script) since installation. ==> Package distributor has shipped an updated version. What would you like to do about it ? Your options are: Install the package maintainter's version / keep your currently installed version / show the differences between the versions / start a shell to examine the situation. The default action is to keep your current version.
Question: why should I not update this ? There were a total of 3 of these instances (see below).

I aborted the installation here. Why that D-BUS problem from my first attempt did not re-occur I do not know, but it came back again on the next try:



C1.
(gconftool-2:25632): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken
WARNING: node <gettext_domain> not understood below <schema>
(the WARNING was listed 32 times)
Processing triggers for menu (2.1.46) ...

And almost the same warning came up again a little further down.
(gconftool-2:29342): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken
WARNING: node <gettext_domain> not understood below <schema>
(the WARNING was listed 32 times)
Processing triggers for cups (1.7.5-11+deb8u1) ...

However, this: "GConf Error: No D-BUS daemon running" from the first attempt did not come up again.

C2: Unpacking imagemagick-common (8:6.8.9.9-5+deb8u1) over (8.6.7.7.10-6) ...
dpkg: warning: unable to delete old directory '/etc/ImageMagick': Directory not empty
Selecting previously unselected package libmagickcore-6.q16-2:amd64

C3: was the same as B4:
No such key 'menus-have-icons' in scheme 'org.gnome.desktop.interface' as specified in override file 'usr/share/glib-2.0/schemas/debian-system-adjustments-gschema.override': ignoring override for this key.
No such key 'menus-have-icons' in scheme 'org.gnome.desktop.interface' as specified in override file 'usr/share/glib-2.0/schemas/mint-artwork-mate.gschema.override': ignoring override for this key.

C4: was the same as B2:
Preparing to unpack ... /packagekit_1.0.1-2_amd64.deb ...
Unpacking packagekit (1.0.1-2) over (0.0.12-1) ...
dpkg: warning: unable to delete old directory '/etc/PackageKit/events/pre-transaction.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/PackageKit/events/post-transaction.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/PackageKit/events': Directory not empty

C5: the same as C3 (see above)

C6: same as B3:
dpkg: warning: unable to delete old directory '/etc/systemd/system/multi-user.target.wants': Directory not empty

C7: the same as C3 and C5 (see above)

C8: Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/ptspt'
Unknown media type in type 'uri/ptspu'

C9: same as B5:
libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 2: ingoring bad line starting with 'sudo"
libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 3: ingoring bad line starting with 'sudo"
libkmod: ERROR ../libkmod/libkmod-config.c:673 kmod_config_parse: /etc/modprobe.d/thinkfan.conf line 4: ingoring bad line starting with 'sudo"

C10: same as B6 (regarding plymouth)

C11: C9 again, repeated about 30 times

C12: Configuration file '/etc/issue' == > Modified (by you or by a script) since installation. ==> Package distributor has shipped an updated version. What would you like to do about it ? Your options are: Install the package maintainter's version / keep your currently installed version / show the differences between the versions / start a shell to examine the situation. The default action is to keep your current version.
Question: Why would I not update this ?

C13: Configuration file '/etc/issue.net' == > Modified (by you or by a script) since installation. ==> Package distributor has shipped an updated version. What would you like to do about it ? Your options are: Install the package maintainter's version / keep your currently installed version / show the differences between the versions / start a shell to examine the situation. The default action is to keep your current version.
Question: Why should I not update this ?

C14: C3/C5/C7 again

C15: C3/C5/C7/C14 again
immediately followed by:

C16: dpkg: mate-settings-daemon-pulse: dependency problems, but removing anyway as you requested:
mate-settings-daemon depends on mate-settings-daemon-gstreamer (>= 1.6.1-1-mate1+lmde) I mate-settings-daemon-pulse (>=1.6-1-1-mate1-lmde): however:
Package mate-settings-daemon-gstreamer is not installed
Package mate-settings-daemon-pulse is to be removed

C17: C3/C5/C7/C14 /C15 again
immediately followed by:

C18:
Processing triggers for menu (2.1.46) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for desktop-file-utils (0.22-1) ...
dpkg: libcaja-extension: dependency problems, but removing anyway as you requested:
caja depends on libcaja-extension (= 1.6.2-3+lmde).
caja-gksu depends on libcaja-extension
engrampa dpends on libcja-extension.

C19: C3/C5/C7/C14 /C15/C17 again

C20: C8 again

C21: Preparing to unpack .../engrampa-common_1.12.0-1+betsy_amd64.deb ...
Unpacking engrampa (1.12.0-1+betsy) over (1.6.0-1+lmde) ...
dpkg: error processing archive /var/cach/apt/archives/engrampa_1-12-0-1+betsy_amd64.deb (--unpack):
trying to overwrite 'usr/share/applications/engrampa.desktop', which is also in package engrampa-common 1.6.0-1+lmde
Preparing to unpack .../engrampa-common_1.12.0-1+betsy_all.deb
Unpacking engrampa-common (1.12.0-1+betsy) over (1.6.0-1+lmde)

C22: C3/C5/C7/C14 /C15/C17/C19 again
immediately followed by:

C23:
Processing triggers for mime-support (3.58) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for menu (2.1.46) ...
Processing triggers for mate-icon-theme (1.6.2-1+lmde) ...
Processsing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
/var/cache/apt/archives/engrampa_1.12.0-1+betsy_amd64_deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


I tried:
sudo dpkg -i --force-overwerite /var/cache/apt/archives/engramapa 1.12.0-1+betsy amd64.deb

which returned:
dpkg: dependency problems prevent cofiguration of engrampa:
engrampa depends on bzip2 (>= 1.9.1); however:
Package bzip2 is not configured yet
engrampa depends on caja-common; however:
Package caja-common is not configured yet
engrampa depends on engrampa-common (= 1.12.0-1+betsy); however:
Package engrampa-common is not configured yet.
engrampa depends on p7zip-full; however:
Package p7zip-full ist not configured yet
engrampa depends on libcaja-extension1; however:
Package libcaja-extension1:amd64 is not configured yet.

dpkg: error processing package engrampa (--install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.58) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Errors were encountered while processing:
engrampa


LMDE1 3.11-2-amd64 x86_64 (64 bit, gcc: 4.8.1) MATE 1.6.1
(Live CD works fine, by the way)

kevinthefixer
Level 4
Level 4
Posts: 266
Joined: Thu Jul 23, 2015 10:36 pm

Re: Mult. erratic probs, stuck for good at caja / engrampa

Post by kevinthefixer » Mon Apr 18, 2016 9:33 pm

When you have problems upgrading, the standard cure is a clean installation of the new system.

Sydney
Level 2
Level 2
Posts: 66
Joined: Mon Oct 28, 2013 8:31 am

Re: Mult. erratic probs, stuck for good at caja / engrampa

Post by Sydney » Mon Apr 18, 2016 9:58 pm

Yeah, except I specifically chose LMDE as my OS so that I NEVER had to do that.
Also, I am not one that plays around with the OS or install / deinstall a lot.
I do not understand how there can be such issues upgrading ?

kevinthefixer
Level 4
Level 4
Posts: 266
Joined: Thu Jul 23, 2015 10:36 pm

Re: Mult. erratic probs, stuck for good at caja / engrampa

Post by kevinthefixer » Tue Apr 19, 2016 10:16 pm

Operating systems are incredibly complicated, problem could be anything. One or two incompatible apps. A slightly off-color video card, or a Bluetooth dongle you forgot was in the back USB port. Mismatched RAM cards.

Whoever told you that you would never ever have to do a clean reinstall was misguided.

Locked

Return to “LMDE 1 Archive”