LMDE Bug Reports Thread

Archived topics about LMDE 1
anticapitalista
Level 2
Level 2
Posts: 63
Joined: Thu Nov 13, 2008 7:51 pm

Re: LMDE Bug Reports Thread

Post by anticapitalista » Wed Sep 08, 2010 6:10 pm

This works if there are unmet dependencies after dpkg.

dpkg -i xxxx.deb
apt-get -f install

User avatar
tux-sven
Level 3
Level 3
Posts: 111
Joined: Sun Mar 08, 2009 6:44 am
Location: Sweden (@ Kinnekulle)

Re: LMDE Bug Reports Thread

Post by tux-sven » Wed Sep 08, 2010 6:20 pm

@kmb42vt

I tested

Code: Select all

sudo dpkg -i skype-debian_2.1.0.81-1_i386.deb
and it installed without problems. Now I have it in the menu and it starts and works fine! :D

Thanks all,
/Sven

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE Bug Reports Thread

Post by kmb42vt » Wed Sep 08, 2010 7:28 pm

tux-sven wrote:@kmb42vt

I tested

Code: Select all

sudo dpkg -i skype-debian_2.1.0.81-1_i386.deb
and it installed without problems. Now I have it in the menu and it starts and works fine! :D

Thanks all,
/Sven
Thanks for checking Sven. Glad it's working now.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

User avatar
eco2geek
Level 1
Level 1
Posts: 24
Joined: Mon Sep 28, 2009 3:22 pm
Location: Portland, Oregon

Re: LMDE Bug Reports Thread

Post by eco2geek » Wed Sep 08, 2010 10:30 pm

tux-sven wrote:I wanted the hp-toolbox and installed hplip packages (including hplip-gui). However I can't find any hp-toolbox anywhere in the menus. Finally I started hp-toolbox from a terminal window.
Nevertheless I haven't been able to install my network-connected HP Photosmart 2610 all-in-one printer. When I use hp-toolbox it finds my printer when I give it the ip-number but can not create a printer cue because I need to restart Cups first. I can not get my printer to work. :(
(a) You can enable the icon for the hp-toolbox in the Preferences menu by using the menu editor (called "Main Menu", also on the Preferences menu).
(b) Run hp-setup as root with X privileges to set up your HP printer. For example:
# sux
# hp-setup

(You'll have to install sux first. You could use "sudo" instead, or "gksu".) Then follow the prompts to set up your device. Hopefully there's a suitable CUPS driver for it!

Once that's done, run the hp-toolbox applet and you should see your printer listed.

(This isn't an LMDE bug, and AFAIK it's not a bug at all...)

User avatar
eco2geek
Level 1
Level 1
Posts: 24
Joined: Mon Sep 28, 2009 3:22 pm
Location: Portland, Oregon

Re: LMDE Bug Reports Thread

Post by eco2geek » Wed Sep 08, 2010 10:51 pm

More installer weirdness: It wrote the following in /etc/fstab:

Code: Select all

# / was on /dev/sda1 during installation
UUID=39dce7bc-28c6-4d48-a3e1-b2d48712856e /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=f5355ad1-6de9-497b-a8d4-e2abe7336d4d none            swap    sw              0       0
While I do have 3 hard drives in this box, neither of those UUIDs match any existing UUIDs, and root ("/") is on sdc3, not sda1. (Maybe that's what they were before the partitions were reformatted by the installer?) In addition, swap is on sda7, not sda5. (No wonder the system was taking so long to boot up.)

<edit> "proc" was in there twice as well.

Binx
Level 1
Level 1
Posts: 22
Joined: Fri Sep 03, 2010 3:37 am

Re: LMDE Bug Reports Thread

Post by Binx » Thu Sep 09, 2010 3:57 am

No joy for me, the live disc runs at work on a new ish pc, but not at home on my 7 year old heap, it wont boot up, it gets past all the scrolling text then stops with a black screen and a static cursor in the top left corner, i thought i would try debian itself so i did a net install, all went well but when it come to boot time the same thing happend so its not a mint problem its a my ole heap problem :lol: I'm getting a new toshiba laptop latter this year so i'll try again then :wink:

Missed
Level 2
Level 2
Posts: 74
Joined: Thu Sep 06, 2007 4:46 am
Location: New Zealand

Re: LMDE Bug Reports Thread

Post by Missed » Thu Sep 09, 2010 4:03 am

When I started up today after downloading level 3 updates last night, I have no /HOME. :(

I have no access to Nautilus, or menus or anything. Just a screen with the wallpaper, and a very minimalist task bar.

ghysmodos
Level 1
Level 1
Posts: 9
Joined: Tue Jul 06, 2010 5:01 am
Location: Berlin, Germany

Re: LMDE Bug Reports Thread

Post by ghysmodos » Thu Sep 09, 2010 4:33 am

eco2geek wrote:More installer weirdness: It wrote the following in /etc/fstab:
Mine is similar

Code: Select all

# / was on /dev/sda1 during installation
UUID=39dce7bc-28c6-4d48-a3e1-b2d48712856e /               ext3    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=f5355ad1-6de9-497b-a8d4-e2abe7336d4d none            swap   
/ was not on /sda1 (which can't be ext3, otherwise Vista would not run on it), nor was swap on sda5.

Also I cannot mount nor /sda1, /sda5 ore any other partition.

User avatar
tawan
Level 4
Level 4
Posts: 401
Joined: Thu Apr 03, 2008 2:45 am
Contact:

Re: LMDE Bug Reports Thread

Post by tawan » Thu Sep 09, 2010 5:06 am

craig10x wrote:Quick note to Mint Team regarding the difference in the font rendering of ubuntu/kubuntu to the way direct debian looks, this was a reply posted to me in the Mint Debian thread as to what he believes accounts for the difference:

I believe it's because ubuntu includes a libfreetype patch and debian does not.
In fact I notice most distros have iffy fonts compared to ubuntu and openSUSE.

I hope you can look into that and see if that will enhance the look :wink:
this saved as ~/.fonts.conf makes my fonts look beautiful

Code: Select all

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>


	<!-- Info:
	Latest version:    http://forums.gentoo.org/viewtopic-p-6183606.html#6183606
	xeffects thread:   http://forums.gentoo.org/viewtopic-t-511382.html
	Sub-pixel hinting: http://www.infinality.net/blog/?p=67
	Alternative:       https://wiki.ubuntu.com/Fonts
	http://wiki.archlinux.org/index.php/XOrg_Font_Configuration
	http://antigrain.com/research/font_rasterization/index.html
	http://freddie.witherden.org/pages/font-rasterisation/
	http://fontconfig.org/fontconfig-user.html
	Free fonts: http://www.design-by-izo.com/2010/06/07/8-excellent-fonts-for-screen-and-print/
	-->


	<!-- Crimson Text: http://www.fontsquirrel.com/fonts/download/Crimson_text -->
	<alias>
		<family>Times</family>
		<prefer>
			<family>Times New Roman</family>
			<family>Times New Roman PS</family>
			<family>Times Ten</family>
			<family>Crimson Text</family>
			<family>Cambria</family>
		</prefer>
	</alias>



	<!-- http://bugs.gentoo.org/show_bug.cgi?id=130466
	Times: http://en.wikipedia.org/wiki/Times_Roman
	Crimson Text: http://www.fontsquirrel.com/fonts/download/Crimson_text
	Linux Libertine from http://sourceforge.net/projects/linuxlibertine/
	Is important to have good, easily-readable default fonts for:
	serif, sans-serif, monospace, Courier -->
	<alias>
		<family>serif</family>
		<prefer>
			<family>Times New Roman</family>
			<family>Crimson Text</family>
			<family>Cambria</family>
			<family>DejaVu Serif</family>
			<family>Bitstream Vera Serif</family>
			<family>Liberation Serif</family>
			<family>Linux Libertine</family>
		</prefer>
	</alias>

	<!-- Corbel is ugly - don't use -->
	<alias>
		<family>sans-serif</family>
		<prefer>
			<family>DejaVu Sans</family>
			<family>Bitstream Vera Sans</family>
			<family>Verdana</family>
			<family>Liberation Sans</family>
		</prefer>
	</alias>

	<!-- Examples: http://www.codestyle.org/css/font-family/sampler-Monospace.shtml
	Used to show text email messages in Evolution, by default.
	DejaVu Sans Mono is still the best. -->
	<alias>
		<family>monospace</family>
		<prefer>
			<family>DejaVu Sans Mono</family>
			<family>Nimbus Mono L</family>
			<family>Lucida Sans Typewriter</family>
			<family>Consolas</family>
			<family>Bitstream Vera Sans Mono</family>
			<family>Liberation Mono</family>
			<family>Andale Mono</family>
		</prefer>
	</alias>

	<!-- Common web font -->
	<match target="pattern">
		<test name="family">
			<string>Helvetica</string>
		</test>
		<edit name="family" mode="prepend" binding="strong">
			<string>Helvetica World</string>
		</edit>
	</match>

	<!-- Common web font -->
	<match target="pattern">
		<test name="family">
			<string>Courier</string>
		</test>
		<edit name="family" mode="prepend" binding="strong">
			<string>Courier New</string>
		</edit>
	</match>


	<!-- Replace Arial bold with a better-looking font - looks terrible at e.g. http://digg.com
	Calibri is quite good.
	ChaletBookTT: http://www.identifont.com/
	Also try "Arial Unicode MS" or "Arial MT": http://en.wikipedia.org/wiki/Arial_Unicode
	Aeriel from http://aur.archlinux.org/packages.php?ID=21892
	i.e. ftp://ftp.fi.debian.org/pub/gentoo/distfiles/ttf-arkpandora-2.04.tgz
	Liberation Sans: https://fedorahosted.org/releases/l/i/liberation-fonts/
	PT Sans: http://www.paratype.com/public/ and http://www.fontstock.com/public/PTSans.zip
	CartoGothic Std: http://www.fontsquirrel.com/fonts/download/CartoGothic-Std
 	Cantarell: http://www.fontsquirrel.com/fonts/download/Cantarell
 	Comfortaa: http://www.fontsquirrel.com/fonts/download/Comfortaa -->
	<match target="pattern">
		<test name="family">
			<string>Arial</string>
		</test>
		<test compare="less" name="pixelsize">
			<double>12</double>
		</test>
		<edit name="family" mode="prepend" binding="strong">
			<string>Liberation Sans</string>
		</edit>
	</match>


	<!-- From:
		http://repos.archlinux.org/wsvn/packages/fontconfig/trunk/
		http://bugs.archlinux.org/task/15833
		http://bugs.freedesktop.org/show_bug.cgi?id=18002
		http://freedesktop.org/wiki/Software/poppler
		http://bugs.gentoo.org/show_bug.cgi?id=303591

		Get urw-fonts from http://koji.fedoraproject.org/koji/packageinfo?packageID=905 -->
	<match target="pattern">
		<test name="family">
			<string>ZapfDingbats</string>
		</test>
		<edit name="family" mode="prepend" binding="same">
			<string>Dingbats</string>
		</edit>
	</match>

	<!-- Based on http://bugs.gentoo.org/show_bug.cgi?id=282151 -->
	<match target="pattern">
		<test name="family">
			<string>NewCenturySchlbk</string>
		</test>
		<edit name="family" mode="append" binding="same">
			<string>Century Schoolbook L</string>
		</edit>
	</match>

	<match target="pattern">
		<test name="family">
			<string>AvantGarde</string>
		</test>
		<edit name="family" mode="append" binding="same">
			<string>URW Gothic L</string>
		</edit>
	</match>


	<match target="pattern">
		<test name="family">
			<string>ZapfChancery</string>
		</test>
		<edit name="family" mode="append" binding="same">
			<string>URW Chancery L</string>
		</edit>
	</match>


	<!-- From suse-pre-user.conf in fontconfig-2.8.0-20.1.src.rpm from http://software.opensuse.org/search?baseproject=openSUSE%3AFactory&p=1&q=fontconfig
	http://bugs.gentoo.org/show_bug.cgi?id=303591
	https://bugs.freedesktop.org/show_bug.cgi?id=27653 -->
	<match target="pattern">
		<test name="family">
			<string>symbol</string>
		</test>
		<edit name="family" mode="append" binding="strong">
			<string>OpenSymbol</string>
		</edit>
		<edit name="family" mode="append" binding="strong">
			<string>Standard Symbols L</string>
		</edit>
	</match>


	<match target="pattern" name="family">
		<test name="family" qual="any">
			<string>fixed</string>
		</test>
		<edit name="family" mode="assign">
			<string>monospace</string>
		</edit>
	</match>


<!--
   From suse-pre-user.conf in fontconfig-2.8.0-2.7.src.rpm from http://download.opensuse.org/factory/repo/src-oss/suse/src/
   OpenSUSE Bugzilla #52167 and bugzilla #246804:
   Some fonts like "Luxi Mono", and "Nimbus Mono L"
   which are intended to be monospace are not detected as
   monospace because they have a few glyphs with wrong width.
   That is of course a bug in the fonts but this is difficult
   to fix and sometimes even impossible because of license reasons.
   For most purposes it is useful to force these fonts to be
   detected as monospace because it doesn't matter much if only
   a handful of rarely used glyphs has the wrong width.
-->
	<match target="scan" >
		<test compare="contains" name="family">
			<string>Luxi Mono</string>
			<string>Nimbus Mono L</string>
		</test>
		<edit mode="assign_replace" name="spacing">
			<const>mono</const>
		</edit>
	</match>


<!-- From http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/fontconfig/current/SOURCES/20-mdv-CJK-dualwidth.conf?view=markup
	and http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/fontconfig/current/SOURCES/25-mdv-CJK-disable-hinting.conf?view=log
	https://bugs.freedesktop.org/show_bug.cgi?id=17267
	We can't hint CJK fonts well, so turn off hinting for CJK fonts.
	Some Asian fonts misadvertise themselves as monospaced when
	in fact they are dual-spaced (half and full). This makes
	FreeType very confused as it forces all widths to match.
	Undo this magic by disabling the width-forcing code.
-->
	<match target="font">
		<test target="pattern" name="lang" compare="contains">
			<string>zh-tw</string>
			<string>zh-cn</string>
			<string>ja</string>
			<string>ko</string>
		</test>
		<edit name="spacing">
			<const>proportional</const>
		</edit>
		<edit name="globaladvance">
			<bool>false</bool>
		</edit>
		<edit name="hinting" mode="assign">
			<bool>false</bool>
		</edit>
	</match>


	<!-- Reject bitmap fonts in favour of Truetype, Postscript, etc. -->
	<selectfont>
		<rejectfont>
			<pattern>
				<patelt name="scalable">
					<bool>false</bool>
				</patelt>
			</pattern>
		</rejectfont>
	</selectfont>


	<!-- http://svn.mandriva.com/cgi-bin/viewvc.cgi/packages/cooker/fontconfig/current/SOURCES/26-mdv-no-embeddedbitmap.conf?view=markup
	Japanese fonts: http://bbs.archlinux.org/viewtopic.php?id=91276
	Calibri font: http://forums.fedoraforum.org/showthread.php?p=1045807#post1045807
	Don't use bitmaps at all, because they look horrible. Enable them for individiual fonts and sizes, if needed. -->
	<match target="font">
		<edit name="embeddedbitmap" mode="assign">
			<bool>false</bool>
		</edit>
	</match>

	<!-- This is only here in case it is useful sometime.
	Example at http://www.codestyle.org/css/font-family/sampler-Monospace.shtml
	Others from 25-no-bitmap-fedora.conf at:
	http://distro.ibiblio.org/pub/linux/distributions/texstar/pclinuxos/apt/pclinuxos/2010/SRPMS.main/fontconfig-2.8.0-1pclos2010.src.rpm
	<match target="font">
		<test name="family" qual="any">
			<string>Cambria</string>
			<string>Monaco</string>
			<string>Kochi Mincho</string>
			<string>Kochi Gothic</string>
			<string>Sazanami Mincho</string>
			<string>Sazanami Gothic</string>
		</test>
		<edit name="embeddedbitmap" mode="assign">
			<bool>false</bool>
		</edit>
	</match> -->


	<!-- Ubuntu options:  lcdnone, lcddefault, lcdlight, lcdlegacy -->
	<!-- hintnone, hintslight, hintmedium, hintfull -->
	<!-- autohint off: https://bugs.launchpad.net/ubuntu/+source/fontconfig/+bug/14310/comments/14 -->
	<!-- Blurry fonts:  Try rgb, bgr, vrgb, vbgr for "rgba" -->
	<!-- Blurry:  http://forums.gentoo.org/viewtopic-p-5060979.html#5060979 -->
	<match target="font">
		<edit name="rgba" mode="assign"><const>rgb</const></edit>
		<edit name="autohint" mode="assign"><bool>false</bool></edit>
		<edit name="antialias" mode="assign"><bool>true</bool></edit>
		<edit name="hinting" mode="assign"><bool>true</bool></edit>
		<edit name="hintstyle" mode="assign"><const>hintfull</const></edit>
		<edit name="lcdfilter" mode="assign"><const>lcddefault</const></edit>
	</match>


	<!-- autohint.
	Luxi Sans - http://market-ticker.denninger.net/
	Some entries copied from http://www.infinality.net/blog/?p=10
	Arial Black: http://www.wired.com/ -->
	<match target="font">
		<test name="family" qual="any">
			<string>Arial Narrow</string>
			<string>Bitstream Vera Serif</string>
			<string>Courier10 BT</string>
			<string>DejaVu LGC Sans Mono</string>
			<string>DejaVu Sans Mono</string>
			<string>DejaVu Serif</string>
			<string>Delicious</string>
			<string>District</string>
			<string>Dutch801 Rm BT</string>
			<string>Fontin Sans</string>
			<string>FreeMono</string>
			<string>FreeSans</string>
			<string>FreeSerif</string>
			<string>Gotham Book</string>
			<string>Gotham Light</string>
			<string>Gotham Medium</string>
			<string>Helvetica</string>
			<string>Helvetica LT Std</string>
			<string>Lacuna</string>
			<string>Lucida Console</string>
			<string>Lucida Grande</string>
			<string>Lucida Sans Unicode</string>
			<string>Luxi Sans</string>
			<string>Luxi Serif</string>
			<string>MankSans</string>
			<string>Metabook-Roman</string>
			<string>MetaMedium-Roman</string>
			<string>Miriam</string>
			<string>Miso</string>
			<string>MS Mincho</string>
			<string>Myriad Pro</string>
			<string>Myriad Web Pro</string>
			<string>New Century Schoolbook</string>
			<string>Nimbus Mono L</string>
			<string>Nina</string>
			<string>Ocean Sans Std</string>
			<string>Swansea</string>
			<string>Swiss721</string>
			<string>Utopia</string>
			<string>Vegur</string>
			<string>Verdimka</string>
		</test>
		<edit name="autohint" mode="assign">
			<bool>true</bool>
		</edit>
	</match>


</fontconfig>

User avatar
Gramps50
Level 4
Level 4
Posts: 238
Joined: Sun Dec 13, 2009 1:36 am

Re: LMDE Bug Reports Thread

Post by Gramps50 » Thu Sep 09, 2010 12:32 pm

tawan wrote:
craig10x wrote:Quick note to Mint Team regarding the difference in the font rendering of ubuntu/kubuntu to the way direct debian looks, this was a reply posted to me in the Mint Debian thread as to what he believes accounts for the difference:

I believe it's because ubuntu includes a libfreetype patch and debian does not.
In fact I notice most distros have iffy fonts compared to ubuntu and openSUSE.

I hope you can look into that and see if that will enhance the look :wink:
this saved as ~/.fonts-conf makes my fonts look beautiful
A little unclear as to where to put the .fonts-conf file I have a fonts.conf file in /etc/fonts but it says not to edit it that it will get overritten that changes go into local.conf. Just al little cnfused at the moment.
LMDE ROCKS!!!

craig10x
Level 7
Level 7
Posts: 1575
Joined: Fri Jul 03, 2009 12:44 pm

Re: LMDE Bug Reports Thread

Post by craig10x » Thu Sep 09, 2010 1:00 pm

this is what i mean...look at all the various tinkering needed to make it look good...mint is a complete out of the box, newbie friendly distro....and i am sure that is the ultimate goal for the mint team with the debian version as well...sure, one can do tinkering after the fact to their personal tastes, but the main "out of the box" look needs to be up to (or better then) the normal ubuntu/kubuntu based mint standards...

also, the installer looks more technical and complicated then the standard ubuntu type of installer...i always have it wipe out what i have and completely install over (without any fancy partitioning) and you have that option on there, but not on the debian installer...so that needs to be made newbie friendly as well...

User avatar
kmb42vt
Level 5
Level 5
Posts: 973
Joined: Sun Dec 06, 2009 11:15 am
Location: Vermont
Contact:

Re: LMDE Bug Reports Thread

Post by kmb42vt » Thu Sep 09, 2010 1:21 pm

Gramps50 wrote:
tawan wrote:
craig10x wrote:Quick note to Mint Team regarding the difference in the font rendering of ubuntu/kubuntu to the way direct debian looks, this was a reply posted to me in the Mint Debian thread as to what he believes accounts for the difference:

I believe it's because ubuntu includes a libfreetype patch and debian does not.
In fact I notice most distros have iffy fonts compared to ubuntu and openSUSE.

I hope you can look into that and see if that will enhance the look :wink:
this saved as ~/.fonts-conf makes my fonts look beautiful
A little unclear as to where to put the .fonts-conf file I have a fonts.conf file in /etc/fonts but it says not to edit it that it will get overritten that changes go into local.conf. Just al little cnfused at the moment.
@Gramps50 - "~/" means your Home directory :) . You'll need to hit "Ctrl-h" in Nautilus in order to see the hidden folders and files as the ".fonts-config" will end up as one of those hidden files as well.
"Humph. Choice, it is the quintessential Linux delusion, simultaneously the source of it's greatest strength, and it's greatest weakness." (All apologies to The Architect)

Locked

Return to “LMDE 1 Archive”