How Do I Enable Compiz in LMDE

Archived topics about LMDE 1
Locked
User avatar
gqpolo
Level 2
Level 2
Posts: 85
Joined: Sun Jun 06, 2010 11:23 am
Location: Orlando, Florida

How Do I Enable Compiz in LMDE

Post by gqpolo » Sun Oct 03, 2010 2:19 pm

Please??
HP DV5-5120, AMD Turion 64 ML-32, ATI M200, 1GB RAM, Mint 9 LXDE


User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: How Do I Enable Compiz in LMDE

Post by zombie » Sun Oct 03, 2010 2:37 pm

http://wiki.debian.org/Compiz

You can probably skip the part about editing the xorg.conf file.
It worked for me...

User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: How Do I Enable Compiz in LMDE

Post by darethehair » Sun Oct 03, 2010 4:01 pm

I am confused by this: LMDE comes with a 'Preferences' option named 'CompizConfig Settings Manager', with a bunch of clickable options inside of it. Does this mean that Compiz is already present, even though I did not install anything (that I recall)?

Thanks for clarification of this issue. I have a netbook, and I am not sure if I 'should' activate Compiz, owing to the speed/battery hit that it would create -- but it still might be interesting to see how it looks.
There is nothing more dangerous than a bored cat.

User avatar
zombie
Level 3
Level 3
Posts: 131
Joined: Wed Oct 31, 2007 4:45 pm
Location: Longmont Colorado

Re: How Do I Enable Compiz in LMDE

Post by zombie » Sun Oct 03, 2010 4:34 pm

@darethehair: Try to run the command "compiz --replace" in the terminal. If everything else is in place it should start Compiz.

User avatar
darethehair
Level 4
Level 4
Posts: 239
Joined: Sun Mar 08, 2009 2:22 pm
Location: Morden Manitoba Canada
Contact:

Re: How Do I Enable Compiz in LMDE

Post by darethehair » Mon Oct 04, 2010 2:08 pm

zombie wrote:@darethehair: Try to run the command "compiz --replace" in the terminal. If everything else is in place it should start Compiz.
Nope, it did not work. Ultimately, I was missing some necessary (?) packages:
  • compiz
    compiz-fusion-plugins-main
    libgl1-mesa-dri
Other optional (?) pieces I installed:
  • compiz-fusion-plugins-extra
    fusion-icon
The pieces that LMDE installed by default (?):
  • compizconfig-settings-manager
    compiz-gnome
    compiz-gtk
I am not sure why some -- but not all -- pieces of 'compiz' were already present in the default (?) LMDE install, but it works great now.

BONUS: As a side-benefit, my 'GoogleEarth' app now runs properly, rather than crashing with a 'signal 11' right off the bat!
There is nothing more dangerous than a bored cat.

Locked

Return to “LMDE 1 Archive”