Page 1 of 1

Hibernate [SOLVED]

Posted: Wed Oct 20, 2010 5:05 pm
by cecar
Hi all.

I used mint 9 Gnome before and just installed Debian edition. There is no hibernate button when i click on quit in the menu, just suspend. Is there not a hibernate function in LMDE? Or is there something wrong with my swap partition maybe? I have set up a swap of 4GB and have 3GB or RAM. How can i check if the system uses the SWAP partition?

Thanks...

Re: Hibernate

Posted: Wed Oct 20, 2010 5:56 pm
by asymmetros
By gparted (swap on pr swap off)
By System Monitor

There is a file /etc/fstab in your system. It shows among other things which partitions are somehow "been activated" every time you start your pc.
That file must contains (somewhere in the end) a line like that
/dev/sdax none swap sw 0 0

x stands as the number of your swap partition.

If that kind of info isnt there you have to add it manually.

You can open this file with gedit or you favorite editor. Be careful though to not delete something important.

Re: Hibernate

Posted: Wed Oct 20, 2010 6:16 pm
by cecar
THANK YOU very much asymmetros. You are a true hero! :)

Turned out the swap partition was not mounted. Now the button is there and i have a swap partition after editing the fstab file..

Re: Hibernate [SOLVED]

Posted: Wed Feb 02, 2011 11:45 am
by digitsm
Really thank you asymmetros
I had the same problem with hibernating my LMDE x64 & your solution worked for me too.
Plus you had a very small mistake in typing the fstab entry:
"/dev/sdax none swap sw 0 0" -> "/dev/sdax none swap rw,errors=remount-ro 0 0"
Because I feel responsible of other people because I used this solution, I'll put some screenshots below, hope to help someone:

If you have the problem above, you should check the file /etc/fstab in your system. It may be something like the image[1].
Image[1]:http://cid-dba902e0ed8b0663.office.live ... 0fstab.png
Image


So then you should modify that file with superuser privilege (using sudo) to make it like image[2].
Image[2]:http://cid-dba902e0ed8b0663.office.live ... 0fstab.png
Image

Re: Hibernate

Posted: Wed Feb 02, 2011 1:09 pm
by digitsm
I thought my problem solved, but after I tested the hibernate button it didn't work. Actually it did a shot down & after resuming it started over from begining & nothing resumed.
Can anyone help?

I have 4GB RAM on my dell laptop with 4.19GB swap on logical sda8.
Should I increase my swap partition?

Re: Hibernate

Posted: Wed Feb 02, 2011 6:05 pm
by digitsm
After I press the Hibernate button from menu in LMDE x64 It shows the messages below in a black screen (I don't know what it is called):

Code: Select all

[     69.238720] btusb_intr_complete: hci0 urb ffff8801143d4e40 failed to resubmit (1)
[     69.239721] btusb_bulk_complete: hci0 urb ffff8801143d4540 failed to resubmit (1)
[     69.240721] btusb_bulk_complete: hci0 urb ffff8801143d4f00 failed to resubmit (1)
[     71.216086] ata4.01: failed to resume link (SControl 0)
_
[/size]
Then the cursor blinks for some seconds and the my laptop shutdown. Then when I turn the computer on and go to the appropriate linux kernel the messages below would be shown:

Code: Select all

Loading, please wait...
[     3.540008] ata4.01: failed to resume link (SControl 0)
INIT: version 2.88 booting
Starting the hotplug events dispatcher: udevd.
.
.
.
[/size]

I've installed nvidia-glx (v195.36.31) which works fine beside the compiz.

So do you have any suggestion with the full information above?