LMDE - Kernel update and my DVB-T Stick fails after.

Archived topics about LMDE 1 and LMDE 2
Level 1
Level 1
Posts: 6
Joined: Mon Oct 11, 2010 5:46 pm

LMDE - Kernel update and my DVB-T Stick fails after.

Post by JariTapio »


I have FujTech AF9015 TV USB Stick, stick has an kernel support, and i have used stick with Ubuntu9/10 Mint9 and now on LMDE.
I have just complited an new install of LMDE, my TV STICK worked ok after i installed LMDE i even recorded an movie, then i complited an
"sudo aptitude dist-upgrade" on console and my Kernel updated, and now my firmware wont load anymore, what i can do to make my TV STICK to operate again ??

[ 8.518062] dvb-usb: found a 'Afatech AF9015 DVB-T USB2.0 stick' in cold state, will try to load a firmware
[ 8.518071] usb 1-3: firmware: requesting dvb-usb-af9015.fw
[ 8.604172] dvb-usb: did not find the firmware file. (dvb-usb-af9015.fw) Please see linux/Documentation/dvb/ for more details on firmware-problems. (-2)
[ 8.604266] dvb_usb_af9015: probe of 1-3:1.0 failed with error -2

This is very big issue to me, how to set an firmware to new kernel, with old kernel my stick worked right out of the box.

WIth MINT9 i needed some nonfree firmware packed and xine-all, what i need with LMDE ??



User avatar
Level 4
Level 4
Posts: 272
Joined: Thu Jul 29, 2010 6:03 am
Location: Cheltenham, UK

Re: LMDE - Kernel update and my DVB-T Stick fails after.

Post by ukbrian »

Hi JariTapio this link might help you http://rende.se/pmwiki/index.php?n=Main.DVB-USB-af9015
Download and copy the firmware file to /lib/firmware and then reboot

There's also a big thread on the ubuntu forum about this tuner, the last 3 pages are the ones to read but they talk about recompiling the kernal which is outside my comfort zone. http://ubuntuforums.org/showthread.php?t=606487&page=16
good luck


Return to “LMDE Archive”