LMDE XFCE: touchpad does not emulate clicking

Archived topics about LMDE 1
Locked
aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

LMDE XFCE: touchpad does not emulate clicking

Post by aljoriz » Thu Mar 24, 2011 5:54 am

I have installed LMDE XFCE 32bit on my Asus 1005ha EEEpc. My problem is the touch pad can emulate a click by tapping on the touch pad.

Any advise will be appreciated.

User avatar
richyrich
Level 19
Level 19
Posts: 9075
Joined: Mon May 04, 2009 8:31 pm

Re: LMDE XFCE: touchpad does not emulate clicking

Post by richyrich » Thu Mar 24, 2011 7:44 am

Is your trackpad listed in Settings->Mouse ?

If not, try the following terminal command :

Code: Select all

xinput list
Does it show your trackpad ? What brand and model ? ALPS ?

aljoriz
Level 4
Level 4
Posts: 274
Joined: Wed Dec 23, 2009 12:50 pm
Location: Cebu City, Philippines

Re: LMDE XFCE: touchpad does not emulate clicking

Post by aljoriz » Thu Mar 24, 2011 8:28 am

thanks for the reply. It took me 15min to google: "debian xfce touchpad" and read through every result and here is the solution

Code: Select all

sudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf
copy-paste the following over the entries:
Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "VertEdgeScroll" "1"
EndSection

Save then go back to the terminal and type sudo reboot

on the reboot all will be well.

MODS: Pls marked as solved

User avatar
Troken
Level 3
Level 3
Posts: 109
Joined: Mon Nov 16, 2009 3:56 am

Re: LMDE XFCE: touchpad does not emulate clicking

Post by Troken » Tue Mar 29, 2011 12:53 pm

aljoriz wrote:thanks for the reply. It took me 15min to google: "debian xfce touchpad" and read through every result and here is the solution
...

MODS: Pls marked as solved
Thank you, it works as a charm! Solved indeed.

travlemon
Level 2
Level 2
Posts: 54
Joined: Fri Mar 05, 2010 2:18 pm

Re: LMDE XFCE: touchpad does not emulate clicking

Post by travlemon » Thu Oct 13, 2011 6:36 pm

aljoriz wrote:thanks for the reply. It took me 15min to google: "debian xfce touchpad" and read through every result and here is the solution

Code: Select all

sudo gedit /usr/share/X11/xorg.conf.d/50-synaptics.conf
copy-paste the following over the entries:
Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "VertEdgeScroll" "1"
EndSection

Save then go back to the terminal and type sudo reboot

on the reboot all will be well.

MODS: Pls marked as solved
I would just like to confirm that this fix worked for me as well. Thanks so much!
For my video tutorials, check out:
http://www.youtube.com/webhunterification

timbo
Level 1
Level 1
Posts: 47
Joined: Sun Oct 09, 2011 5:06 pm

WARNING

Post by timbo » Fri Nov 18, 2011 7:20 pm

I do not know why, BUT after I applied those changes on my Thinkpad x220, boot into the system did not work. I have reverted the file to its original state via a Live environment.

So be cautious.

travlemon
Level 2
Level 2
Posts: 54
Joined: Fri Mar 05, 2010 2:18 pm

Re: WARNING

Post by travlemon » Fri Nov 18, 2011 7:30 pm

timbo wrote:I do not know why, BUT after I applied those changes on my Thinkpad x220, boot into the system did not work. I have reverted the file to its original state via a Live environment.

So be cautious.
Now that you mention this, I had the same problem. The fix worked the first time, but I had to reinstall my system for various reasons. I tried to apply it again, and I couldn't get it to boot. Only thing I did differently the second time was type the data into the file manually, rather than copy and paste it.
For my video tutorials, check out:
http://www.youtube.com/webhunterification

Zenbaku
Level 1
Level 1
Posts: 1
Joined: Sun Apr 03, 2011 11:59 am

Re: LMDE XFCE: touchpad does not emulate clicking

Post by Zenbaku » Sat Nov 19, 2011 11:16 pm

Many thanks for the solution, I just copy the part that involved the touch, and no the one relating to vertical edge or something. (Maybe that part caused the boot problem for the other users)

Thanks!

genaroarismendi
Level 1
Level 1
Posts: 1
Joined: Mon Feb 13, 2012 4:21 am

Re: WARNING

Post by genaroarismendi » Mon Feb 13, 2012 4:31 am

Hi, I have the problem with the touchpad and I tryed to fix it using this post, however, something were wrong during my procedure application and now y have the following problem when my computer starts: startpar: service(s) returned failure: rc.local ... failed!

Please note that I errased ALL the content of the file and pasted:

Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "VertEdgeScroll" "1"
EndSection

I would like to restore the original content of file, or do something that bring my computer back! [I'm new in all this linux stuff]

Thanks a lot in advance!
timbo wrote:I do not know why, BUT after I applied those changes on my Thinkpad x220, boot into the system did not work. I have reverted the file to its original state via a Live environment.

So be cautious.

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE XFCE: touchpad does not emulate clicking

Post by xircon » Mon Feb 13, 2012 3:29 pm

This mine, try copying and pasting:

Code: Select all

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
        Option "TapButton1" "1"    # tap to click
        Option "VertEdgeScroll" "1"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
#       MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection
Think the indentation is important.
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

tip_1
Level 1
Level 1
Posts: 1
Joined: Thu Feb 16, 2012 2:28 am

Re: LMDE XFCE: touchpad does not emulate clicking

Post by tip_1 » Thu Feb 16, 2012 2:33 am

Thanks so much.. It works well on my Debian Wheezy..

shailK
Level 1
Level 1
Posts: 1
Joined: Mon Mar 05, 2012 1:42 am

Re: LMDE XFCE: touchpad does not emulate clicking

Post by shailK » Mon Mar 05, 2012 2:02 am

Ya I tried in Debian Wheezy too. It works.

Locked

Return to “LMDE 1 Archive”