LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Archived topics about LMDE 1
Locked
wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by wayne128 » Mon May 07, 2012 8:35 pm

oh. haha, mixed up, this is another partition tracking testing. sorry :lol:
may be that is how gnome get into xfce :lol: :lol:
better get back to SID partitions.
here is the upgrade..

Code: Select all

The following packages will be upgraded:
  acpi-support-base acpid alsa-utils apache2.2-bin aptdaemon aptitude
  aptitude-doc-en baobab bash bind9-host bluez bogofilter bogofilter-bdb
  brasero brasero-common btrfs-tools busybox cdrdao colord console-setup
  console-setup-linux coreutils cpp-4.4 cryptsetup cups-pdf curl dbus dbus-x11
  debconf debconf-i18n debianutils diffutils discover dmidecode dnsmasq-base
  dnsutils dpkg dpkg-dev dselect e2fslibs e2fsprogs evince fakeroot fancontrol
  file file-roller fontconfig fontconfig-config fonts-droid fonts-opensymbol
  foomatic-db foomatic-filters ftp fuse fuse-utils g++-4.4 gawk gcalctool
  gcc-4.4 gcc-4.4-base gconf-defaults-service gconf-service gconf2
  gconf2-common geoip-database ghostscript ghostscript-cups ghostscript-x gimp
  gir1.2-atk-1.0 gir1.2-clutter-gst-1.0 gir1.2-evince-3.0 gir1.2-freedesktop
  gir1.2-gdkpixbuf-2.0 gir1.2-glib-2.0 gir1.2-gtksource-3.0 gir1.2-pango-1.0
  gir1.2-peas-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 gir1.2-vte-2.90
  glib-networking glib-networking-common glib-networking-services
  gnome-desktop-data gnome-desktop3-data gnome-dictionary gnome-doc-utils
  gnome-icon-theme gnome-icon-theme-symbolic gnome-media gnome-nettool
  gnome-search-tool gnome-session-bin gnome-session-canberra
  gnome-session-common gnome-settings-daemon gnome-sushi gnome-utils-common
  grep groff-base grub-common grub-pc grub-pc-bin grub2-common
  gsettings-desktop-schemas gstreamer0.10-gconf gstreamer0.10-nice
  gstreamer0.10-plugins-bad gstreamer0.10-plugins-good
  gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gtk2-engines
  gtk2-engines-aurora gtk2-engines-murrine gtk3-engines-unico gucharmap
  guile-1.8-libs gzip hal hdparm hunspell-en-us imagemagick imagemagick-common
  info initramfs-tools initscripts insserv install-info iproute
  isc-dhcp-client isc-dhcp-common iso-codes keyboard-configuration libaacs0
  libao-common libao4 libapr1 libapt-pkg-perl libarchive12 libatk1.0-0
  libatk1.0-data libaudio2 libbind9-80 libbluetooth3 libbluray1
  libbrasero-media3-1 libburn4 libc-bin libc-dev-bin libc6 libc6-dev
  libc6-i686 libcaca0 libcairo-gobject2 libcairo-perl libcairo2
  libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra0
  libccid libclutter-gst-1.0-0 libcolord1 libcomerr2 libcroco3 libcryptsetup4
  libcrystalhd3 libcurl3 libcurl3-gnutls libcurl3-nss libcwidget3 libdbus-1-3
  libdc1394-22 libdiscover2 libdjvulibre-text libdjvulibre21 libdns81
  libdpkg-perl libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2
  libevent-2.0-5 libevince3-3 libexpat1 libfaad2 libfontconfig1 libfontenc1
  libfreetype6 libfribidi0 libfs6 libfuse2 libgarcon-1-0 libgarcon-common
  libgcc1 libgconf-2-4 libgconf2-4 libgd2-xpm libgdata-common libgdata13
  libgdict-1.0-6 libgdiplus libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common
  libgfortran3 libgimp2.0 libgirepository-1.0-1 libgjs0b libglib2.0-data
  libglibmm-2.4-1c2a libgmime-2.6-0 libgnome-desktop-2-17 libgnome-desktop-3-2
  libgnome-keyring-common libgnome-keyring0 libgnome-speech7
  libgnomekbd-common libgnomekbd7 libgnutls26 libgomp1 libgphoto2-2
  libgphoto2-port0 libgs9 libgs9-common libgsf-1-114 libgsf-1-common libgsm1
  libgstreamer-plugins-bad0.10-0 libgtksourceview-3.0-0
  libgtksourceview-3.0-common libgtop2-7 libgtop2-common libgucharmap-2-90-7
  libgupnp-1.0-4 libhal-storage1 libhal1 libhtml-parser-perl libhttp-date-perl
  libhyphen0 libice6 libicu48 libidn11 libilmbase6 libimobiledevice2
  libio-socket-ssl-perl libisc83 libisccc80 libisccfg82 libisofs6 libjack0
  libkeyutils1 liblcms1 liblocale-ruby1.8 liblua5.1-0 liblwres80 libmagic1
  libmodplug1 libmtp-common libmtp-runtime libmtp9 libmusicbrainz3-6
  libnautilus-extension1a libncurses5 libncursesw5 libneon27-gnutls
  libnet-ssleay-perl libnice10 libnm-glib-vpn1 libnm-glib4 libnm-gtk-common
  libnm-gtk0 libnm-util2 libnotify-bin libnotify4 libofa0 libopenal-data
  libopenal1 libopencore-amrnb0 libopencore-amrwb0 libopenexr6 libopenjpeg2
  libopenraw1 liborc-0.4-0 libp11-kit0 libpackagekit-glib2-14 libpango1.0-0
  libparted0debian1 libpci3 libpciaccess0 libpcre3 libpcsclite1 libpeas-1.0-0
  libpeas-common libpng12-0 libpulse-mainloop-glib0 libpulse0 libpython2.7
  libquadmath0 libquvi-scripts libquvi7 libraptor1 libraptor2-0
  libregexp-assemble-perl libreoffice libreoffice-base libreoffice-base-core
  libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw
  libreoffice-emailmerge libreoffice-filter-mobiledev libreoffice-gnome
  libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-report-builder-bin libreoffice-style-tango libreoffice-writer
  librsvg2-2 librsvg2-common libsamplerate0 libsane libsane-common
  libschroedinger-1.0-0 libsdl1.2debian libsensors4 libsepol1
  libservlet2.5-java libsigc++-2.0-0c2a libslang2 libsm6 libsoup-gnome2.4-1
  libsoup2.4-1 libspandsp2 libsqlite3-0 libss2 libssh2-1 libssl1.0.0
  libstdc++6 libstdc++6-4.4-dev libsvga1 libtag1-vanilla libtag1c2a libtagc0
  libtasn1-3 libtasn1-3-bin libtdb1 libtelepathy-glib0 libtextcat-data
  libtextcat0 libthunarx-2-0 libtiff4 libtinfo5 libtotem-plparser17 libtotem0
  libts-0.0-0 libuniconf4.6 libupower-glib1 liburi-perl libusb-1.0-0 libv4l-0
  libv4lconvert0 libva-x11-1 libva1 libvdpau1 libvo-aacenc0 libvo-amrwbenc0
  libvorbis0a libvorbisenc2 libvorbisfile3 libvte-2.90-9 libvte-2.90-common
  libwavpack1 libwnck-3-0 libwnck-3-common libwpd-0.9-9 libwps-0.2-2
  libwvstreams4.6-base libwvstreams4.6-extras libxau-dev libxau6 libxaw7
  libxcb-composite0 libxcb-dri2-0 libxcb-randr0 libxcb-render0 libxcb-shape0
  libxcb-shm0 libxcb-xfixes0 libxcb-xv0 libxcb1 libxcb1-dev libxcursor1
  libxdmcp-dev libxdmcp6 libxext-dev libxext6 libxi6 libxml2 libxml2-utils
  libxmu6 libxmuu1 libxpm4 libxt6 libxv1 libxvmc1 libyelp0 libzbar0
  libzvbi-common libzvbi0 linux-headers-3.2.0-2-486
  linux-headers-3.2.0-2-common linux-image-3.2.0-2-486 linux-kbuild-3.2
  linux-libc-dev lm-sensors locales lsb-base lsb-release lsof make man-db mawk
  mobile-broadband-provider-info modemmanager module-init-tools mousetweaks
  multiarch-support nautilus nautilus-data nautilus-sendto ncurses-base
  ncurses-bin network-manager network-manager-gnome network-manager-pptp
  network-manager-pptp-gnome obex-data-server openssh-client openssl os-prober
  oss-compat packagekit packagekit-backend-aptcc pciutils pcscd
  printer-driver-all printer-driver-c2esp printer-driver-foo2zjs pulseaudio
  pulseaudio-esound-compat pulseaudio-module-gconf pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python-aptdaemon
  python-decorator python-egenix-mxdatetime python-egenix-mxtools python-gdata
  python-gdbm python-gi python-gi-cairo python-gobject python-gobject-2
  python-httplib2 python-libxml2 python-mako python-numpy python-packagekit
  python-simplejson python-software-properties python-uno python2.7
  python2.7-minimal python3 python3-minimal python3.2 python3.2-minimal
  rsyslog samba-common-bin sane-utils simple-scan software-properties-gtk
  synaptic sysv-rc sysvinit sysvinit-utils tasksel tasksel-data thunar
  thunar-data thunar-volman totem totem-common totem-plugins tsconf
  ttf-opensymbol ucf udisks ufraw-batch ufw unattended-upgrades uno-libs3
  unzip upower ure usbutils vino wajig wget whois wvdial x11proto-core-dev
  x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xchat xchat-common
  xfce4-mixer xfce4-power-manager xfce4-power-manager-data
  xfce4-power-manager-plugins xserver-xorg-input-evdev
  xserver-xorg-input-synaptics xserver-xorg-video-ark xserver-xorg-video-ati
  xserver-xorg-video-cirrus xserver-xorg-video-i128 xserver-xorg-video-intel
  xserver-xorg-video-mach64 xserver-xorg-video-radeon xserver-xorg-video-vesa
  xserver-xorg-video-vmware yelp yelp-xsl zenity zenity-common

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by wayne128 » Mon May 07, 2012 8:50 pm

on Debian sid , cannot d.u with this..Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.jp.debian.org_debian_dists_unstable_main_i18n_Translation-en Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.jp.debian.org_debian_dists_unstable_non-free_i18n_Translation-en Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by zerozero » Mon May 07, 2012 9:06 pm

wayne128 wrote:oh. haha, mixed up, this is another partition tracking testing. sorry :lol:
:mrgreen: :lol: too many systems installed :lol:
Image

[ bliss of ignorance ]

craigevil
Level 5
Level 5
Posts: 554
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by craigevil » Mon May 07, 2012 9:12 pm

wayne128 wrote:on Debian sid , cannot d.u with this..Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.jp.debian.org_debian_dists_unstable_main_i18n_Translation-en Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.jp.debian.org_debian_dists_unstable_non-free_i18n_Translation-en Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
Happens. Just re-run apt-get update.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by wayne128 » Mon May 07, 2012 9:15 pm

craigevil wrote: Happens. Just re-run apt-get update.
craig, yes, I did it many times, same error, still stuck..

EDIT. change repos to .au, try again, still stuck.

Code: Select all

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/ftp.au.debian.org_debian_dists_unstable_main_i18n_Translation-en  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.
This is the old running Debian Sid, since Feb2011. Hope it will survive.
May be need some other idea :idea: :!:

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by GregE » Tue May 08, 2012 12:53 am

Wayne,

It appears to be the Australian English translations from English. You can probably ignore the error and upgrade anyway. Another, and better, approach is to temporarily switch to the main servers.

wayne128
Level 10
Level 10
Posts: 3412
Joined: Tue Jul 13, 2010 12:15 am

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by wayne128 » Tue May 08, 2012 2:39 am

GregE wrote:Wayne,

It appears to be the Australian English translations from English. You can probably ignore the error and upgrade anyway. Another, and better, approach is to temporarily switch to the main servers.
Greg,
When this happens, it will stop and give me # prompt, thus I cannot proceed to d.u.

after few more trying, successful finally :mrgreen:

Code: Select all

Fetched 631 MB in 31min 28s (334 kB/s)                                         
Retrieving bug reports... Done
Parsing Found/Fixed information... Done
grave bugs of shotwell (0.11.6-2 -> 0.12.2-1) <unfixed>
 #670644 - shotwell: Segfault once a photo is selected
grave bugs of libnss3-1d (3.13.3-1 -> 3.13.4-1) <unfixed>
 #670882 - libnss3-1d: Iceweasel says that various sites use an invalid security certificate
Summary:
 shotwell(1 bug), libnss3-1d(1 bug)
take the risk to d.u. and deal with those errors later


EDIT...
survived!! :mrgreen: did not use shortwell so ignore for time being...
read this from rhodry and thought to copy here
@Craigevil has been "around the block" many a time with Debian. His guides are always good value!

Be patient!
rhodry.
(brought to you by Sid - the most stable unstable!! :) )

craigevil
Level 5
Level 5
Posts: 554
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by craigevil » Tue May 08, 2012 12:05 pm

I run apt-get dist-upgrade at least daily sometimes twice a day (morning/evening). The longer you wait the more problems you can run into. I think it helps that I am not using Gnome which has a habit of being broken in sid, also helps that I am not using nvidia or Ati/fglrx.
Having both apt-listbugs and apt-listchanges installed is a must. 8)

It sometimes helps to check the aptosid and siduction forums, not as much as it used to when sidux was popular, but you still can find upgrade warnings and fixes.

My d-u for this a.m.:

Code: Select all

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  mysql-server-core-5.1
The following NEW packages will be installed:
  libaio1 mysql-server-core-5.5
The following packages will be upgraded:
  grep libpci3 libperl5.14 mysql-common pciutils perl perl-base perl-modules
8 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B/16.2 MB of archives.
After this operation, 8,881 kB of additional disk space will be used.
Went through without any problems.

Code: Select all

$ inxi -Sr
System:    Host: debian Kernel: 3.3.0-trunk-486 i686 (32 bit) Desktop: KDE 4.7.4 Distro: Debian GNU/Linux wheezy/sid
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://ftp.us.debian.org/debian/ unstable main contrib non-free                                               
           deb http://ftp.us.debian.org/debian/ experimental main contrib non-free                                           
           deb http://www.debian-multimedia.org/ unstable main non-free                                                      
           deb http://dl.google.com/linux/chrome/deb/ stable main                                                            
           deb http://dl.google.com/linux/musicmanager/deb/ stable main                                                      
           deb http://download.jitsi.org/deb/ unstable/                       
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

User avatar
Regulus74
Level 2
Level 2
Posts: 61
Joined: Mon Oct 03, 2011 6:07 pm
Location: Mantova - Italy

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by Regulus74 » Thu May 10, 2012 12:16 pm

Debian sid with gnome-shell only (I don't have cinnamon, mate, etc.), today it's all ok :mrgreen:
Arch Linux user

User avatar
dcihon
Level 4
Level 4
Posts: 286
Joined: Sun Aug 07, 2011 2:15 pm
Location: Florissant, MO USA

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by dcihon » Fri May 11, 2012 11:17 am

This looks bad:

Code: Select all

danc-linux-mint-debian ~ # apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  baobab brasero debian-multimedia-keyring evince file-roller gcalctool gconf-editor gdebi gecko-mediaplayer gir1.2-caribou-1.0
  gir1.2-gkbd-3.0 gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-panelapplet-4.0 gir1.2-vte-2.90 gnome-applets
  gnome-bluetooth gnome-dictionary gnome-disk-utility gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring gnome-media
  gnome-mplayer gnome-nettool gnome-panel gnome-power-manager gnome-search-tool gnome-session-bin gnome-session-canberra
  gnome-settings-daemon gnome-system-log gnome-system-monitor gnome-system-tools gnome-themes-standard gnome-tweak-tool
  gnome-user-share gthumb gtk3-engines-unico gucharmap libavahi-ui-gtk3-0 libbrasero-media3-1 libcanberra-gtk3-0 libcaribou0
  libedataserverui-3.0-1 libepc-ui-1.0-3 libevince3-3 libgail-3-0 libgcr-3-1 libgdict-1.0-6 libgdu-gtk0 libgmtk0 libgnome-bluetooth8
  libgnome-control-center1 libgnome-desktop-3-2 libgnome-media-profiles-3.0-0 libgnomekbd7 libgtk-3-0 libgtk-3-bin libgtkmm-3.0-1
  libgtksourceview-3.0-0 libgucharmap-2-90-7 libgweather-3-0 libnautilus-extension1a libnm-gtk0 libpanel-applet-4-0 libunique-3.0-0
  libvte-2.90-9 libwnck-3-0 mint-meta-codecs mousetweaks murrine-themes nautilus-open-terminal network-manager-gnome
  network-manager-pptp-gnome notification-daemon notify-osd policykit-1-gnome python-aptdaemon.gtk3widgets remmina remmina-plugin-rdp
  remmina-plugin-vnc seahorse simple-scan software-properties-gtk system-config-printer transmission-gtk vino
The following NEW packages will be installed:
  mplayer2
The following packages have been kept back:
  chromium chromium-inspector libobrender27 libreoffice libreoffice-base libreoffice-base-core libreoffice-calc libreoffice-core
  libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-writer mplayer python-uno
  vlc-nox vlc-plugin-notify vlc-plugin-pulse xfce4-diskperf-plugin
The following packages will be upgraded:
  conky deb-multimedia-keyring gthumb-data gvfs gvfs-backends gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs krb5-locales
  libattr1 libgssapi-krb5-2 libgtk-3-common libgtksourceview-3.0-common libio-socket-ssl-perl libk5crypto3 libkrb5-3 libkrb5support0
  libobt0 libpcap0.8 openbox python-gi python-gi-cairo python-gobject python-numpy python-xapian
27 upgraded, 1 newly installed, 89 to remove and 20 not upgraded.
Need to get 27.1 MB of archives.
After this operation, 177 MB disk space will be freed.
Do you want to continue [Y/n]? 
Kernel 3.2.0-3-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
ATI - Tracking - Testing

autocrosser
Level 4
Level 4
Posts: 436
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by autocrosser » Sat May 12, 2012 9:49 pm

Just a "Heads-up" note from Experimental---Initscripts, Sysv-rc,Sysvinit & Sysvinit-Utils were just upgraded from -22.1 to -24. There is a "new" section in /lib/init/mount-functions.sh that MUST NOT have /run as a symlink to /var/run---it is now the reverse--make sure you have a symlink from /var/run to /run or you will loose keyboard, mouse & ALSA...the fix is simple, either boot from another OS or a Live-CD & recreate /run, then populate it with the contents of /var/run--then symlink /var/run to /run & you are good to go. I remember about a year or so ago that there was a "fix" that symlinked /run--so if your install is more than 1 or so years old....you might check before this upgrade.
Last edited by autocrosser on Sun May 13, 2012 10:05 am, edited 1 time in total.
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230

Brian49
Level 5
Level 5
Posts: 611
Joined: Thu Oct 29, 2009 2:27 pm

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by Brian49 » Sun May 13, 2012 4:38 am

autocrosser - I ran into that problem after upgrading those packages. I decided to restore my system to its previous state and wait for the upgrades to move into Unstable (if they ever will). I already have a symlink from /var/run to /run, but evidently it didn't save me.

autocrosser
Level 4
Level 4
Posts: 436
Joined: Tue Dec 28, 2010 5:00 pm
Location: Eagle Point, Oregon

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by autocrosser » Sun May 13, 2012 10:13 am

Sorry to hear that Brian---The fix is rather easy--it just took the developer & I a bit of time to sleuth it out...... So the -24 version will be moving into Unstable/Testing rather soon..there was another problem with the bootclean script that might trip people up also... The bug report is: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=669949 for anyone wanting to follow the trail. The developer is looking into the problem a bit more...it "should" have worked the way it was--but didn't...O-the Joys of Triage.... ;)
"Let's nobody be dead today----Looks very bad on my report" One of my favorite lines from AVATAR :)
Linux User# 395230

craigevil
Level 5
Level 5
Posts: 554
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by craigevil » Mon May 14, 2012 1:00 am

Do not d-u today as ceni and ifupdown would be removed. The problem is the new version of netbase.

netbase : Breaks: ifupdown (< 0.7~rc1) but 0.7~alpha5+really0.6.16 is installed.

Code: Select all

The following packages will be REMOVED:
  ceni ifupdown
The following packages will be upgraded:
  dctrl-tools debhelper emacsen-common kmod libc-ares2 libio-socket-ssl-perl libkmod2 libmpg123-0 libmsn0.3
  module-init-tools netbase
11 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.

Code: Select all

 aptitude full-upgrade -s
The following packages will be upgraded: 
  bash-completion dctrl-tools debhelper emacsen-common initscripts kmod libc-ares2 libio-socket-ssl-perl libkmod2 
  libmpg123-0 libmsn0.3 module-init-tools netbase{b} sysv-rc sysvinit sysvinit-utils 
The following packages are RECOMMENDED but will NOT be installed:
  libio-socket-inet6-perl 
16 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/2,150 kB of archives. After unpacking 474 kB will be freed.
The following packages have unmet dependencies:
 netbase : Breaks: ifupdown (< 0.7~rc1) but 0.7~alpha5+really0.6.16 is installed.
The following actions will resolve these dependencies:

     Remove the following packages:
1)     ceni                        
2)     ifupdown                    



Accept this solution? [Y/n/q/?] q
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by xircon » Tue May 15, 2012 4:42 am

Todays updates break:

Themes - Cinnamon & Gnome revert to that lovely Win95 look.

Icons - revert to the ugly Gnome default.

Touchpad - Scrolling and tap to click lost, managed to get back with

Code: Select all

synclient tapbutton1=1 && synclient vertedgescroll=1
Todays updates:

Code: Select all

Start-Date: 2012-05-15  08:27:40
Commandline: /usr/sbin/synaptic
Install: libx264-123:amd64 (0.123.2189+git35cf912-1, automatic), hardening-includes:amd64 (2.1, automatic)
Upgrade: gnome-session-bin:amd64 (3.4.1-1, 3.4.2-1), gstreamer0.10-plugins-ugly:amd64 (0.10.19-2, 0.10.19-2+b1), libnm-util2:amd64 (0.9.4.0-3, 0.9.4.0-4), gnome-session:amd64 (3.4.1-1, 3.4.2-1), gnome-session-common:amd64 (3.4.1-1, 3.4.2-1), libnm-glib-dev:amd64 (0.9.4.0-3, 0.9.4.0-4), gnome-session-fallback:amd64 (3.4.1-1, 3.4.2-1), network-manager:amd64 (0.9.4.0-3, 0.9.4.0-4), network-manager-dev:amd64 (0.9.4.0-3, 0.9.4.0-4), netbase:amd64 (4.47, 5.0), libnm-glib-vpn1:amd64 (0.9.4.0-3, 0.9.4.0-4), ifupdown:amd64 (0.7~beta2, 0.7~rc3), libnm-glib4:amd64 (0.9.4.0-3, 0.9.4.0-4), vino:amd64 (3.4.1-1, 3.4.2-1), xfce4-battery-plugin:amd64 (1.0.1-1, 1.0.4-1), wpasupplicant:amd64 (1.0-1, 1.0-2), libnm-util-dev:amd64 (0.9.4.0-3, 0.9.4.0-4), gir1.2-networkmanager-1.0:amd64 (0.9.4.0-3, 0.9.4.0-4), lintian:amd64 (2.5.6, 2.5.7), file-roller:amd64 (3.4.1-1, 3.4.2-1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2012-05-15  08:30:03
Ignore the error - been getting it for days, know about the bug.

I assume it is gnome-session that is causing the problem.

Steve
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

AlbertP
Level 16
Level 16
Posts: 6724
Joined: Sun Jan 30, 2011 12:38 pm
Location: Utrecht, The Netherlands

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by AlbertP » Tue May 15, 2012 5:22 am

You can try disabling the gnome-session update in the updater (no need to ignore it, just uncheck it) to see if it's fixed then.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.

User avatar
xircon
Level 5
Level 5
Posts: 768
Joined: Sun Aug 01, 2010 7:59 am
Location: Sheffield, UK

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by xircon » Tue May 15, 2012 5:28 am

AlbertP - Can you explain what you mean? I have updated, I could roll back (if packages are in the cache).
Dell Inspiron N5010 / Core I5 / ATI Mobility Radeon HD5400, LMDE Tracking Sid & Cinnamon Desktop
"Ubuntu is an African word meaning 'I can't configure Debian'"

craigevil
Level 5
Level 5
Posts: 554
Joined: Wed Sep 15, 2010 6:10 am
Location: down the rabbit hole
Contact:

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by craigevil » Tue May 15, 2012 4:16 pm

For those running KDE, the qt-kde repo now has KDE 4.8.3

Lots of shiny new KDE upgrades.

Debian Qt/KDE semi-official package repository - http://qt-kde.debian.net/
Just add the repo:
deb http://qt-kde.debian.net/debian/ experimental-snapshots main
apt-get update && apt-get -t experimental-snapshots dist-upgrade

111 upgraded, 7 newly installed, 2 to remove and 0 not upgraded.
Need to get 132 MB of archives.

No problems reported so far, aptosid and siduction guys all reporting the upgrade goes well with no issues.
2012-05-14
Main KDE Plasma Workspaces 4.8.3 packages are now available from these mirrors. Check this announcement mailfor further information.
As usual, do not file bugs in the official Debian BTS. Instead use the debian-kde mailing list or the #debian-kde IRC channel on irc.debian.org.
Debian Sid KDE4.8.4 Kernel 3.4 Thinkpad R40 CPU Pentium M 1.3MHz RAM 2GB ATI Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by GregE » Wed May 16, 2012 12:40 am

xircon wrote:AlbertP - Can you explain what you mean? I have updated, I could roll back (if packages are in the cache).
My 2c worth ....

I would not bother as we are in the transition to 3.4. If it is working other than the theme then I would just wait. It is up to you. I would also remove all extensions before that final update to gnome-shell 3.4.

http://www.0d.be/debian/debian-gnome-3.4-status.html

I would guess that we are only 3 packages away from complete transition. You will have to re-apply your extensions then anyway. The good news is that there is a 3.4 theme changer just a click away in extensions.gnome.org.

I think you know way more about themes than I do, but if you are keen you could update the theme with a hammer. Just pick a theme and overwrite the contents of /usr/share/gnome-shell/theme and thus make your theme the default theme. It will get overwritten in the upgrade to gnome-shell 3.4.

ps to everyone

you can bypass issues with ifupdown by installing the experimental version.
Last edited by GregE on Wed May 16, 2012 1:18 am, edited 1 time in total.

GregE
Level 4
Level 4
Posts: 472
Joined: Sun Jan 16, 2011 6:24 am
Location: Melbourne, Australia

Re: LMDE BREAKAGES - (Tracking SID!) - May 5th

Post by GregE » Wed May 16, 2012 1:12 am

How to transition extensions to 3.4

Extensions are stored in two places.

Those installed from a deb are in /usr/share/gnome-shell/extensions

Those installed from extensions.gnome.org are in /home/you/.local/share/gnome-shell/extensions

Each extension is a group of text files. Each has a file called metadata.json

If you look inside metadata.json with a text editor you will see a line something like "shell-version": [ "3.2", "3.3" ]

This will tell you whether the extension is compatible with shell 3.4, so note those you can keep and those that need updating.

Just before updating Gnome Shell use Tweak Tool/Advanced Settings to disable the extension you can no longer use - then simply delete the files from /home/.local/share/gnome-shell/extensions. For the deb installed extensions just un-install them.

Then upgrade to Gnome Shell 3.4 and then go to extensions.gnome.org and re-install the extensions that you want.

Please speak up if you have an easier or more elegant way.

This whole thing is one weakness of extensions - they do not easily update across Gnome versions. Many are now written to cover multiple versions so they will transition easily. Also many can be manually edited to add 3.4 to the list in metadata.json, but that might have unforeseen consequences.

Locked

Return to “LMDE 1 Archive”