Page 73 of 73

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Posted: Mon May 06, 2013 9:10 am
by Brian49
The upgrade to libcairo2 which has just come through involves installing these new packages, taking up an additional 36Mb of disk space:

libdrm-nouveau1a
libegl1-mesa
libgbm1
libwayland0
libxcb-dri2-0
libxcb-xfixes0

What on earth is that about, I wonder?

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Posted: Mon May 06, 2013 11:03 am
by karashata
Hm, I'm guessing libcairo2 version 1.12.14-1 (or newer) must have recently dropped into SID then. Those packages would ultimately have been pulled in as dependencies of either libcairo2 itself or new packages that libcairo2 now depends on. libegl1-mesa is a new dependency of libcairo2, and it depends on libwayland0, plus the libegl1-mesa-drivers package (which libegl1-mesa depends on, but you haven't listed here) depends on libdrm-nouveau1a. (That's as far as I've bothered to trace, but you get the picture...)

I can't currently install libcairo2 version 1.12.14-1 (still listed as being in Experimental here) due to libegl1-mesa's dependency on libwayland0, since currently libwayland0 is not capable of being co-installed with its i386 arch package (it doesn't support multiarch yet), so I'm still stuck with the version shipping in Testing. There have been reports asking for a version update at least for Experimental for libwayland0 to support multiarch, but it was considered low-priority by the maintainers as the packages were still just in Experimental. Hopefully with this push into SID they'll consider updating libwayland0 for multiarch support to be somewhat more important.

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Posted: Tue May 07, 2013 7:02 am
by GeneC
Bug with : ifupdown 0.7.41

http://www.mail-archive.com/debian-bugs ... 17963.html

http://aptosid.com/index.php?name=PNphp ... pic&t=2584

Suggested to put on hold until ifupdown 0.7.43

Re: LMDE BREAKAGES - (Tracking SID!) - Jan 2, 2013

Posted: Tue May 07, 2013 2:23 pm
by GeneC
GeneC wrote:Bug with : ifupdown 0.7.41

http://aptosid.com/index.php?name=PNphp ... pic&t=2584
http://www.mail-archive.com/debian-bugs ... 17963.html

Suggested to put on hold until ifupdown 0.7.43
OK to upgrade. ifupdown 0.7.43 has already hit the repos.

Code: Select all

gene@solydx64:~$ apt-cache policy ifupdown
ifupdown:
  Installed: 0.7.43
  Candidate: 0.7.43
  Version table:
 *** 0.7.43 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Lots of updates today. One for libc6

Code: Select all

gene@solydx64:~$ apt-cache policy libc6
libc6:
  Installed: 2.17-1
  Candidate: 2.17-1
  Version table:
 *** 2.17-1 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
        100 /var/lib/dpkg/status
Pop-up screen appears. I just hit enter, and continued. No issues on re-boot.
Image

Re: LMDE BREAKAGES - (Tracking SID!) -{CLOSED}

Posted: Tue May 07, 2013 3:09 pm
by GeneC
Could a moderator please close this thread. Its old, getting too large, and I started a new one.


http://forums.linuxmint.com/viewtopic.p ... 8&t=133211

Thanks. :)