Login Screen Settings not unlocking.

Archived topics about LMDE 1 and LMDE 2
Locked
User avatar
Cheesethief
Level 2
Level 2
Posts: 53
Joined: Tue Jun 22, 2010 6:52 pm

Login Screen Settings not unlocking.

Post by Cheesethief »

So after installing 201108 RC (Gnome), I started to tweak it to my liking one of these tweaks is to make it so it does not prompt me for a password upon startup. I am the only person who has access to this computer, so it gets a little annoying.

What I noticed is that when I go to Menu>All Applications>Admin>Login Screen, it does not unlock the window to tweak settings when I press on the padlock image.

I am running the 64bit version by the way.
Desktop: Intel Core i5-2500K 3.3GHz, 8GB RAM, AMD Radeon HD 6670 1GB: Windows 8.1 Pro
Laptop: Intel Core i7-2675QM 2.2GHz, 6GB RAM, AMD Radeon HD 6750M/Intel HD Graphics 3000: Linux Mint 17.1
Server: Raspberry Pi Model B: Raspbian Wheezy

User avatar
xenopeek
Level 24
Level 24
Posts: 24338
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Login Screen Settings not unlocking.

Post by xenopeek »

I can confirm the unlock button on the login screen doesn't work. Tried "gksudo gdmsetup" also to force root priviliges, same problem. Not finding any useful errors in syslog or on the terminal output.

Workaround:
1. Open a terminal (from Menu) and run:

Code: Select all

gksudo gedit /etc/gdm3/daemon.conf
2. Under the section [daemon] replace the text to read the following (don't replace any lines with [something] on them):

Code: Select all

TimedLoginEnable=false
AutomaticLoginEnable=true
TimedLogin=<your username>
AutomaticLogin=<your username>
TimedLoginDelay=30
Replace the <your username> (including the angeled brackets) with your username. If you are unsure of that, type:

Code: Select all

whoami
3. Save & close the file, from now on you should login automatically. (Code copied from the Live CD.)
Image

User avatar
xenopeek
Level 24
Level 24
Posts: 24338
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Login Screen Settings not unlocking.

Post by xenopeek »

I reported this as a bug: https://bugs.launchpad.net/linuxmint/+bug/830409. It also affects the Network and "Time and Date" administrative applications.
Image

secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: Login Screen Settings not unlocking.

Post by secipolla »

Yep, I suggested to Clem (I think) to remove the desktop file for gdmsetup as it's broken and probably won't be fixed as gdm3 is the 2.30 version and for GNOME 3 the 'User account' window allows to set automatic login.
People can set it by editing /etc/gdm3/daemon.conf (if it's worthwhile maybe a little GUI could be made for that).

David Brown
Level 2
Level 2
Posts: 60
Joined: Sat Jun 28, 2008 5:55 pm

Re: Login Screen Settings not unlocking.

Post by David Brown »

I'm using the (201109-gnome-32bit) version of LMDE. Following various suggestions, I've added the suggested lines to both /etc/gdm3/daemon.conf and to /etc/gdm3/custom.conf. Neither works. With LMDE before loading the new spin, adding these lines to daemon.conf did work for me.

Opening (gksudo gdmsetup) gives a small window with an unlocked padlock but with all the commands greyed out. All that does work is the Close button.

David Brown

David Brown
Level 2
Level 2
Posts: 60
Joined: Sat Jun 28, 2008 5:55 pm

Re: Login Screen Settings not unlocking.

Post by David Brown »

Solved for me: see
http://forums.linuxmint.com/viewtopic.p ... in#p475935
Thank you xenopeek

Locked

Return to “LMDE Archive”