HDMI-Sound gone after LMDE upgrade (solved)

Archived topics about LMDE 1
Locked
Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

HDMI-Sound gone after LMDE upgrade (solved)

Post by Eko_taas » Sun Aug 21, 2011 3:00 am

My TV-Mint was running OK
- LMDE updated around 10.6.2011 (working well, then traveling 2M)
- HDMI (picture, sound) OK with HDMI on LCD-TV (also in new location)
(HW: Dell Inspiron Zino HD with RS780 Azelia controller Digital Stereo (HDMI))
http://www.dell.com/us/en/corp/desktops ... -hd&s=corp

When I found that MintUpdate claimed "packages broken", I run

Code: Select all

apt-get install -f && apt-get clean && apt-get update && apt-get dist-upgrade
All was looking OK and looks to be up to date (as per MintUpdate as well), but found no sound :evil:
(System Monitor: kernel 3.0.0.-1-amd64, Gnome 3.0.2)

I have checked sound settings several times
- not muted (100%) :lol:
- Sound Pref / Output "RS780 ....(HDMI) stereo"
- Sound pref /hardware Profile "digital stereo (HDMI) output"
- all sounds missing (VLC medial player, system sounds).

Where to start fixing?
Last edited by Eko_taas on Mon Aug 22, 2011 3:13 pm, edited 1 time in total.

User avatar
Oscar799
Level 19
Level 19
Posts: 9984
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: HDMI-Sound gone after LMDE upgrade

Post by Oscar799 » Sun Aug 21, 2011 5:42 am

Moved here from Hardware Support
Image

Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Eko_taas » Sun Aug 21, 2011 7:41 am

Sorry for wrong location... Analoque headphones OK when selecting as active output...
Last edited by Eko_taas on Sun Aug 21, 2011 8:13 am, edited 1 time in total.

User avatar
Oscar799
Level 19
Level 19
Posts: 9984
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: HDMI-Sound gone after LMDE upgrade

Post by Oscar799 » Sun Aug 21, 2011 7:45 am

Eko_taas,
I moved your post here as it is more likely to be seen by people who know about LMDE,and therefore may be answered quicker than if it had stayed where it was in Hardware Support
Image

Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Eko_taas » Sun Aug 21, 2011 8:14 am

Thanks, waiting for innovative solutions to fix this.

User avatar
sumski
Level 3
Level 3
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: HDMI-Sound gone after LMDE upgrade

Post by sumski » Sun Aug 21, 2011 11:36 am

Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2

Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Eko_taas » Sun Aug 21, 2011 3:58 pm

....
To re-enable HDMI audio, in /boot/grub/menu.lst, add this to the end of your "kernel" line:
radeon.audio=1
...
Seems that good hint (as for radeon), but as newbie bit complicated to implement :cry:

In my LMDE, above file/folder :?: :oops: does not exist :?: (even if as sudo)

User avatar
mads
Level 6
Level 6
Posts: 1298
Joined: Wed Nov 03, 2010 3:44 pm
Contact:

Re: HDMI-Sound gone after LMDE upgrade

Post by mads » Sun Aug 21, 2011 4:30 pm

Have you checked "Sound Preferences" - "Output" - "Choose a device for sound output"?
Some times it switches the graphic cards.

Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Eko_taas » Mon Aug 22, 2011 1:53 am

mads wrote:Have you checked "Sound Preferences" - "Output" - "Choose a device for sound output"?
Some times it switches the graphic cards.
As stated earlier, done as 1st thing... Also bottom selection (i.e. not "off")

User avatar
sumski
Level 3
Level 3
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: HDMI-Sound gone after LMDE upgrade

Post by sumski » Mon Aug 22, 2011 2:08 am

Eko_taas wrote:
....
To re-enable HDMI audio, in /boot/grub/menu.lst, add this to the end of your "kernel" line:
radeon.audio=1
...
Seems that good hint (as for radeon), but as newbie bit complicated to implement :cry:

In my LMDE, above file/folder :?: :oops: does not exist :?: (even if as sudo)
Arch Linux uses "old" grub , Debian/LMDE "new" GRUB2. You need to edit another file - /etc/default/grub, and under
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" add radeon.audio=1, so it looks like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1", and then run
sudo update-grub , and reboot
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2

Eko_taas
Level 2
Level 2
Posts: 72
Joined: Sat Jul 03, 2010 3:04 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Eko_taas » Mon Aug 22, 2011 3:12 pm

sumski wrote:....
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1", and then run
sudo update-grub , and reboot
Thanks Man, you made my day :D worked like a charm 8)

Makes me wonder, why this change has been done (or why GUI cannot detect this setting....

User avatar
sumski
Level 3
Level 3
Posts: 109
Joined: Fri Nov 26, 2010 6:36 am
Location: Zagreb, Croatia

Re: HDMI-Sound gone after LMDE upgrade (solved)

Post by sumski » Mon Aug 22, 2011 4:23 pm

no problem ;) i also find this change puzzling
Acer Extensa 5630G - Core2Duo T5800 2GHz , 4 GB ram, Ati Mobility 3650.
OpenSUSE 12.1 KDE 4.7.3
Debian Sid KDE 4.7.1/2

User avatar
Sithun
Level 1
Level 1
Posts: 2
Joined: Thu Mar 08, 2012 7:03 am

Re: HDMI-Sound gone after LMDE upgrade

Post by Sithun » Sun Mar 11, 2012 2:56 am

....
To re-enable HDMI audio, in /boot/grub/menu.lst, add this to the end of your "kernel" line:
radeon.audio=1
...
That broke the frames around all of my windows (except chromium). I'm not certain how to search for this, can someone give me a pointer? I'm using LMDE with XFCE.

This might be related to the "Save session" -option, which was enabled at the time.

EDIT: Missing frames solved by typing

Code: Select all

xfwm4
in the terminal. Rebooted with "save session".

kadm
Level 1
Level 1
Posts: 17
Joined: Sat Jun 04, 2011 9:42 pm

Re: HDMI-Sound gone after LMDE upgrade

Post by kadm » Fri Aug 10, 2012 7:07 pm

sumski wrote:edit another file - /etc/default/grub, and under
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" add radeon.audio=1, so it looks like
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1", and then run
sudo update-grub , and reboot
It worked for me, running LMDE-Mate with ATI Radeon 4650. No audio out of HDMI port despite using HDMI 1.4 latest standard with audio return channel or old 1.3 cable. Adding radeon.audio=1 to grub was the only thing who made sound go thru HDMI to TV. ++

jason_eit
Level 1
Level 1
Posts: 1
Joined: Wed Nov 07, 2012 10:47 am

Re: HDMI-Sound gone after LMDE upgrade (solved)

Post by jason_eit » Wed Nov 07, 2012 10:50 am

And what is the corresponding GRUB command if you have an Intel chip?

/j

telenux
Level 3
Level 3
Posts: 163
Joined: Tue Nov 06, 2007 2:52 am

Re: HDMI-Sound gone after LMDE upgrade (solved)

Post by telenux » Sat Nov 10, 2012 3:32 am

jason_eit wrote:And what is the corresponding GRUB command if you have an Intel chip?

/j
This might be of some help despite it being for ArchLinux. I think the concept of what you have to do is the same.

https://bbs.archlinux.org/viewtopic.php?id=132641

Run these commands:
aplay -l

Get the device info.

E.g. say, it is 'device 3.'

Create or edit asoundrc file. Put something like this there:

pcm.!default{
type hw
card 0
device 3
}

This is for using ALSA. If you want it for PulseAudio, read over the first ArchLinux thread and see if it helps.

Locked

Return to “LMDE 1 Archive”