Right click in thunar; keep mouse button pressed (SOLVED)

Archived topics about LMDE 1
Locked
Dave W.
Level 2
Level 2
Posts: 63
Joined: Wed Apr 07, 2010 9:15 pm
Location: Pennsylvania, USA

Right click in thunar; keep mouse button pressed (SOLVED)

Post by Dave W. »

Hello,
I searched for this, wondering if this is a bug or me just not understanding the Settings Manager.
When I use thunar as either user or root I noticed that if I want to open a particular folder and I right click and get the menu, I must keep the right button depressed and place the mouse pointer over my desired option and then release the button in order to access that function. If I don't keep the right mouse button depressed my menu options are no longer visible.
Is this what is supposed to happen?

Thanks,
Dave

inxi output:
System: Host mint64xfce Kernel 2.6.39-2-amd64 x86_64 (64 bit) Distro Linux Mint Xfce Edition
CPU: Dual core AMD Athlon 64 X2 4800+ (-MCP-) cache 1024 KB flags (lm nx sse sse2 sse3 svm) bmips 4018.6
Clock Speeds: (1) 1000.00 MHz (2) 1000.00 MHz
Graphics: Card nVidia C61 [GeForce 6150SE nForce 430] X.Org 1.10.2.902 Res: 1280x1024@50.0hz
GLX Renderer GeForce 6150SE nForce 430/PCI/SSE2 GLX Version 2.1.2 NVIDIA 280.13 Direct Rendering Yes
Audio: Card-1 nVidia MCP61 High Definition Audio driver HDA Intel BusID: 00:05.0
Card-2 Logitech Inc. Webcam Pro 9000 driver snd-usb-audio
Sound: Advanced Linux Sound Architecture Version 1.0.24
Network: Card nVidia MCP61 Ethernet driver forcedeth at port ec00 BusID: 00:07.0
Disks: HDD Total Size: 820.2GB (0.5% used) 1: /dev/sda WDC_WD5000AAKB 500.1GB
2: /dev/sdb WDC_WD3200AAJS 320.1GB
Partition: ID:/ size: 15G used: 3.6G (26%) fs: ext4 ID:/home size: 61G used: 263M (1%) fs: ext4
ID:swap-1 size: 7.82GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 9.0C mobo: N/A gpu: 0.0:
Fan Speeds (in rpm): cpu: N/A
Info: Processes 135 Uptime 25 min Memory 417.6/2894.0MB Runlevel 2 Client Shell inxi 1.4.23
Last edited by Dave W. on Mon Sep 12, 2011 9:27 am, edited 1 time in total.
LMDE cinnamon 64 bit
Manjaro 0.8.8 Ascella Gnome amd64

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Right click in thunar; having to keep mouse button press

Post by zerozero »

try change from the mint theme to any other and see if you can still replicate that issue
Image

[ bliss of ignorance ]

Dave W.
Level 2
Level 2
Posts: 63
Joined: Wed Apr 07, 2010 9:15 pm
Location: Pennsylvania, USA

Re: Right click in thunar; keep mouse button pressed (SOLVED

Post by Dave W. »

Thanks zerozero. That did the trick. I needed to try a few before I found one that worked.
Dave
LMDE cinnamon 64 bit
Manjaro 0.8.8 Ascella Gnome amd64

zerozero
Level 16
Level 16
Posts: 6480
Joined: Tue Jul 07, 2009 2:29 pm

Re: Right click in thunar; keep mouse button pressed (SOLVED

Post by zerozero »

you're welcome 8) and enjoy LMDE :D
Image

[ bliss of ignorance ]

User avatar
tivasyk
Level 1
Level 1
Posts: 15
Joined: Sun May 31, 2009 4:22 am
Location: kyiv, ukraine
Contact:

Re: Right click in thunar; keep mouse button pressed (SOLVED

Post by tivasyk »

well… with these minty themes (styles actually) thunar behaves differently from all the other apps, and the only (simple) way to fix this is to just give up and search for another theme not because of looks, but just to avoid this abnormal behaviour? how lame…
«it's quite easy if you don't know how» (c) douglas adams

secipolla
Level 4
Level 4
Posts: 355
Joined: Sun Sep 05, 2010 5:19 pm

Re: Right click in thunar; keep mouse button pressed (SOLVED

Post by secipolla »

Yep, that would be really lame. So if the Mint theme has this bug it must be fixed.
Some themes from murrine-themes in Debian have this bug and it's due to the parameter "gtk-menu-popup-delay" in their gtkrc. One should simply remove/comment that line and it will be fixed.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=624328
(the maintainer there decided not fix it - at least not yet - but it really should be fixed as that parameter brings no benefit at all and just breaks the themes' usage)

Locked

Return to “LMDE 1 Archive”