Page 1 of 1

wrong hardware address for eth1

Posted: Fri Sep 30, 2011 11:32 am
by pampelmoose
Since the latest massive LMDE upgrade, I've got a problem with my ethernet connection.

I've got a pretty simple set-up : a Realtek 8111E chip, and an ethernet connection to my router which is a DHCP server.

Prior to the upgrade, the chip was recognized at eth0, and the "network connections" app connected automatically at boot-up.

After the update, the chip is now at eth1.

That's not a problem. The problem is that the computer gets the wrong hardware address at boot-up. So I have to manually run "ifdown eth1" and then "ifup eth1" after booting, in order to establish the connection.

Here's my /etc/network/interfaces file :


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth1
iface eth1 inet dhcp
hwaddress ether f4:6d:04:5a:23:86


That's the correct hardware address I've put in the file. But this file is being ignored at boot-up : eth1 gets assigned the wrong hardware address (which gets corrected as soon as I run ifdown eth1 and ifup eth1).

So some application is running at boot-up, and ignoring /etc/network/interfaces, and assigning the wrong hardware address to eth1. I've disabled "network manager" at boot-up, so some other script is the culprit.

So, in summary : eth1 works if it gets the correct hardware address, but something in the boot-up sequence is using the wrong hardware address. Any suggestions on how to repair this?

Re: wrong hardware address for eth1

Posted: Fri Sep 30, 2011 12:16 pm
by Gerd50
Maybe with the update you've got the package dnet-common? If, then remove it and your network connection should be ok.

Re: wrong hardware address for eth1

Posted: Fri Sep 30, 2011 2:04 pm
by pampelmoose
Thanks a lot, Gerd. That seemed to do the trick.

[I still am having troubles with the new kernel (3.0.0-1). The "r8169" module won't get the eth1 up, even with the right hardware address. Now r8169 has been a problem with the Realtek 8111E chipset, and I have been using the Realtek proprietary r8168 module. But when I try to install that module with the new kernel, I get a stack overflow, and the computer freezes. So for now I'll just stick with kernel 2.6.39-2.]

Re: wrong hardware address for eth1

Posted: Sat Oct 01, 2011 9:49 am
by Gerd50
Maybe you are missing the linux-headers for the new kernel?

Re: wrong hardware address for eth1

Posted: Sat Oct 01, 2011 9:32 pm
by ellipse55
I had the same problem, and was able to fix it using the information found in this post and its comments:
http://www.fantaghost.com/2010/06/eth0-mac-address-fixed-on-aa0004000a04/

More specifically, when I had my laptop and desktop both connected to my router, I was no longer able to ping them. They were invisible to each other. When I went into the setup page of the router, I saw that the MAC addresses of both computers were identical and set to "AA:00:04:00:0A:04". Obviously, this is not allowed. By uninstalling dnet-common and rebooting, the correct MAC addresses were used and everything was working fine again.

Best, Pierre.