unable to update mint debian

Archived topics about LMDE 1
Forum rules
LMDE 2 support ends on 1-1-2019
biffer
Level 2
Level 2
Posts: 94
Joined: Fri Dec 14, 2007 7:23 am

unable to update mint debian

Post by biffer » Tue Nov 08, 2011 6:56 pm

Hi,

I've downloaded and burnt lxde without problem. It's nice to use. However when I try to run the 'updates' it fails to complete the task. I get:

Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 139608 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--unpack):
trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

No updates are installed. Can anyone help me here, please?

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Tue Nov 08, 2011 8:36 pm

first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
Image

[ bliss of ignorance ]

biffer
Level 2
Level 2
Posts: 94
Joined: Fri Dec 14, 2007 7:23 am

Re: unable to update mint debian

Post by biffer » Wed Nov 09, 2011 2:19 am

It worked! Zerozero you are undoubtedly a storming genius. I can't imagine how you knew what was needed to solve my difficulty but I'm grateful you did. My update icon is now replete with a tick.

Many many thanks for your willingness to help.

Best wishes,

biffer

User avatar
Oscar799
Level 19
Level 19
Posts: 9875
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: unable to update mint debian

Post by Oscar799 » Wed Nov 09, 2011 8:38 am

Moved here from the main forum
Image

User avatar
SunWorks
Level 3
Level 3
Posts: 186
Joined: Tue Dec 15, 2009 11:30 pm
Location: Minnesota, USA
Contact:

Re: unable to update mint debian

Post by SunWorks » Thu Nov 17, 2011 8:33 pm

zerozero wrote:- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
Thank you zerozero... had the same problem with a Dell Inspiron 1501 I am installing LMDE 32 to, and all is good.

Many thanks,
clinton

travlemon
Level 2
Level 2
Posts: 54
Joined: Fri Mar 05, 2010 2:18 pm

Re: unable to update mint debian

Post by travlemon » Fri Nov 18, 2011 1:36 am

zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
ZeroZero- I'd also like to say that this worked for me as well! Thanks very much! I hope this continues to solve the issue for future users!
For my video tutorials, check out:
http://www.youtube.com/webhunterification

seeyouentee
Level 1
Level 1
Posts: 11
Joined: Tue Mar 24, 2009 11:41 am

Re: unable to update mint debian

Post by seeyouentee » Fri Nov 18, 2011 6:03 pm

Hope someone can help me . I am new to lmde . After installing lmde im recieving this message everytime i try to update .Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages . Any help much appreciated thanks .

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Fri Nov 18, 2011 8:26 pm

seeyouentee,
can you please open the terminal, copy the 2 commands bellow and copy-past the output here, thanks.

Code: Select all

inxi -r

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
Image

[ bliss of ignorance ]

varonbondumb
Level 1
Level 1
Posts: 44
Joined: Wed May 04, 2011 4:23 pm
Location: Raleigh, NC

Re: unable to update mint debian

Post by varonbondumb » Sat Feb 04, 2012 3:47 am

thank you very much for this, zerozero! It fixed my issue as well.
zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Sat Feb 04, 2012 12:32 pm

varonbondumb wrote:It fixed my issue as well.
glad i could help.
Image

[ bliss of ignorance ]

User avatar
Tony.B
Level 2
Level 2
Posts: 60
Joined: Mon Oct 25, 2010 3:51 pm
Location: Kent, UK & KZN, South Africa

Re: unable to update mint debian

Post by Tony.B » Sat Feb 18, 2012 4:20 pm

Thanks, zerozero. You've just helped me too.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Sat Feb 18, 2012 8:55 pm

Tony.B wrote:Thanks, zerozero. You've just helped me too.
8) enjoy lmde
Image

[ bliss of ignorance ]

User avatar
surfer57
Level 1
Level 1
Posts: 9
Joined: Sun Jul 08, 2007 4:51 pm

Re: unable to update mint debian <RESOLVED>

Post by surfer57 » Mon Mar 05, 2012 11:47 pm

zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

You rock zerozero!!!!

squeezy
Level 5
Level 5
Posts: 566
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: unable to update mint debian

Post by squeezy » Tue Mar 06, 2012 1:13 am

An even easier way to resolve this problem. From the notes when you click on the Update Pack Info button in Update Manager...
Gstreamer
The package mint-meta-codecs features an update which should prevent you from experiencing this issue. For information, and in case you are faced with a conflict between gstreamer0.10-plugins-bad and gstreamer0.10-plugins-really-bad, simply remove the gstreamer0.10-plugins-really-bad package. It is maintained by debian-multimedia.org and currently conflicts with the Gstreamer packages maintained by Debian.
Sometimes it pays to RTFM, eh?

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Tue Mar 06, 2012 11:52 am

squeezy, the question here with the "fine manual" :wink: is that it instructs you to remove the pkg, loosing functionality and the force-overwrite (not being the most elegant solution) preserves all the codecs
Image

[ bliss of ignorance ]

squeezy
Level 5
Level 5
Posts: 566
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: unable to update mint debian

Post by squeezy » Tue Mar 06, 2012 12:14 pm

zerozero wrote:squeezy, the question here with the "fine manual" :wink: is that it instructs you to remove the pkg, loosing functionality and the force-overwrite (not being the most elegant solution) preserves all the codecs
Theoretically, yes. I've not suffered any loss of functionality that I can detect however. All my audio/video apps work just fine. I'll admit I am not a power user generally, although I do a bit of home recording now and then. All I can say is I've done it both ways and not seen any difference in function either way. The new mint-meta-codecs package removed the dependancy for this so I figured it was a non-essential package anyway.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Tue Mar 06, 2012 12:18 pm

i have to admit, i never did it the other way :oops: so i have no way to compare, as you say, is a theoretical assumption
Image

[ bliss of ignorance ]

squeezy
Level 5
Level 5
Posts: 566
Joined: Thu Feb 23, 2012 2:05 pm
Location: The Land of Enchantment

Re: unable to update mint debian

Post by squeezy » Tue Mar 06, 2012 12:52 pm

Yes, I did it using the overwrite method the first couple of times myself. Then I read the fine manual and saw that bit mentioned. Been simply deleting the package since then with no ill effects noticed. :D

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: unable to update mint debian

Post by zerozero » Tue Mar 06, 2012 2:21 pm

tbh, if we ask apt
apt show gstreamer0.10-plugins-really-bad
Package: gstreamer0.10-plugins-really-bad
New: yes
State: installed
Automatically installed: no
Version: 0.10.23-0.0
Priority: optional
Section: sound
Maintainer: Christian Marillat <marillat@debian.org>
Uncompressed Size: 1,109 k
Depends: libc6 (>= 2.2.5), libfaac0, libgcc1 (>= 1:4.1.1), libglib2.0-0 (>=
2.24.0), libgstreamer-plugins-base0.10-0 (>= 0.10.36),
libgstreamer0.10-0 (>= 0.10.36), libmjpegtools-2.0-0, libstdc++6 (>=
4.1.1), libvdpau1 (>= 0.2), libx11-6
Description: GStreamer plugins from the "bad" set
GStreamer is a streaming media framework, based on graphs of filters which
operate on media data. Applications using this library can do anything from
real-time sound processing to playing videos, and just about anything else
media-related. Its plugin-based architecture means that new data types or
processing capabilities can be added simply by installing new plug-ins.

This package contains plugins from the "bad" set, a set of non-free plug-ins
that might pose distribution problems.

Bad plugins are faac, mpeg2enc, mplex, vdpau and xvid.
Homepage: http://gstreamer.net/
nahh i maybe never use this :P
Image

[ bliss of ignorance ]

User avatar
Herpy
Level 2
Level 2
Posts: 54
Joined: Sun Nov 27, 2011 4:59 pm

Re: unable to update mint debian

Post by Herpy » Tue Mar 06, 2012 8:57 pm

zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
When I run that I get this. pkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
Image

Locked

Return to “LMDE 1 Archive”