Page 1 of 2

unable to update mint debian

Posted: Tue Nov 08, 2011 6:56 pm
by biffer
Hi,

I've downloaded and burnt lxde without problem. It's nice to use. However when I try to run the 'updates' it fails to complete the task. I get:

Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 139608 files and directories currently installed.)
Preparing to replace gstreamer0.10-plugins-bad 0.10.22-2 (using .../gstreamer0.10-plugins-bad_0.10.22-3_i386.deb) ...
Unpacking replacement gstreamer0.10-plugins-bad ...
dpkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--unpack):
trying to overwrite '/usr/lib/gstreamer-0.10/libgstxvid.so', which is also in package gstreamer0.10-plugins-really-bad 0.10.22-0.1
configured to not write apport reports
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

No updates are installed. Can anyone help me here, please?

Re: unable to update mint debian

Posted: Tue Nov 08, 2011 8:36 pm
by zerozero
first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

Re: unable to update mint debian

Posted: Wed Nov 09, 2011 2:19 am
by biffer
It worked! Zerozero you are undoubtedly a storming genius. I can't imagine how you knew what was needed to solve my difficulty but I'm grateful you did. My update icon is now replete with a tick.

Many many thanks for your willingness to help.

Best wishes,

biffer

Re: unable to update mint debian

Posted: Wed Nov 09, 2011 8:38 am
by Oscar799
Moved here from the main forum

Re: unable to update mint debian

Posted: Thu Nov 17, 2011 8:33 pm
by SunWorks
zerozero wrote:- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
Thank you zerozero... had the same problem with a Dell Inspiron 1501 I am installing LMDE 32 to, and all is good.

Many thanks,
clinton

Re: unable to update mint debian

Posted: Fri Nov 18, 2011 1:36 am
by travlemon
zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
ZeroZero- I'd also like to say that this worked for me as well! Thanks very much! I hope this continues to solve the issue for future users!

Re: unable to update mint debian

Posted: Fri Nov 18, 2011 6:03 pm
by seeyouentee
Hope someone can help me . I am new to lmde . After installing lmde im recieving this message everytime i try to update .Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages . Any help much appreciated thanks .

Re: unable to update mint debian

Posted: Fri Nov 18, 2011 8:26 pm
by zerozero
seeyouentee,
can you please open the terminal, copy the 2 commands bellow and copy-past the output here, thanks.

Code: Select all

inxi -r

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade

Re: unable to update mint debian

Posted: Sat Feb 04, 2012 3:47 am
by varonbondumb
thank you very much for this, zerozero! It fixed my issue as well.
zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

Re: unable to update mint debian

Posted: Sat Feb 04, 2012 12:32 pm
by zerozero
varonbondumb wrote:It fixed my issue as well.
glad i could help.

Re: unable to update mint debian

Posted: Sat Feb 18, 2012 4:20 pm
by Tony.B
Thanks, zerozero. You've just helped me too.

Re: unable to update mint debian

Posted: Sat Feb 18, 2012 8:55 pm
by zerozero
Tony.B wrote:Thanks, zerozero. You've just helped me too.
8) enjoy lmde

Re: unable to update mint debian <RESOLVED>

Posted: Mon Mar 05, 2012 11:47 pm
by surfer57
zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);

now your problem:
- after updating, with the terminal, with

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb

You rock zerozero!!!!

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 1:13 am
by squeezy
An even easier way to resolve this problem. From the notes when you click on the Update Pack Info button in Update Manager...
Gstreamer
The package mint-meta-codecs features an update which should prevent you from experiencing this issue. For information, and in case you are faced with a conflict between gstreamer0.10-plugins-bad and gstreamer0.10-plugins-really-bad, simply remove the gstreamer0.10-plugins-really-bad package. It is maintained by debian-multimedia.org and currently conflicts with the Gstreamer packages maintained by Debian.
Sometimes it pays to RTFM, eh?

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 11:52 am
by zerozero
squeezy, the question here with the "fine manual" :wink: is that it instructs you to remove the pkg, loosing functionality and the force-overwrite (not being the most elegant solution) preserves all the codecs

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 12:14 pm
by squeezy
zerozero wrote:squeezy, the question here with the "fine manual" :wink: is that it instructs you to remove the pkg, loosing functionality and the force-overwrite (not being the most elegant solution) preserves all the codecs
Theoretically, yes. I've not suffered any loss of functionality that I can detect however. All my audio/video apps work just fine. I'll admit I am not a power user generally, although I do a bit of home recording now and then. All I can say is I've done it both ways and not seen any difference in function either way. The new mint-meta-codecs package removed the dependancy for this so I figured it was a non-essential package anyway.

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 12:18 pm
by zerozero
i have to admit, i never did it the other way :oops: so i have no way to compare, as you say, is a theoretical assumption

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 12:52 pm
by squeezy
Yes, I did it using the overwrite method the first couple of times myself. Then I read the fine manual and saw that bit mentioned. Been simply deleting the package since then with no ill effects noticed. :D

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 2:21 pm
by zerozero
tbh, if we ask apt
apt show gstreamer0.10-plugins-really-bad
Package: gstreamer0.10-plugins-really-bad
New: yes
State: installed
Automatically installed: no
Version: 0.10.23-0.0
Priority: optional
Section: sound
Maintainer: Christian Marillat <marillat@debian.org>
Uncompressed Size: 1,109 k
Depends: libc6 (>= 2.2.5), libfaac0, libgcc1 (>= 1:4.1.1), libglib2.0-0 (>=
2.24.0), libgstreamer-plugins-base0.10-0 (>= 0.10.36),
libgstreamer0.10-0 (>= 0.10.36), libmjpegtools-2.0-0, libstdc++6 (>=
4.1.1), libvdpau1 (>= 0.2), libx11-6
Description: GStreamer plugins from the "bad" set
GStreamer is a streaming media framework, based on graphs of filters which
operate on media data. Applications using this library can do anything from
real-time sound processing to playing videos, and just about anything else
media-related. Its plugin-based architecture means that new data types or
processing capabilities can be added simply by installing new plug-ins.

This package contains plugins from the "bad" set, a set of non-free plug-ins
that might pose distribution problems.

Bad plugins are faac, mpeg2enc, mplex, vdpau and xvid.
Homepage: http://gstreamer.net/
nahh i maybe never use this :P

Re: unable to update mint debian

Posted: Tue Mar 06, 2012 8:57 pm
by Herpy
zerozero wrote:first, a small correction, LMDE doesn't come with lxde (gnome and xfce are the default DE);
run this

Code: Select all

sudo dpkg -i --force-overwrite /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb
When I run that I get this. pkg: error processing /var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
/var/cache/apt/archives/gstreamer0.10-plugins-bad_0.10.22-3_i386.deb