browsers are broken after update! [resolved]

Archived topics about LMDE 1
Locked
wilo108
Level 1
Level 1
Posts: 28
Joined: Sat May 07, 2011 1:02 pm

browsers are broken after update! [resolved]

Post by wilo108 » Mon Apr 09, 2012 1:19 am

Hi -- I've just upgraded my LMDE installation UP4, and everything went very well. I now have MATE and Cinnamon installed, and I've not had any major problems with kernels or graphics drivers etc.

However, all my browsers (which is to say Chromium, Firefox and Iceweasel) are broken. Iceweasel just crashes, Firefox crashes and offers the Mozilla reporting dialogue, and Chromium shows me the "aw, snap" screen. I've uninstalled and re-installed them all, and used brand-new clean profiles, but I can't get any of them to work. I'm writing this using Chromium on a Windows 7 installation in virtualbox!

Can anyone offer me a hint?

Cheers!

wilo
Last edited by wilo108 on Sun Apr 15, 2012 1:44 am, edited 1 time in total.

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: browsers are broken after update!

Post by zerozero » Mon Apr 09, 2012 7:36 am

definitely not a normal thing to happen :shock: wilo
i remember one report when testing UP4 in incoming regarding chromium but wasn't replicated, now all the 3.
if you launch them from the terminal can you make any sense of the errors?

in the meantime you can try opera (let's hope it's not affected) and don't need VB
Image

[ bliss of ignorance ]

wilo108
Level 1
Level 1
Posts: 28
Joined: Sat May 07, 2011 1:02 pm

Re: browsers are broken after update!

Post by wilo108 » Sun Apr 15, 2012 1:44 am

hi -- sorry for the delayed reply. I got this sorted out in the end. I'm still not sure exactly what the problem was (there was no useful output running the browsers from a terminal -- i tried running chromium in gdb, too, but couldn't get any useful info), but I think it must have had something to do with version conflicts, I think. I was tracking the mozilla.debian.org repo for Iceweasel updates, and when I removed that, then removed and reinstalled all browsers from the Mint repo, everything was okay. I've now restored mozilla.debian.org, and updated Iceweasel from there, and it works just fine. I'm just going to put it down to upgrade teething troubles. Thanks for taking the time to reply -- much appreciated.

Locked

Return to “LMDE 1 Archive”