Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
koval
Level 1
Level 1
Posts: 37
Joined: Fri Jan 08, 2016 2:40 pm

Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by koval »

Hello,

Code: Select all

Windows 10
VirtualBox 6.1.22

Code: Select all

inxi -Fxz
System:    Kernel: 5.4.0-74-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6 
           Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal 
Machine:   Type: Virtualbox System: innotek product: VirtualBox v: 1.2 serial: <filter> 
           Mobo: Oracle model: VirtualBox v: 1.2 serial: <filter> BIOS: innotek v: VirtualBox date: 12/01/2006 
Battery:   ID-1: BAT0 charge: 50.0 Wh condition: 50.0/50.0 Wh (100%) model: innotek 1 status: Full 
CPU:       Topology: Dual Core model: Intel Core i5-8365U bits: 64 type: MCP arch: Kaby Lake rev: C L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 7584 
           Speed: 1896 MHz min/max: N/A Core speeds (MHz): 1: 1896 2: 1896 
Graphics:  Device-1: VMware SVGA II Adapter driver: vmwgfx v: 2.15.0.0 bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.9 driver: vmware unloaded: fbdev,modesetting,vesa resolution: 1920x996~60Hz 
           OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6 direct render: Yes 
Audio:     Device-1: Intel 82801AA AC97 Audio vendor: Dell driver: snd_intel8x0 v: kernel bus ID: 00:05.0 
           Sound Server: ALSA v: k5.4.0-74-generic 
Network:   Device-1: Intel 82540EM Gigabit Ethernet driver: e1000 v: 7.3.21-k8-NAPI port: d020 bus ID: 00:03.0 
           IF: enp0s3 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus v: N/A port: d200 bus ID: 00:07.0 
Drives:    Local Storage: total: 30.00 GiB used: 16.76 GiB (55.9%) 
           ID-1: /dev/sda vendor: VirtualBox model: VBOX HARDDISK size: 30.00 GiB 
Partition: ID-1: / size: 28.91 GiB used: 16.76 GiB (58.0%) fs: ext4 dev: /dev/sda5 
Sensors:   Message: No sensors data was found. Is sensors configured? 
Info:      Processes: 168 Uptime: 8m Memory: 3.84 GiB used: 717.8 MiB (18.2%) Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 
           Shell: bash v: 5.0.17 inxi: 3.0.38 

Code: Select all

dmesg | egrep -i 'virtualbox|vbox'
[    0.000000] DMI: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
[    0.076718] ACPI: RSDP 0x00000000000E0000 000024 (v02 VBOX  )
[    0.076721] ACPI: XSDT 0x00000000DFFF0030 00003C (v01 VBOX   VBOXXSDT 00000001 ASL  00000061)
[    0.076726] ACPI: FACP 0x00000000DFFF00F0 0000F4 (v04 VBOX   VBOXFACP 00000001 ASL  00000061)
[    0.076730] ACPI: DSDT 0x00000000DFFF0470 002325 (v02 VBOX   VBOXBIOS 00000002 INTL 20100528)
[    0.076736] ACPI: APIC 0x00000000DFFF0240 00005C (v02 VBOX   VBOXAPIC 00000001 ASL  00000061)
[    0.076739] ACPI: SSDT 0x00000000DFFF02A0 0001CC (v01 VBOX   VBOXCPUT 00000002 INTL 20100528)
[    1.276383] ata2.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/133
[    1.278282] scsi 1:0:0:0: CD-ROM            VBOX     CD-ROM           1.0  PQ: 0 ANSI: 5
[    1.740333] ata3.00: ATA-6: VBOX HARDDISK, 1.0, max UDMA/133
[    1.740635] scsi 2:0:0:0: Direct-Access     ATA      VBOX HARDDISK    1.0  PQ: 0 ANSI: 5
[    2.175818] usb 1-1: Manufacturer: VirtualBox
[    2.206030] input: VirtualBox USB Tablet as /devices/pci0000:00/0000:00:06.0/usb1/1-1/1-1:1.0/0003:80EE:0021.0001/input/input6
[    2.206363] hid-generic 0003:80EE:0021.0001: input,hidraw0: USB HID v1.10 Mouse [VirtualBox USB Tablet] on usb-0000:00:06.0-1/input0
[    3.206246] systemd[1]: Set hostname to <roman-VirtualBox>.
[    3.987926] vboxguest: loading out-of-tree module taints kernel.
[    3.988080] vboxguest: module verification failed: signature and/or required key missing - tainting kernel
[    4.011568] vboxguest: Successfully loaded version 6.1.22 r144080
[    4.011586] vboxguest: misc device minor 58, IRQ 20, I/O port d040, MMIO at 00000000f0400000 (size 0x400000)
[    4.011587] vboxguest: Successfully loaded version 6.1.22 r144080 (interface 0x00010004)
[   14.175145] vboxvideo: loading version 6.1.22 r144080
[   14.229727] 06:45:25.556533 main     VBoxService 6.1.22 r144080 (verbosity: 0) linux.amd64 (Apr 28 2021 18:43:39) release log
[   14.229836] 06:45:25.556677 main     Executable: /opt/VBoxGuestAdditions-6.1.22/sbin/VBoxService
Display settings > Graphics Controller > VMSVGA
Display settings > Graphics Controller > Acceleration Enabled 3D Acceleration turn on.

What else can I check?
User avatar
SMG
Level 16
Level 16
Posts: 6275
Joined: Sun Jul 26, 2020 6:15 pm
Location: USA

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by SMG »

koval wrote:
Fri Jul 09, 2021 2:58 am
What else can I check?
Maybe check /var/log/Xorg.0.log for errors or warnings?

Is this a new problem? Or is this a new install?

I noticed your system is not running the most recent kernel, 5.4.0-77, but I would not expect that to cause this issue.

System:
Kernel: 5.4.0-74- generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
A woman typing on a laptop with LM20.2 Cinnamon.
DisturbedDragon
Level 4
Level 4
Posts: 238
Joined: Mon Oct 29, 2012 6:29 pm
Location: Texas

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by DisturbedDragon »

Have you installed guest additions?
AMD Ryzen 9 3950X 16C/32T | MSI x470 Gaming Pro | 2TB Mushkin Pilot-E NVMe | 1TB Crucial P1 NVMe | 1TB Samsung 960 Pro NVMe | 32GB DDR4 3200 | Nvidia RTX2080 OC | Linux Mint 20.1 Cinnamon
koval
Level 1
Level 1
Posts: 37
Joined: Fri Jan 08, 2016 2:40 pm

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by koval »

DisturbedDragon wrote:
Fri Jul 09, 2021 8:55 pm
Have you installed guest additions?
Yes, I did

Code: Select all

[    4.011587] vboxguest: Successfully loaded version 6.1.22 r144080 (interface 0x00010004)
koval
Level 1
Level 1
Posts: 37
Joined: Fri Jan 08, 2016 2:40 pm

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by koval »

SMG wrote:
Fri Jul 09, 2021 2:46 pm
koval wrote:
Fri Jul 09, 2021 2:58 am
What else can I check?
Maybe check /var/log/Xorg.0.log for errors or warnings?

Is this a new problem? Or is this a new install?

I noticed your system is not running the most recent kernel, 5.4.0-77, but I would not expect that to cause this issue.

System:
Kernel: 5.4.0-74- generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.6
Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
Is this a new problem? Or is this a new install?
This is new install.
I noticed your system is not running the most recent kernel, 5.4.0-77, but I would not expect that to cause this issue.
I've installed latest Kernel just for test. Nothing changes.
Maybe check /var/log/Xorg.0.log for errors or warnings?
Checked. Nothing special there.
RIH
Level 6
Level 6
Posts: 1209
Joined: Sat Aug 22, 2015 3:47 am

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by RIH »

Display settings > Graphics Controller > VMSVGA
Display settings > Graphics Controller > Acceleration Enabled 3D Acceleration turn on.
What is your video memory set to on that page??
koval
Level 1
Level 1
Posts: 37
Joined: Fri Jan 08, 2016 2:40 pm

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by koval »

What is your video memory set to on that page??
128 Mb
Reddog1
Level 4
Level 4
Posts: 401
Joined: Wed Jun 01, 2011 2:12 pm

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by Reddog1 »

I've never gotten Cinnamon to work with VB. Well, it works, but without its eye candy, and it throws errors related to video acceleration. Xfce works, Mate works, even kde with plasma works, but Cinnamon always tosses an error. Good thing I don't like Cinnamon.
RIH
Level 6
Level 6
Posts: 1209
Joined: Sat Aug 22, 2015 3:47 am

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by RIH »

Strange.
I have not had an issue with running cinnamon in Mint versions 18, 19 or 20 in VirtualBox.
cinn.png
koval
Level 1
Level 1
Posts: 37
Joined: Fri Jan 08, 2016 2:40 pm

Re: Mint 20.1/Cinnamon 4.8.6 running in software rendering mode VirtualBox

Post by koval »

Reddog1 wrote:
Fri Jul 23, 2021 2:02 am
I've never gotten Cinnamon to work with VB. Well, it works, but without its eye candy, and it throws errors related to video acceleration. Xfce works, Mate works, even kde with plasma works, but Cinnamon always tosses an error. Good thing I don't like Cinnamon.
That's why I switched to MATE on my VirtualBox :)
Post Reply