Working on Virtual Box Issues.

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
FUBAR
Level 3
Level 3
Posts: 114
Joined: Mon Jun 27, 2022 8:19 am

Working on Virtual Box Issues.

Post by FUBAR »

Hello, I started off with Virtual Box and Win10. I am at the point that it will run, however getting the USB to be recognized appeared. I followed the following post and attempted the following .
Re: Installed Win10 VM can't see USB drive, don't understand shared folder route

Post by Reddog1 » Thu Sep 08, 2022 12:55 am
I open usb's in a somewhat unconventional manner. Plug your usb into your mint host. It will mount in /home/media/yourusername/xxxxxx(the drive designation)
With the Windows VM running, open VBoxManager>Settings and navigate to 'Shared Folders'
When the sharing windows opens, click the Plus folder on the right and navigate to the mountpoint on your linux host via the Folder Path and the dropdown menu to 'other'. At the mountpoint, choose it and then click 'automount'. Then it should show up in your Windows file manager as a disk that you can read and write to.
Hope this helps.

Note: this assumes you have added your username to the vbox users group:

$sudo gpasswd -a yourusernamehere vboxsf

Code: Select all

fubar@fubar-System-Product-Name:~$ sudo gpasswd -a fubar vboxsf
[sudo] password for fubar:  
gpasswd: group 'vboxsf' does not exist in /etc/group

This where I am. I have a USB working for Documents, however can't open it as I don't own it. I suspect the lack of the vboxsf is the issue?
Cosmo.
Level 24
Level 24
Posts: 22055
Joined: Sat Dec 06, 2014 7:34 am

Re: Working on Virtual Box Issues.

Post by Cosmo. »

The group vboxsf is needed and available in Linux guests, not in hosts.
Gotcha!
User avatar
AndyMH
Level 20
Level 20
Posts: 10799
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Working on Virtual Box Issues.

Post by AndyMH »

A lot simpler, with win running goto the VB devices menu, select USB, it will show you a list of USB devices, click the one you want. While your win guest has access to the USB drive it will not be available to mint.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
FUBAR
Level 3
Level 3
Posts: 114
Joined: Mon Jun 27, 2022 8:19 am

Re: Working on Virtual Box Issues.

Post by FUBAR »

All that tells me is that the USB is not connected, when I have one in the usb port!
ajgreeny
Level 6
Level 6
Posts: 1321
Joined: Mon Nov 19, 2007 3:27 pm

Re: Working on Virtual Box Issues.

Post by ajgreeny »

Do you have the guest-additions installed in the guest?
And what is your host and guest OS? You mention Windows 10 but I'm not sure if that is your host or the guest. You also do not tell us which version of virtualbox you're using; when I did use it I always installed directly using the virtualbox repositories as shown in the page at https://www.virtualbox.org/wiki/Linux_Downloads in the Debian-based Linux distributions section.
This is assuming your host is Mint but if it is Windows I can not help at all as I no longer have Windows on any computers.

It is a long time since I used virtualbox but I think the Guest Additions were needed to make a lot of activities in the guest possible, or at least easier, including using USB drives.
User avatar
AndyMH
Level 20
Level 20
Posts: 10799
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Working on Virtual Box Issues.

Post by AndyMH »

ajgreeny wrote:
Thu Sep 15, 2022 3:22 pm
It is a long time since I used virtualbox but I think the Guest Additions were needed to make a lot of activities in the guest possible, or at least easier, including using USB drives.
I think it is the extension pack that gives you usb functionality, not guest additions, but for a fully functional VM you should install both.
Homebrew i5-8400+GTX1080 Cinnamon 19.0, 4 x Thinkpad T430 Cinnamon 20.1, 2 x i7-3632 , i5-3320, i5-3210, Thinkpad T60 19.0 Mate
Cosmo.
Level 24
Level 24
Posts: 22055
Joined: Sat Dec 06, 2014 7:34 am

Re: Working on Virtual Box Issues.

Post by Cosmo. »

Without the extension pack only USB 1.1 is supported, for USB 2 and above the extension pack is needed. The guest additions are pointless for USB. But in Linux hosts the user must be member of the group vboxusers.
Gotcha!
FUBAR
Level 3
Level 3
Posts: 114
Joined: Mon Jun 27, 2022 8:19 am

Re: Working on Virtual Box Issues.

Post by FUBAR »

Cosmo. wrote:
Fri Sep 16, 2022 5:55 am
Without the extension pack only USB 1.1 is supported, for USB 2 and above the extension pack is needed. The guest additions are pointless for USB. But in Linux hosts the user must be member of the group vboxusers.
Okay Cosmo, can you describe the method for vboxusers please?
Cosmo.
Level 24
Level 24
Posts: 22055
Joined: Sat Dec 06, 2014 7:34 am

Re: Working on Virtual Box Issues.

Post by Cosmo. »

Open Users & Groups -> mark your account -> on the bottom of the right side there is a list of groups, where you belong to, this is actually a clickable button -> click it -> activate vboxusers in the list -> OK. You need to log out and back in to make this effective.
Gotcha!
FUBAR
Level 3
Level 3
Posts: 114
Joined: Mon Jun 27, 2022 8:19 am

Re: Working on Virtual Box Issues.

Post by FUBAR »

Open Users & Groups -> mark your account -> on the bottom of the right side there is a list of groups, where you belong to, this is actually a clickable button -> click it -> activate vboxusers in the list -> OK. You need to log out and back in to make this effective.
Hi Cosmo, I can't see users and groups. 1) Do I start VB first and have it running? 2) Where should I find Users and Groups?
I am running VB latest from their site, I do have the Guest extensions installed, VB is running Windows 10 x64.

Maybe some screenshots of what I am seeing?
RIH
Level 8
Level 8
Posts: 2122
Joined: Sat Aug 22, 2015 3:47 am

Re: Working on Virtual Box Issues.

Post by RIH »

The Users & Groups Cosmo is talking about is in Mint - from the Menu..
Image
Cosmo.
Level 24
Level 24
Posts: 22055
Joined: Sat Dec 06, 2014 7:34 am

Re: Working on Virtual Box Issues.

Post by Cosmo. »

I told you already, that the group vboxusers is needed on the host. (It would be more than strange, if you would find Users & Groups on a Windows guest.)

You should find Users & Groups in the menu. In case, that you use another language than English it has another name. In this case do that:
Open a terminal (press ctrl-alt-T) and enter

Code: Select all

cinnamon-settings-users
than press the Enter key.
Gotcha!
Reddog1
Level 6
Level 6
Posts: 1088
Joined: Wed Jun 01, 2011 2:12 pm

Re: Working on Virtual Box Issues.

Post by Reddog1 »

Read what cosmo wrote. You must be a member of the vboxusers group on your Mint host.

Open a terminal and type the command $id

the (vboxusers) group should show up after a group id number

If you are not, you must add yourself to that group (reboot or log out and log back in after)

To add yourself to the vboxusers group Start Menu>System>Users and Groups>Users Settings>Manage Groups>in Groups Settings arrow down to vboxusers>properties>then check the box by your username

After reboot you should see the (vboxusers) with the 'id' command, and your usb in the usb section of vboxmanager settings

However, mounting that usb drive on your guest can still be wonky because VBox doesn't like usb drives that are mounted in two places (on the host and on the guest). That's why I go through the share. You can do whatever works best for you.
User avatar
cpedretti
Level 3
Level 3
Posts: 184
Joined: Tue Mar 10, 2020 12:06 am

Re: Working on Virtual Box Issues.

Post by cpedretti »

FUBAR wrote:
Mon Sep 12, 2022 3:15 pm
Hello, I started off with Virtual Box and Win10. I am at the point that it will run, however getting the USB to be recognized appeared. I followed the following post and attempted the following .
Re: Installed Win10 VM can't see USB drive, don't understand shared folder route

Post by Reddog1 » Thu Sep 08, 2022 12:55 am
I open usb's in a somewhat unconventional manner. Plug your usb into your mint host. It will mount in /home/media/yourusername/xxxxxx(the drive designation)
With the Windows VM running, open VBoxManager>Settings and navigate to 'Shared Folders'
When the sharing windows opens, click the Plus folder on the right and navigate to the mountpoint on your linux host via the Folder Path and the dropdown menu to 'other'. At the mountpoint, choose it and then click 'automount'. Then it should show up in your Windows file manager as a disk that you can read and write to.
Hope this helps.

Note: this assumes you have added your username to the vbox users group:

$sudo gpasswd -a yourusernamehere vboxsf

Code: Select all

fubar@fubar-System-Product-Name:~$ sudo gpasswd -a fubar vboxsf
[sudo] password for fubar:  
gpasswd: group 'vboxsf' does not exist in /etc/group

This where I am. I have a USB working for Documents, however can't open it as I don't own it. I suspect the lack of the vboxsf is the issue?
Hi, if you want usb connectivity you need to add your current user to the vboxusers group like:

Code: Select all

sudo usermod -aG vboxusers fubar
Restart system to take effekt.


The vboxsf group is for the shared folder, must added into your vm and not your host ,like:

Code: Select all

sudo usermod -aG vboxsf fubar
Restart vm.
AMD Ryzen 7 3700X - 32GB DDR4 - Asus GTX1660TI EVO - SSD SAMSUNG EVO 860 - Mobo Gigabyte AORUS ELITE B550 V2 - PSU Gigabyte 750W Gold - Case Zalman X3 White
LMDE5 / W11
Post Reply

Return to “Virtual Machines”