vboxclient the virtualbox kernel service is not running

Questions about virtualization software
Forum rules
Before you post please read how to get help
catfish12
Level 3
Level 3
Posts: 143
Joined: Sun Dec 01, 2013 8:41 pm

vboxclient the virtualbox kernel service is not running

Postby catfish12 » Wed Nov 25, 2015 2:52 pm

hi i keep getting this message while booting up after latest update vboxclient the virtualbox kernel service is not running never had it before anything to worry about any way to stop it
also if i use time shift back to restore it goes so it from the the update any advice would be great
Last edited by karlchen on Sat Nov 28, 2015 4:08 am, edited 1 time in total.
Reason: Made this thread sticky.

Habitual
Level 13
Level 13
Posts: 4866
Joined: Sun Nov 21, 2010 8:31 pm
Location: 0.0.0.0

Re: vboxclient the virtualbox kernel service is not running

Postby Habitual » Wed Nov 25, 2015 2:58 pm

Output of

Code: Select all

sudo grep -i virtualbox /var/log/boot.log
please.
Image

catfish12
Level 3
Level 3
Posts: 143
Joined: Sun Dec 01, 2013 8:41 pm

Re: vboxclient the virtualbox kernel service is not running

Postby catfish12 » Wed Nov 25, 2015 3:30 pm

Hi Habitual thanks for quick reply
sudo grep -i virtualbox /var/log/boot.log

gives me out put in terminal

VirtualBox Additions disabled, not in a Virtual Machine

thanks :)

User avatar
Flemur
Level 13
Level 13
Posts: 4556
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: vboxclient the virtualbox kernel service is not running

Postby Flemur » Wed Nov 25, 2015 3:39 pm

booting up after latest update


New kernel? Reinstall virtualbox-dkms, possibly virtualbox too.
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

catfish12
Level 3
Level 3
Posts: 143
Joined: Sun Dec 01, 2013 8:41 pm

Re: vboxclient the virtualbox kernel service is not running

Postby catfish12 » Wed Nov 25, 2015 4:08 pm

no new kernels just regular updates 1 2 3 i have change nothing strange this one top right of screen screen shot attached

removed virtualbox-dkms no luck

norm.h
Level 4
Level 4
Posts: 363
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: vboxclient the virtualbox kernel service is not running

Postby norm.h » Wed Nov 25, 2015 4:35 pm

I am having the same issue.
Is there away to remove the recent updates?

catfish12
Level 3
Level 3
Posts: 143
Joined: Sun Dec 01, 2013 8:41 pm

Re: vboxclient the virtualbox kernel service is not running

Postby catfish12 » Wed Nov 25, 2015 4:39 pm

i not alone thought i was going cazy :roll: :D

norm.h
Level 4
Level 4
Posts: 363
Joined: Tue Mar 23, 2010 11:45 am
Location: Oxfordshire, UK

Re: vboxclient the virtualbox kernel service is not running

Postby norm.h » Wed Nov 25, 2015 4:48 pm

I thought I had found the answer, but sadly not.

I looked in Update Manager history and found 3 VM files.
I then did a search in Synaptic for VM, and found the same files, as one would expect.
As they were the only VM files I removed them, did a restart [not a cold reboot] but the message still appears.

Weird or what?

User avatar
Flemur
Level 13
Level 13
Posts: 4556
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: vboxclient the virtualbox kernel service is not running

Postby Flemur » Wed Nov 25, 2015 6:18 pm

removed virtualbox-dkms no luck


Don't remove it, reinstall it. It's the kernel service that's not running (or, at least it enables that service).

Edit: try in terminal:

Code: Select all

virtualbox
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

Paladin2019
Level 2
Level 2
Posts: 60
Joined: Tue Sep 16, 2014 2:31 pm

Re: vboxclient the virtualbox kernel service is not running

Postby Paladin2019 » Wed Nov 25, 2015 6:55 pm

Same problem here.

User avatar
karlchen
Level 17
Level 17
Posts: 7955
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: vboxclient the virtualbox kernel service is not running

Postby karlchen » Wed Nov 25, 2015 7:17 pm

Same popup notification here on Mint 17.2 xfce 32-bit.
The popup notification appeared right after logging into the GUI after the following updates had been installed and the system rebooted:

Code: Select all

Commit Log for Wed Nov 25 23:39:43 2015
Die folgenden Pakete wurden aktualisiert:
virtualbox-guest-dkms (4.3.18-dfsg-1~ubuntu1~trusty1) to 4.3.34-dfsg-1+deb8u1ubuntu1.14.04.1
virtualbox-guest-utils (4.3.18-dfsg-1~ubuntu1~trusty1) to 4.3.34-dfsg-1+deb8u1ubuntu1.14.04.1
virtualbox-guest-x11 (4.3.18-dfsg-1~ubuntu1~trusty1) to 4.3.34-dfsg-1+deb8u1ubuntu1.14.04.1

As this Mint 17.2 is not running inside a virtual machine, I am not sure whether the popup notification indicates a real problem or merely confirms that the virtualbox is not needed.

<Added 29-Nov-2015>

You might like to jump forward directly to
  • the explanation what has changed in virtualbox-guest-x11 that causes the popup notification, which is really just informational and which does not point to any malfunction, > here <.
  • krow7's step by step instruction on how to workaround / solve the problem of the irritating popup notification, > here <.
or simply read on through all of the posts ...
</Added 29-Nov-2015>
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

User avatar
WharfRat
Level 19
Level 19
Posts: 9956
Joined: Thu Apr 07, 2011 8:15 pm

Re: vboxclient the virtualbox kernel service is not running

Postby WharfRat » Wed Nov 25, 2015 9:50 pm

I'm getting the message too. Also this viewtopic.php?f=47&t=210040
Image ImageImage

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3963
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: vboxclient the virtualbox kernel service is not running

Postby Fred Barclay » Wed Nov 25, 2015 10:08 pm

Same here on VBox 5.0.10. :(

Code: Select all

fred@aussie! ~ $ inxi -Fxz
System:    Host: aussie! Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: Cinnamon 2.8.4 (Gtk 3.14.5+4)
           Distro: LinuxMint 2 betsy
Machine:   System: Gateway product: T-1625 v: 90.02
           Mobo: GATEWAY model: N/A v: Rev1.90.02 Bios: Gateway v: 90.02 date: 08/02/2007
CPU:       Dual core AMD Turion 64 X2 Mobile TL-60 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 svm) bmips: 6399
           Clock Speeds: 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS690M [Radeon Xpress 1200/1250/1270] bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x800@60.00hz
           GLX Renderer: Gallium 0.4 on ATI RS690 GLX Version: 2.1 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS690 HDMI Audio [Radeon Xpress 1200 Series]
           driver: snd_hda_intel bus-ID: 01:05.2
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: a000 bus-ID: 08:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Realtek RTL8187B Wireless 802.11g 54Mbps Network Adapter usb-ID: 001-003
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 314.4GB (29.1% used) ID-1: /dev/sda model: Hitachi_HTS54252 size: 250.1GB
           ID-2: USB /dev/sdc model: USB_2.0_FD size: 64.4GB
Partition: ID-1: / size: 133G used: 34G (27%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 5.24GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 55.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 176 Uptime: 8:14 Memory: 1436.4/2574.8MB Init: systemd Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.1.28

Code: Select all

fred@aussie! ~ $ sudo grep -i virtualbox /var/log/boot.log
[sudo] password for fred:
         Starting LSB: VirtualBox Linux X11 Additions...
[  OK  ] Started LSB: VirtualBox Linux X11 Additions.
         Starting LSB: VirtualBox Linux Additions...
         Starting LSB: VirtualBox Linux kernel module...
[  OK  ] Started LSB: VirtualBox Linux Additions.
[  OK  ] Started LSB: VirtualBox Linux kernel module.
         Starting LSB: VirtualBox web service API...
         Starting LSB: VirtualBox autostart service...
         Starting LSB: VirtualBox watchdog daemon...
[  OK  ] Started LSB: VirtualBox web service API.
[  OK  ] Started LSB: VirtualBox autostart service.
[  OK  ] Started LSB: VirtualBox watchdog daemon.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
WharfRat
Level 19
Level 19
Posts: 9956
Joined: Thu Apr 07, 2011 8:15 pm

Re: vboxclient the virtualbox kernel service is not running

Postby WharfRat » Wed Nov 25, 2015 10:23 pm

I just purged virtualbox-guest-x11 virtualbox-guest-utils virtualbox-guest-dkms and that solved the pop-up message.

Do this only if you're running mint natively i.e., not in a virtual box.
Image ImageImage

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3963
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: vboxclient the virtualbox kernel service is not running

Postby Fred Barclay » Wed Nov 25, 2015 10:49 pm

WharfRat wrote:I just purged virtualbox-guest-x11 virtualbox-guest-utils virtualbox-guest-dkms and that solved the pop-up message.

Do this only if you're running mint natively i.e., not in a virtual box.

Did you reinstall afterwards or just purge?
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
WharfRat
Level 19
Level 19
Posts: 9956
Joined: Thu Apr 07, 2011 8:15 pm

Re: vboxclient the virtualbox kernel service is not running

Postby WharfRat » Wed Nov 25, 2015 11:05 pm

Just purge them.

Those apps are meant to be run inside a virtual machine so they are not needed if you're running natively :wink:

Whatever these guys did with vbox and vbox guest appears to have broken things.

My win7 vm crashed upon starting immediately following the upgrade. I purged the latest, installed the older version and placed vbox on hold for now so it's back to normal.
Image ImageImage

catfish12
Level 3
Level 3
Posts: 143
Joined: Sun Dec 01, 2013 8:41 pm

Re: vboxclient the virtualbox kernel service is not running

Postby catfish12 » Thu Nov 26, 2015 3:20 am

Excellent wharfrat i just purged virtualbox-guest-x11 virtualbox-guest-utils virtualbox-guest-dkms

all working good now thanks very much :D :wink:

krow7
Level 3
Level 3
Posts: 102
Joined: Thu Apr 17, 2014 7:08 am

Re: vboxclient the virtualbox kernel service is not running

Postby krow7 » Thu Nov 26, 2015 5:53 am

WharfRat wrote:Just purge them.
Those apps are meant to be run inside a virtual machine so they are not needed if you're running natively :wink:


This solution also worked worked for me. And my vm's are running as usual. Thanks!
The command to uninstall see the command here - viewtopic.php?f=47&t=210020&start=20#p1096534

I always wondered if I need these packages installed to run Virtualbox and was misinformed here - viewtopic.php?f=190&t=188112#p1040372 that these packages should not be removed....
Anyway, thanks again WharfRat!
Last edited by krow7 on Thu Nov 26, 2015 11:27 am, edited 1 time in total.

Cosmo.
Level 22
Level 22
Posts: 15431
Joined: Sat Dec 06, 2014 7:34 am

Re: vboxclient the virtualbox kernel service is not running

Postby Cosmo. » Thu Nov 26, 2015 6:06 am

The strange thing for me in the above reports is the fact, that I do not get the updates for the 3 virtualbox-guest-* packages. I have exactly the version installed, that are shown in the codebox by karlchen as old (4.3.18). Even after doing a refresh I do not get offered an update, in synaptic this version gets shown as installed and as the newest available. I wonder why?

Maybe - the only assumption which comes at now to my mind - the source of the installed VB makes the difference. I take VB (at now 4.3.34) always and only from the downloaded packages from the VB download site.

Interestingly: If I look at the version tab for the properties of the 3 packages in synaptic, 4.3.34 (and 4.3.10) get listed, besides 4.3.18. And no, I do not (and never) have made a setting to force any specific version, so we can exclude this possibility.
But possibly another solution for the affected systems could be to force the version 4.3.18 instead removing the packages. Just a guess, as I obviously cannot test it.

Another idea: Are in the affected any level 5 (kernel-related) updates applied in the past? Here not. Installed is on the host kernel 3.13.0-37.

DarinB
Level 4
Level 4
Posts: 246
Joined: Fri Feb 12, 2010 11:32 am

virtualbox kernel not running service exiting

Postby DarinB » Thu Nov 26, 2015 9:19 am

Hi

I booted up this morning and got this message on my screen after the login before the desktop booted up.

virtualbox kernel not running service exiting

how do I get rid of this? Message

I looked in synaptic and have virtualbox guest added i didn't add this. I don't know what to do. Should I delete that app or will it kill my pc?


Return to “Virtualization”