Win10 1703 will not boot on VirtualBox in Mint

Questions about virtualization software
Forum rules
Before you post please read how to get help
jumptothebase
Level 1
Level 1
Posts: 1
Joined: Fri Apr 21, 2017 10:45 am

Win10 1703 will not boot on VirtualBox in Mint

Postby jumptothebase » Fri Apr 21, 2017 10:49 am

Hello! :)

I cant install Win10_1703 in VirtualBox (Linux Mint 18.1 x64 Cin), previous builds went fine. With 1703 (creators update edition) i only get the MS WIN logo with no circle going round and round, all the VirtualBox settings were the same as with the previous builds.
Note that the same Windows.iso works fine in VirtualBox under Windows.
What seems to be the problem here?

User avatar
Pierre
Level 15
Level 15
Posts: 5856
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby Pierre » Sat Apr 22, 2017 9:34 am

some new change with the way that the World of Windows is working .. ..

I'd the same sort of issue, when win-10 1st came out,
& it took several days to figure out what was going on.

so, you're going to have to be prepared to do the same ,
ie: spent some time on it, if you really wish to get CU to work in a VB.

strangely enough, the VBs that I'd made in 2015, are tricky to get working in a VB,
on this machine & it took a little messing around, to get those backups working again.
- such is the Way that Windows Works
:(
unreliable, at Best.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

altair4
Level 18
Level 18
Posts: 8767
Joined: Tue Feb 03, 2009 10:27 am

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby altair4 » Sat Apr 22, 2017 11:01 am

Just a suggestion but you should post where you got the VBox package and what version you are using. It makes a difference:

The version of VBox in the Min18 repository is: 5.0.36

The current version of VBox from Oracle is: 5.1.20
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Dave B
Level 4
Level 4
Posts: 339
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby Dave B » Sun Apr 23, 2017 3:18 pm

jumptothebase wrote:Note that the same Windows.iso works fine in VirtualBox under Windows.
What seems to be the problem here?

As altair4 hinted, if using an older VirtualBox version, download 5.1.20 direct from Oracle's website (you'll need the Xenal version for your CPU type).
Once installed, if still no go, try booting with 3D acceleration disabled/enabling, make sure 2D acceleration is enabled.

Try copying the (Windows 10).vbox setting file from Windows (host) to Mint (host), this ensures you're using the same VirtualBox settings that work on the Windows host.

Laugh2
Level 3
Level 3
Posts: 155
Joined: Fri Aug 16, 2013 4:01 am

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby Laugh2 » Mon Jul 17, 2017 4:25 am

Maybe the problem is that there are bugs in Windows 10 1703? The following article gives reason to believe 1703 isn't mature enough yet ...
https://www.theregister.co.uk/2017/04/26/stop_downloading_win10_creators_update/
Perhaps we just have to wait a bit?

After Win10-1703 failed to let itself be installed in Virtualbox 5.0.40_Ubuntu-r115130 (from the official repository) I tried Win10-1607, which installed without problem. (LM18.1-64bit MATE is host on this machine.)

Laugh2
Level 3
Level 3
Posts: 155
Joined: Fri Aug 16, 2013 4:01 am

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby Laugh2 » Sat Jul 29, 2017 7:40 pm

After automatically updating (grrrr...) from Win10-1607 to Win10-1703 on Virtualbox Version 5 immediately Win10 wouldn't boot anymore. Since this is on my production machine I played a bit with it.

I already had "3D Acceleration" (under "Display") turned off as it seems to get mixed up sometimes with Firefox on my machine (perhaps because I've forced hardware acceleration?), so all trials here had "3D-Acceleration" turned off.

Paravirtualisation Interface
Playing with the "Paravirtualisation Interface" finally got Win10-1703 working on Virtualbox 5 by selecting "None" with "Enable VT-x/AMD-V". After booting up once it appears the "Paravirtualisation Interface" setting becomes less important. Currently I have it set to "Default" again and Win10 boots in Virtualbox 5 OK.

In the short time since I've had to repeat this procedure once, so it may not be 100% stable. Since it is now working I can't now test this solution for reproducibility. Perhaps this will work for others?

Equipment
    Linux Mint 18.1 Serena, 64bit, MATE
    Gigabyte Technology motherboard with 8MB RAM (Core i5 CPU)
    nVidia Quadro 2000 graphics (integrated GPU disabled)
    Virtualbox Version 5.0.40_Ubuntu r115130
    Win10-1607 updated to Win10-1703

User avatar
Jim Hauser
Level 4
Level 4
Posts: 343
Joined: Mon Jun 30, 2014 10:08 pm
Location: Pascagoula, Mississippi

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby Jim Hauser » Sat Jul 29, 2017 11:04 pm

altair4 wrote:Just a suggestion but you should post where you got the VBox package and what version you are using. It makes a difference:

The version of VBox in the Min18 repository is: 5.0.36

The current version of VBox from Oracle is: 5.1.20


I am running 5.1.22 and have been notified that 5.1.26 is available. The older VB versions had trouble with 4.10 series of kernels on my system but worked well with the 4.4 series (thanks Cosmo!)

PCAdvisorUK
Level 1
Level 1
Posts: 1
Joined: Thu Aug 10, 2017 4:46 pm

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby PCAdvisorUK » Sat Aug 19, 2017 4:07 pm

Just a note, I have managed to get this working using the following config:-

VBox 5.0.40 Ubuntu r115130

stage 1, create VRMachine default settings for win 10. enable efi, disable PAE/NX, set paravirtualization to none..... boot off dvd, install windows 10 1703

stage 2, after windows has installed do the following, if it fails to boot. turn off virtual machine. set paravirtualization to legacy. turn virtual machine on..... and off you go.

this worked for me!!

have fun...

fnerkyboy
Level 1
Level 1
Posts: 1
Joined: Mon Nov 06, 2017 5:47 am

Re: Win10 1703 will not boot on VirtualBox in Mint

Postby fnerkyboy » Mon Nov 06, 2017 5:55 am

Hi Guys.

My Windows 10 VM stopped booting after updating to V 1703.

Host PC is as follows:
Kernel: 4.8.0-53-generic x86_64 (64 bit)
Desktop: Xfce 4.12.3 Distro: Linux Mint 18.2 Sonya


After changing ParaVirtualisation as per PCAdvisorUK, it is now all good.

Thanks Guys :)

fnerkyboy


Return to “Virtualization”

Who is online

Users browsing this forum: No registered users and 3 guests