Citrix Receiver SSL error on Firefox

Questions about virtualization software
Forum rules
Before you post please read how to get help
govindbn
Level 1
Level 1
Posts: 3
Joined: Mon Sep 04, 2017 2:19 am

Citrix Receiver SSL error on Firefox

Postby govindbn » Mon Sep 04, 2017 12:26 pm

Hi all,
I am a Linux newbie seeking assistance from the gurus here.. I use Citrix Receiver to VPN to my office network. I did not have any problems on Win XP. On LM 18.2, I am getting an SSL error. The error description is as follows:
Contact your help desk with the following information: You have not chosen to trust "Symantec Class 3 Secure Server SHA256 SSL CA", the Issuer of the server's security certificate (SSL error 61). I updated Firefox browser to the latest version, but it didn't resolve the error. Any help is greatly appreciated.

SSL error.png

Thanks,
Badri

User avatar
karlchen
Level 18
Level 18
Posts: 8031
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Citrix Receiver SSL error on Firefox

Postby karlchen » Mon Sep 04, 2017 3:42 pm

Hello, Badri.

The problem is not inside Firefox. You have to make the Firefox certificates available to the Citrix receiver as well. The Citrix receiver does not look in the Firefox certificate directory.
The terminal command to make the Citrix Receiver use the Firefox certificates as well is like follows:

Code: Select all

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts/
You will very likely have to restart the Citrix receiver after having executed the commandline.

HTH,
Karl
--
Commandline got from this (German) Ubuntu Wiki article, Citrix ICA Client, and applied successfully on several Ubuntu and Mint systems.
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

govindbn
Level 1
Level 1
Posts: 3
Joined: Mon Sep 04, 2017 2:19 am

Re: Citrix Receiver SSL error on Firefox

Postby govindbn » Thu Sep 07, 2017 5:18 am

Hi Karl,
Thank you for the prompt reply and fix. Now the SSL error is gone. When I click the Citrix desktop icon, a *.ica file is downloaded on my laptop. When I double click the file, a small window pops-up saying "Connecting to Citrix Environment" but then nothing happens. What is the issue here?

Thanks,
Badri

User avatar
karlchen
Level 18
Level 18
Posts: 8031
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Citrix Receiver SSL error on Firefox

Postby karlchen » Thu Sep 07, 2017 11:08 am

Hello, Badri.

Inside your Firefox open the preferences. Go to the applications. Check which action is the default for "Citrix ICA" files.
It used to be some Firefox Citrix plugin.
But here, too, this stopped working round about FF 54.0 finally.
So I changed the application to wfica instead. (/opt/Citrix/ICAClient/wfica here)
Result:
FF will download the ICA file, launch the programme wfica and pass the name of the ICA file to it.
Goal achieved. Citrix session opens. (At least here)

HTH,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

User avatar
karlchen
Level 18
Level 18
Posts: 8031
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Citrix Receiver SSL error on Firefox

Postby karlchen » Tue Sep 12, 2017 6:02 pm

Hello, Badri.
Any update on the second reported issue with the Citrix receiver client?
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.

govindbn
Level 1
Level 1
Posts: 3
Joined: Mon Sep 04, 2017 2:19 am

Re: Citrix Receiver SSL error on Firefox

Postby govindbn » Thu Sep 21, 2017 9:39 am

hi Karl,
Sorry was a bit busy @ work. I tried changing the Firefox preferences but that didn't work. Still the graphical desktop interface wouldn't open. If u can teach me, I can share some log files or settings here so that we can nail down the issue.

Thanks,
Badri

User avatar
karlchen
Level 18
Level 18
Posts: 8031
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Citrix Receiver SSL error on Firefox

Postby karlchen » Thu Sep 21, 2017 12:16 pm

Hello, Badri.

Inside Firefox you click on the hamburger icon, on the preferences icon next.
From the preferences list you select the "applications".

Image
(Click screenshot to enlarge. Press <alt><cursor left> to return here)

There should be a filetype named "Citrix ICA configuration file". Make sure the corresponding action has been set to "Open with Citrix Receiver Engine".
In case this action should not be available from the action drop down menu, then you could also select "Other application ..." from the drop down menu, navigate to the application file /opt/Citrix/ICAClient/wfica and confirm. wfica is the Receiver Engine.

HTH,
Karl
Image
Old bugs good, new bugs bad! Updates are evil: might fix old bugs and introduce no new ones.


Return to “Virtualization”