VMware workstation 12.5.7 and gcc

Questions about virtualization software
Forum rules
Before you post please read how to get help
User avatar
coffee412
Level 5
Level 5
Posts: 685
Joined: Mon Nov 12, 2012 7:38 pm
Location: Indiana, USA
Contact:

VMware workstation 12.5.7 and gcc

Postby coffee412 » Thu Sep 07, 2017 4:23 pm

I have a task to install a small server with a linux host and a windows guest for some 3rd party software that has to run. I first thought of virtualbox as I use that now on my Linux Mint 18.1 64bit system. However, I am looking at Icewarp for a replacement of exchange server and it likes to run on CentOS. Ok, I have several possible options there. But I started looking at VMware.

I downloaded VMware 12.5.7 workstation and its complaining about not finding gcc 7.2.0 or better. I am running a lower version on my system that virtualbox uses. So, I really do not want to mess that up.

Is there a work around?

My first thought of just running virtualbox but I need a DE and CentOS server is strickly terminal based. So, I could run windows and CentOS on top of Mint ?

Should I go thru the pain of manually upgrading gcc?

Your thoughts are welcome here.

coffee
Ryzen x1800 Asus Prime x370-Pro 32 gigs Ram RX480 graphics
IceWarp * Samba AD * Mint 18.1 * RAID 1/5 * OpenVPN * Linux since kernel 2.0.36

deepakdeshp
Level 8
Level 8
Posts: 2371
Joined: Sun Aug 09, 2015 10:00 am

Re: VMware workstation 12.5.7 and gcc

Postby deepakdeshp » Fri Sep 15, 2017 12:07 am

I faced similar problem when I upgraded kernel. Then VMware would not boot and it prompted me to install GCC 6.2. Installed the same but the problem remained.
So I reverted to the old kernel with which VMware worked, and this time it worked without any issues.
The version which works is 4.8.0.37.
You can install the same and boot to it and try VMware with this version.
Good luck
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 18 Cinnamon 64 bit with AMD processor .


Return to “Virtualization”