[solved] purged 5.0, but install of VB 5.1 still hassles me

Questions about virtualization software
Forum rules
Before you post please read how to get help
Jupiter Jones PI
Level 1
Level 1
Posts: 11
Joined: Tue Feb 03, 2015 4:47 pm

[solved] purged 5.0, but install of VB 5.1 still hassles me

Postby Jupiter Jones PI » Sat Oct 14, 2017 9:40 pm

I've been trying to get VirtualBox 5.1 working under Mint 18 KDE, but I'm running into problems. I first installed VB 5.0 something from the Software Manager. With that I was able to install Windows 10 under VB and I installed the Guest Additions. However, I encountered problems. I could not get Windows 10 to go up to full size. It ran in that VB box, but was not re-sizable. I googled around for info and found others having the same problem. It was recommended that I purge VB 5.0 and install the latest version 5.1. Last weekend when I was working on this, I found the VB deb file and attempted to install that. However, the QApt Package Installer refused to install it, saying I had not met all the dependencies, but it would not tell me which dependencies I lacked. So I tried to install with the GDebi Package Installer. That one told me which dependencies I lacked. So I went into the Synaptic Package Manager to look for those packages. However, it said I had them installed. Frustrating. That was last weekend and I did not write down the name of the alleged missing packages. I then re-installed VB from the Software Manager, wondering if I could find an upgrade command to upgrade it from 5.0 to 5.1. No such luck. I found nothing.

So this weekend, I decided to try again. I looked up how to completely purge VB 5.0 from my system before moving on to installing 5.1. This time I was able to find commands for installing it in the terminal on this page:
https://www.linuxbabe.com/virtualbox/in ... untu-16-04

It appeared to install okay and I've saved the code from that:

Code: Select all

thomas@thomas-Inspiron-3650 ~ $ sudo apt update
[sudo] password for thomas:
Hit:1 http://download.virtualbox.org/virtualbox/debian xenial InRelease
Ign:2 http://packages.linuxmint.com serena InRelease                                                                                                                                               
Hit:3 http://archive.canonical.com/ubuntu xenial InRelease                                                                                                                                         
Get:4 https://repo.skype.com/deb stable InRelease [4,487 B]                                                                                     
Hit:5 http://packages.linuxmint.com serena Release                                                                                                                               
Hit:6 http://security.ubuntu.com/ubuntu xenial-security InRelease                                                                               
Hit:7 http://archive.ubuntu.com/ubuntu xenial InRelease                                                                   
Err:4 https://repo.skype.com/deb stable InRelease                                                   
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1F3045A5DF7587C3
Hit:9 http://archive.ubuntu.com/ubuntu xenial-updates InRelease                                     
Hit:10 http://archive.ubuntu.com/ubuntu xenial-backports InRelease                                 
Hit:11 https://deb.opera.com/opera-stable stable InRelease                   
Hit:12 http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial InRelease       
Hit:13 http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu xenial InRelease
Hit:14 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu xenial InRelease 
Hit:15 http://ppa.launchpad.net/vincent-c/cherrytree/ubuntu xenial InRelease   
Hit:16 http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu xenial InRelease
Reading package lists... Done                     
W: GPG error: https://repo.skype.com/deb stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 1F3045A5DF7587C3
E: The repository 'https://repo.skype.com/deb stable InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

And then:

Code: Select all

thomas@thomas-Inspiron-3650 ~ $ sudo apt install virtualbox-5.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done                                                                                                                                                                   
The following packages were automatically installed and are no longer required:                                                                                                                     
  libgsoap8 libvncserver1 virtualbox-dkms                                                                                                                                                           
Use 'sudo apt autoremove' to remove them.                                                                                                                                                           
The following NEW packages will be installed:                                                                                                                                                       
  virtualbox-5.1                                                                                                                                                                                     
0 upgraded, 1 newly installed, 0 to remove and 808 not upgraded.                                                                                                                                     
Need to get 65.9 MB of archives.                                                                                                                                                                     
After this operation, 163 MB of additional disk space will be used.                                                                                                                                 
Get:1 http://download.virtualbox.org/virtualbox/debian xenial/contrib amd64 virtualbox-5.1 amd64 5.1.28-117968~Ubuntu~xenial [65.9 MB]                                                               
Fetched 65.9 MB in 8s (8,081 kB/s)                                                                                                                                                                   
Preconfiguring packages ...                                                                                                                                                                         
Selecting previously unselected package virtualbox-5.1.                                                                                                                                             
(Reading database ... 228928 files and directories currently installed.)                                                                                                                             
Preparing to unpack .../virtualbox-5.1_5.1.28-117968~Ubuntu~xenial_amd64.deb ...                                                                                                                     
Unpacking virtualbox-5.1 (5.1.28-117968~Ubuntu~xenial) ...                                                                                                                                           
Processing triggers for systemd (229-4ubuntu12) ...                                                                                                                                                 
Processing triggers for ureadahead (0.100.0-19) ...                                                                                                                                                 
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...                                                                                                                                       
Processing triggers for shared-mime-info (1.5-2ubuntu0.1) ...                                                                                                                                       
Unknown media type in type 'all/all'                                                                                                                                                                 
Unknown media type in type 'all/allfiles'                                                                                                                                                           
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Setting up virtualbox-5.1 (5.1.28-117968~Ubuntu~xenial) ...
Adding group `vboxusers' (GID 133) ...
Done.


To my delight, it appeared to install. I was then able to go through VB's settings for how I wanted Windows 10 set up and chosing my ISO file for it. However, then I ran into hassles. When I attempted to run the Windows 10 install, I got these error messages:

Image

Image

I've been trying for weeks to get this to run. I had purged the install of the old version of VB by running the uninstall including “purge” and then going in and manually deleting the leftover directories. It should have gotten rid of everything to allow for the install of 5.1. However, it's just not working. I've been trying for weeks to get it to work and I'm extremely frustrated. I've googled and googled and now it's time to reach out for help. Any help would be appreciated. I only need to run one Windows program, Dramatica, which runs under WINE, but extremely poorly. Everything else I'm able to either run natively under Linux or it runs well under WINE. Dramatica is horribly buggy under WINE so I need to get VirtualBox running so I can finally make it work.

I appreciate any help. Thanks.
Last edited by Jupiter Jones PI on Sun Oct 15, 2017 12:41 pm, edited 1 time in total.

User avatar
catweazel
Level 10
Level 10
Posts: 3461
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: purged 5.0, but install of VB 5.1 still hassles me

Postby catweazel » Sun Oct 15, 2017 3:08 am

Did you take the advice in the error message to execute vboxconfig?
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

User avatar
minitux
Level 5
Level 5
Posts: 677
Joined: Tue Sep 12, 2017 10:05 am

Re: purged 5.0, but install of VB 5.1 still hassles me

Postby minitux » Sun Oct 15, 2017 4:17 am

I'm not a VBOX user, I just tried VBOX in the past, while expecting some VBOX expert, you can try to see if there are missing kernel headers

Code: Select all

sudo apt-get install linux-headers-$(uname -r)


and then use this command ( as root) to suggest the error screen and try to start VBOX

Code: Select all

sudo /sbin/vboxconfig
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

Jupiter Jones PI
Level 1
Level 1
Posts: 11
Joined: Tue Feb 03, 2015 4:47 pm

Re: purged 5.0, but install of VB 5.1 still hassles me

Postby Jupiter Jones PI » Sun Oct 15, 2017 12:40 pm

catweazel wrote:Did you take the advice in the error message to execute vboxconfig?


Yes, yesterday I ran "sudo /sbin/vboxconfig" to no avail. The problem still persisted.

minitux wrote:I'm not a VBOX user, I just tried VBOX in the past, while expecting some VBOX expert, you can try to see if there are missing kernel headers

Code: Select all

sudo apt-get install linux-headers-$(uname -r)


and then use this command ( as root) to suggest the error screen and try to start VBOX

Code: Select all

sudo /sbin/vboxconfig


I did that today. At first it did not help, but then it suggested that I remove something called "DKMS". I did so. It then said I could either install the guest additions or disable USB. I disabled USB and Windows 10 installed. I'll install guest additions later and then re-enabled USB.

So, we're working. Thanks to all for your help. I very much appreciate all the help. I'm going to mark this thread solved.

User avatar
catweazel
Level 10
Level 10
Posts: 3461
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: purged 5.0, but install of VB 5.1 still hassles me

Postby catweazel » Mon Oct 16, 2017 12:35 am

Jupiter Jones PI wrote:...it suggested that I remove something called "DKMS". I did so...

You'll be back shortly when you find you can't update your kernel or install certain software.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.


Return to “Virtualization”