Linux mint 18.3 crash with VMware workstation 14 [Solved]

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
happnatious1
Level 1
Level 1
Posts: 16
Joined: Fri Nov 03, 2017 8:58 am
Location: Earth
Contact:

Linux mint 18.3 crash with VMware workstation 14 [Solved]

Post by happnatious1 » Thu Dec 14, 2017 10:21 pm

This is a new build originally Mint 18.2 then upgraded to 18.3. Running windoze 7 in a Virtual machine. Linux mint will hard freeze if left alone with a virtual machine running. All sleep on everything is turned off. Came back from dinner around 20:20 and could still see the display, clock on mint and windoze both frozen at 19:21. Had to hold power button to reboot. Any ideas what might be going on? It's a new purchase of vmware workstation so I get 30 days support. Of course the first thing they say is it's not supported on Linux Mint.

from syslog with message about corrupt characters:

Dec 14 18:42:50 bill-ryzen7 smartd[1101]: Device: /dev/sdb [SAT], SMART Usage Attribute: 194 Temperature_Celsius changed from 115 to 116
Dec 14 19:12:49 bill-ryzen7 smartd[1101]: Device: /dev/sda [SAT], SMART Usage Attribute: 190 Airflow_Temperature_Cel changed from 72 to 73
Dec 14 19:17:01 bill-ryzen7 CRON[5686]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
Dec 14 19:27:05 bill-ryzen7 ntpd[2552]: 66.85.74.226 local addr 192.168.42.20 -> <null>
\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00\00Dec 14 20:31:51 bill-ryzen7 rsyslogd: [origin software="rsyslogd" swVersion="8.16.0" x-pid="1120" x-info="http://www.rsyslog.com"] start
Dec 14 20:31:51 bill-ryzen7 systemd-modules-load[491]: Inserted module 'lp'
Dec 14 20:31:51 bill-ryzen7 rsyslogd-2222: command 'KLogPermitNonKernelFacility' is currently not permitted - did you already set it via a RainerScript command (v6+ config)? [v8.16.0 try http://www.rsyslog.com/e/2222 ]

Output of inxi -Fxz:

System: Host: bill-ryzen7 Kernel: 4.10.0-40-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: Mobo: ASRock model: AB350M Pro4
Bios: American Megatrends v: P4.10 date: 11/27/2017
CPU: Octa core AMD Ryzen 7 1700 Eight-Core (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 47905
clock speeds: max: 3000 MHz 1: 1550 MHz 2: 1550 MHz 3: 1550 MHz
4: 1550 MHz 5: 1550 MHz 6: 1550 MHz 7: 1550 MHz 8: 1550 MHz
9: 1550 MHz 10: 1550 MHz 11: 1550 MHz 12: 1550 MHz 13: 1550 MHz
14: 1550 MHz 15: 1550 MHz 16: 1550 MHz
Graphics: Card: NVIDIA Device 1d01 bus-ID: 09:00.0
Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
Resolution: 1920x1080@60.00hz
GLX Renderer: GeForce GT 1030/PCIe/SSE2
GLX Version: 4.5.0 NVIDIA 384.90 Direct Rendering: Yes
Audio: Card-1 NVIDIA Device 0fb8 driver: snd_hda_intel bus-ID: 09:00.1
Card-2 Advanced Micro Devices [AMD] Device 1457
driver: snd_hda_intel bus-ID: 12:00.3
Card-3 Logitech QuickCam Pro 9000 driver: USB Audio usb-ID: 003-006
Sound: Advanced Linux Sound Architecture v: k4.10.0-40-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 v: 2.3LK-NAPI port: f000 bus-ID: 06:00.0
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 2120.4GB (13.1% used)
ID-1: /dev/nvme0n1 model: N/A size: 500.1GB
ID-2: /dev/sda model: Samsung_SSD_840 size: 120.0GB
ID-3: /dev/sdb model: WDC_WD2002FYPS size: 2000.4GB
Partition: ID-1: / size: 443G used: 58G (14%) fs: ext4 dev: /dev/nvme0n1p2
ID-2: swap-1 size: 17.11GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p3
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 335 Uptime: 12 min Memory: 1761.9/16041.7MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by happnatious1 on Wed Dec 20, 2017 10:40 am, edited 1 time in total.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Linux mint 18.3 crash with VMware workstation 14

Post by ClixTrix » Fri Dec 15, 2017 8:24 am

That is most likely the Ryzen freeze problem reported. See my sig for my build. There is a lot of discussion on cause and trial and error fixes. I recommend you read these threads.

https://bugs.launchpad.net/ubuntu/+sour ... ug/1690085

https://bugzilla.kernel.org/show_bug.cgi?id=196683

The fix that's working for me is adding rcu_nocbs=0-xx, where xx is equal to the number of processor threads minus one to the Grub boot parms, like adding NOMODESET. For your eight cores - 16 threads the syntax is ---

rcu_nocbs=0-15

I haven't had a single freeze for past several months since this patch. Disable C6 in BIOS (in my case Global C-state Control) also worked for me. If you note the AMD push-back on "Haswell Ready" PSU requirement, I have a 500W Thermaltake that meets the requirement. I do agree with that requirement as needed for C6, but it doesn't seem to make a difference to this bug.

FYI.....I run VirtualBox for my work.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Linux mint 18.3 crash with VMware workstation 14

Post by ClixTrix » Fri Dec 15, 2017 3:46 pm

I should add that I had several idle lockups during September and October running Mint only before applying the fix.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

User avatar
happnatious1
Level 1
Level 1
Posts: 16
Joined: Fri Nov 03, 2017 8:58 am
Location: Earth
Contact:

Re: Linux mint 18.3 crash with VMware workstation 14

Post by happnatious1 » Sat Dec 16, 2017 8:48 am

Thank you for your response Clixtrix,

Tons of great information here. After reading through a lot of it, it seems like there are three things that can help mitigate this problem.

1. disable C6 CPU state in BIOS which apparently puts cores to sleep when not being used. This one make a lot of sense to me as a CPU going to sleep with either the host or VM using it could cause a lockup.

2 . disable ASLR which randomizes memory locations. Again makes sense to me, if the host or a VM has memory moved it could cause a lockup.

3. rcu_nocbs=0-15 which turns off Ready_Copy_Update on all CPU's. This one is more difficult for me to understand. I can see where this could be a problem if the kernel cues a RCU on a sleeping CPU, but it seems to me if all CPU's are awake and the system is essentially idle there should be plenty of resources to handle interrupts.

Anyways, following my gut (which is often wrong) last night I went into bios and disabled C6 states and then following the advice on this site "http://blog.programster.org/how-to-disable-aslr" I disabled aslr. I let the computer run overnight and this morning it was still alive!

I'm not going to declare it solved but I would like to offer you a huge thank you for putting me on the right track. :D :D :D

User avatar
happnatious1
Level 1
Level 1
Posts: 16
Joined: Fri Nov 03, 2017 8:58 am
Location: Earth
Contact:

Re: Linux mint 18.3 crash with VMware workstation 14

Post by happnatious1 » Wed Dec 20, 2017 10:35 am

I ran Linux Mint with a Windoze 7 Vm running for about 4 days and had no issues. Last night I set Global C states in my system Bios to auto and this morning the PC was locked up. So for me disabling C states is a must for a stable system.

User avatar
ClixTrix
Level 5
Level 5
Posts: 747
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Linux mint 18.3 crash with VMware workstation 14 [Solved]

Post by ClixTrix » Thu Dec 21, 2017 10:30 am

It appears you are about where I was in testing back in late October.

This commit to Kernel change in June was what got me looking at RCU and why I think this is a latent bug problem on Ryzen:

https://git.kernel.org/pub/scm/linux/ke ... 0602c25764

The RCU_NOCBS override restores what was removed from the affected kernels.

Now, that isn't to suggest there aren't other reasons for freezes, which might include some of the other posted workarounds, e.g. ASLR. Some freezes might have more to do with memory stability problems in overclock or compatibility. The latest AGESA 1.0.7.2a (I haven't updated BIOS to latest as I'm stable) is pro-ported to included more memory compatibility fixes. I'm pretty conservative on my build (see sig) and haven't overclocked (yet), which may be avoiding some of those other problems. :roll:

The next change I'll make is to the 4.14 Kernel to obtain Ryzen Turbo support. Waiting for that Kernel to get to better patch level. Hopefully, early next month and ahead of it moving to Ubuntu 16.04.4 LTS in February.
Linux Mint 18.3 x64 Cinnamon Kernel 4.15.0-39-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / XFX HD5450-1GB
NVMe-SSD Samsung 960 EVO 250GB / SATA-HDD WD1600BEKT 160GB / SATA-SSD Toshiba OCZ VX500 512GB

Post Reply

Return to “Virtualization”