Virtualbox - no audio - selection greyed out.

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
User avatar
Flemur
Level 15
Level 15
Posts: 5794
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Virtualbox - no audio - selection greyed out.

Post by Flemur » Sun Dec 17, 2017 12:40 pm

Mint 18.3 Xfce host, win7 as a virtualbox guest. I've removed pulseaudio (as always).

I can't set the audio in virtualbox because the GUI is greyed-out; the "Intel HD Audio" listed (but grey) is the wrong device (built-in audio which is disabled in BIOS - ?), it should be an old SoundBlaster.

Everything worked fine in Mint 18.2 (also w/o pulse). Audio works fine in Mint and also in wine applications.

virtualbox Version 5.1.20 r114628 (Qt5.5.1)
I tried the newer version from Oracle (5.2.?) , it wouldn't start with my saved Win7 "guest", complaining about "HDA" (audio).

I get no error messages running from a terminal.

Code: Select all

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Live [SB Live! 5.1], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
  Subdevices: 32/32
....

Code: Select all

$ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    PulseAudio Sound Server
default:CARD=Live
    SB Live! 5.1, ADC Capture/Standard PCM Playback
    Default Audio Device
...
Edit:
When trying to create a new "machine" I get

Code: Select all

No audio devices could be opened. Selecting the NULL audio backend with the consequence that no sound is audible.
Error ID: HostAudioNotResponding
Severity: Warning
although the "Audio" GUI is NOT greyed out and I can select "SoundBlaster 16" on it.

Picture is from trying to start existing machine, not create new one ...
Attachments
vbox_audio.jpg
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Post Reply

Return to “Virtualization”