Kernel 4.4.0-109 and virtualbox fails

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
berni123
Level 1
Level 1
Posts: 5
Joined: Sat Jan 16, 2016 6:01 am

Kernel 4.4.0-109 and virtualbox fails

Post by berni123 » Fri Jan 12, 2018 12:24 pm

Dist-Upgrading to new upstream kernel 4.4.0-109 on Mint 17.3 fails

1. Cinnamon enters software rendering

2. Virutal-Box dkms fails:

Code: Select all

run-parts: executing /etc/kernel/header_postinst.d/dkms 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
Error! Bad return status for module build on kernel: 4.4.0-109-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.4/build/make.log for more information.

DKMS make.log for virtualbox-5.0.4 for kernel 4.4.0-109-generic (x86_64)
Fr 12. Jan 17:20:51 CET 2018
make: Verzeichnis »/usr/src/linux-headers-4.4.0-109-generic« wird betreten
  LD      /var/lib/dkms/virtualbox/5.0.4/build/built-in.o
  LD      /var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/built-in.o
  CC [M]  /var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/linux/SUPDrv-linux.o
/var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/linux/SUPDrv-linux.c: In function ‘VBoxDrvLinuxUnload’:
/var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/linux/SUPDrv-linux.c:488:8: error: void value not ignored as it ought to be
     rc = misc_deregister(&gMiscDeviceUsr);
        ^
/var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/linux/SUPDrv-linux.c:493:8: error: void value not ignored as it ought to be
     rc = misc_deregister(&gMiscDeviceSys);
        ^
make[2]: *** [/var/lib/dkms/virtualbox/5.0.4/build/vboxdrv/linux/SUPDrv-linux.o] Fehler 1
make[1]: *** [/var/lib/dkms/virtualbox/5.0.4/build/vboxdrv] Fehler 2
make: *** [_module_/var/lib/dkms/virtualbox/5.0.4/build] Fehler 2
make: Verzeichnis »/usr/src/linux-headers-4.4.0-109-generic« wird verlassen
Upstream kernel 4.4.0-109 is still a bad choice.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Kernel 4.4.0-109 and virutalbox fails

Post by Cosmo. » Fri Jan 12, 2018 4:31 pm

VB 5.0.4 has problems with Linux kernel 4.3 and above. Old trouble is, that this museum piece still gets offered in the official repository. The problems have been fixed by Oracle since a long time, so the solution is to uninstall VB 5.0.4, go to the VirtualBox website and download the latest variant of either 5.1.x (preferable for stability) or 5.0.2.

User avatar
AndyMH
Level 5
Level 5
Posts: 749
Joined: Fri Mar 04, 2016 5:23 pm
Location: Wiltshire

Re: Kernel 4.4.0-109 and virutalbox fails

Post by AndyMH » Fri Jan 12, 2018 5:27 pm

I upgraded the kernel today to 4.4.0.109 and VB 5.0.40 (version in the repository) works fine with it. This version of VB will NOT work with kernel 4.13 - tried and failed, VB locks up. Also found that the later versions of VB 5.2.2+ would work with kernel 4.4.0.53 (what I had before I started) but would NOT work properly in seamless mode. Haven't tried the later VBs with 4.13.

Running 18.3 cinnamon on a thinkpad T430.
Homebrew i5-8400+GTX1080 Cinnamon 19, Thinkpad T430 i7-3632 Cinnamon 19, Thinkpad T420 Cinnamon 18.3, Thinkpad T410 Cinnamon 17.3, Thinkpad T60 19.0 Mate

Post Reply

Return to “Virtualization”