[SOLVED] How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
mintyfreshuser
Level 2
Level 2
Posts: 83
Joined: Sat Dec 30, 2017 10:14 pm

[SOLVED] How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by mintyfreshuser » Tue Feb 06, 2018 10:21 am

Hi.

I'm trying to run the package installer for a newer version of VirtualBox but I've run into the following error message:

"Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

I believe there may be remnants of the previous version of VirtualBox on my computer that are preventing the newer version of VirtualBox from installing.

If this is what this error message means, how do I remove the remnants of the older version of VirtualBox so that I can then run the package installer without issue? For instance, is there a way to do it using the terminal?

I'm a bit cautious about deleting the wrong thing because I did that once and I had to reinstall Linux Mint.

Thank you.

P.S. I'm using Linux 18.3 Sylvia with Cinnamon 3.6.6 desktop environment if that helps.
Last edited by mintyfreshuser on Sun Feb 11, 2018 9:38 am, edited 1 time in total.

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by Dave B » Tue Feb 06, 2018 12:05 pm

Hi,

You can use...

Code: Select all

apt purge virtualbox*
This should remove an older version of VirtualBox plus its configuration files.

Then try the installation again.
If still experience issues, check to make sure the Xenial version of the .deb file was downloaded from https://www.virtualbox.org

User avatar
thx-1138
Level 5
Level 5
Posts: 952
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by thx-1138 » Tue Feb 06, 2018 12:20 pm

Open Synaptic. Search for anything with VirtualBox and also Vbox, remove them...
You should be able to install the newer Virtualbox properly afterwards.

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by Dave B » Tue Feb 06, 2018 12:30 pm

Hi thx-1138,

Previously supplied purge command should perform that action without having to manually search.

User avatar
thx-1138
Level 5
Level 5
Posts: 952
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by thx-1138 » Tue Feb 06, 2018 12:45 pm

Hi Dave, yes, but it was missing sudo (and if the op had older versions, he/she hasn't said, then the packages could be called vbox* instead...)
For instance, is there a way to do it using the terminal?
...so the 100% certain terminal way, regardless of what the op has previously installed or not installed, sudo apt-get purge virtualbox* vbox*...

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by Dave B » Tue Feb 06, 2018 12:55 pm

Ah, with Mint apt is self elevating for many basic commands. Supplied command automatically asks for user password. This saves typing, as well as making commands easier to remember. :)

So the command can be shortened to...
apt purge virtualbox* vbox*

Prefer apt to apt-get, with apt the user has a nice progress bar.

mintyfreshuser
Level 2
Level 2
Posts: 83
Joined: Sat Dec 30, 2017 10:14 pm

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by mintyfreshuser » Tue Feb 06, 2018 6:07 pm

Update: I uninstalled the VirtualBox package that was causing the error by uninstalling it within the Synaptic program. I tried uninstalling it using the terminal, but I must not have entered the right information because it didn't seem to work for me.

I installed the new VirtualBox package without any more complications plus the virtualized version of Windows 10 that had I wanted to install (also without any complications).

Thanks everyone for your help in solving this problem!

Dave B
Level 4
Level 4
Posts: 392
Joined: Thu Jan 08, 2015 10:49 pm
Location: UK

Re: How do I solve this error? "Error: Breaks existing package 'virtualbox' conflict: virtualbox-5.1 ( )"

Post by Dave B » Thu Feb 08, 2018 2:05 pm

Great! :)

Please edit the original thread title adding <SOLVED> to the beginning. Thank you.

Post Reply

Return to “Virtualization”