Error while installing Virtualbox 5.2 on my machine

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
vignesanm
Level 1
Level 1
Posts: 3
Joined: Sat Mar 17, 2018 7:33 am

Error while installing Virtualbox 5.2 on my machine

Post by vignesanm » Sat Mar 17, 2018 8:13 am

Dear Team,
I try to download and install virtualbox-5.2_5.2.8-121009_Ubuntu_zesty_amd64.deb on my PC but following error will show on my screen while i installed the packages. kindly get some solution for that. i am beginner for this linux platform. kindly guide me how to install without error in feature ...... the following screen short for your reference.....
Attachments
Error Virtualbox 5.2.jpeg

JeremyB
Level 18
Level 18
Posts: 8672
Joined: Fri Feb 21, 2014 8:17 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by JeremyB » Sat Mar 17, 2018 8:16 am

Why not install virtualbox from Software Manager or Synaptic? It should solve the dependency issues

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by Cosmo. » Sat Mar 17, 2018 8:25 am

What is your version of Mint and what is the desktop environment? Which kernel and which architecture? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.

You need to give this information for every help request in every thread.
Do not forget this in the future.
vignesanm wrote:
Sat Mar 17, 2018 8:13 am
I try to download and install virtualbox-5.2_5.2.8-121009_Ubuntu_zesty_amd64.deb
This is definitely the wrong version. No Mint version is based on Ubuntu zesty. What you really need depends from your unknown system; the output of my command will clear this up.
JeremyB wrote:Why not install virtualbox from Software Manager or Synaptic? It should solve the dependency issues
... and possibly create new ones. Let us assume, that the OP uses the latest Mint with kernel 4.13 a freeze is guaranteed. So not the way to go (at least not without knowing the basic system specs).

User avatar
kc1di
Level 13
Level 13
Posts: 4519
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Error while installing Virtualbox 5.2 on my machine

Post by kc1di » Sat Mar 17, 2018 8:26 am

do what JeremyB said.
the file you downloaded was for ubuntu 17.04 zesty - Mint 18.x is based on 16.04 series of ubuntu and that's why your running into dependency problems.
Mint follows ubuntu LTS releases , Mint 19 will be based on Ubuntu 18.04.
if for some reason you must have VB 5.2 then this page may be of help.
https://tecadmin.net/install-oracle-vir ... on-ubuntu/
Last edited by kc1di on Sat Mar 17, 2018 8:31 am, edited 2 times in total.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by Cosmo. » Sat Mar 17, 2018 8:27 am

kc1di wrote:
Sat Mar 17, 2018 8:26 am
do what JeremyB said.
Out of the already given reason: Definitely no.

User avatar
catweazel
Level 15
Level 15
Posts: 5917
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Error while installing Virtualbox 5.2 on my machine

Post by catweazel » Sat Mar 17, 2018 8:30 am

JeremyB wrote:
Sat Mar 17, 2018 8:16 am
Why not install virtualbox from Software Manager or Synaptic? It should solve the dependency issues
That's not recommended. The version is old and doesn't work correctly AFAIK.

Cheers.
A new scientific truth does not triumph by convincing its opponents and making them see the light, but rather because its opponents eventually die, and a new generation grows up that is familiar with it. - Max Planck

JeremyB
Level 18
Level 18
Posts: 8672
Joined: Fri Feb 21, 2014 8:17 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by JeremyB » Sat Mar 17, 2018 8:41 am

I can see there might be issues with virtualbox-guest-dkms with any kernel higher than 4.4, but they would just need the vitualbox-guest-dkms-hwe for it to work in anything from 4.4 to 4.13

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by Cosmo. » Sat Mar 17, 2018 10:38 am

Jeremy, what the OP downloaded is simply the wrong file. It is as wrong as if he would have downloaded the version for Windows or Mac. There is no need to make it more complicated: Taking the right file is all, what he needs to do.

vignesanm
Level 1
Level 1
Posts: 3
Joined: Sat Mar 17, 2018 7:33 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by vignesanm » Sat Mar 17, 2018 11:40 am

Cosmo. wrote:
Sat Mar 17, 2018 8:25 am
What is your version of Mint and what is the desktop environment? Which kernel and which architecture? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Kernel: 4.10.0-38-generic x86_64 (64 bit)
Desktop: Cinnamon 3.6.7
Distro: Linux Mint 18.3 Sylvia

kc1di wrote:
Sat Mar 17, 2018 8:26 am
do what JeremyB said.
the file you downloaded was for ubuntu 17.04 zesty - Mint 18.x is based on 16.04 series of ubuntu and that's why your running into dependency problems.
Mint follows ubuntu LTS releases , Mint 19 will be based on Ubuntu 18.04.
if for some reason you must have VB 5.2 then this page may be of help.
https://tecadmin.net/install-oracle-vir ... on-ubuntu/
i try this one and now working fine..... thank you for your support.........

User avatar
kc1di
Level 13
Level 13
Posts: 4519
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Error while installing Virtualbox 5.2 on my machine

Post by kc1di » Sat Mar 17, 2018 12:10 pm

your Welcome , enjoy :)
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Cosmo.
Level 23
Level 23
Posts: 17830
Joined: Sat Dec 06, 2014 7:34 am

Re: Error while installing Virtualbox 5.2 on my machine

Post by Cosmo. » Sat Mar 17, 2018 3:44 pm

The used kernel is since some time no longer supported. This means, your system is vulnerable. Bad choice.

Post Reply

Return to “Virtualization”