<SOLVED> Vagrant won't ssh into XenServer over VirtualBox

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
piovezan
Level 1
Level 1
Posts: 9
Joined: Sun Apr 29, 2018 11:11 am

<SOLVED> Vagrant won't ssh into XenServer over VirtualBox

Post by piovezan » Sun Apr 29, 2018 4:31 pm

I'm trying to run XenServer on top of VirtualBox as instructed here: https://xenserver.org/blog/entry/runnin ... erver.html.

Linux Mint 18.3 64-bit with upgraded kernel 4.13.0-39-generic
VirtualBox 5.2.10
Vagrant 2.0.4

When I run "vagrant up" it reports the following message:

Code: Select all

rodrigo@piomint ~/XenServer $ vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
==> default: Importing base box 'xenserver/dundee-beta'...
==> default: Matching MAC address for NAT networking...
==> default: Checking if box 'xenserver/dundee-beta' is up to date...
==> default: Setting the name of the VM: XenServer_default_1525032216015_29510
==> default: Clearing any previously set network interfaces...
==> default: Available bridged network interfaces:
1) enp1s0
2) enp3s0
==> default: When choosing an interface, it is usually the one that is
==> default: being used to connect to the internet.
    default: Which interface should the network bridge to? enp1s0
    default: Which interface should the network bridge to? 1
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
    default: Adapter 2: bridged
    default: Adapter 3: hostonly
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key
Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.
It seems to be an attempt to ssh into the virtual machine but contrary to what the message says there is no error being reported that might provide a clue to what the problem is. The message appears after a timeout.

Before that I have to choose the bridged network interface. I have two and one of them is disconnected but the error occurs regardless of which one I choose (1 or 2).

What could be the reason for that?

EDIT: I have a clue. I've checked VirtualBox and the 64-bit VM seems to be halted due to lack of virtualization technology to detect it. I tried to enable it in the BIOS but couldn't find a proper setting. The motherboard is an Asus P5KPL-CM and the processor is an Intel Core 2 Duo E7400. I found a mention to "enable Vanderpool technology" but could not find the setting in Advanced > CPU. The mobo may not have support for it.

EDIT 2: Upgrading the BIOS didn't make the option appear. The mobo manual says the option exists, though.

EDIT 3: Dang! Some E7400 processor models don't support Vt-x. Time for a CPU upgrade...

Post Reply

Return to “Virtualization”