Can't load Debian with VBox in UEFI boot mode

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
jfatal
Level 1
Level 1
Posts: 1
Joined: Fri Jun 01, 2018 12:12 pm

Can't load Debian with VBox in UEFI boot mode

Post by jfatal » Fri Jun 01, 2018 12:43 pm

Hey what's up guys. This is my first post and I'm new to the forum, but I hope I don't get the 100% noob treatment lol. Looking for some help here.

I am running Linux Mint 18.1 Sylvia, on a 2005 Mac Mini, this particular model is UEFI , so I do understand that it boots differently, and if there is no .efi file, then there's no boot. Am I right?

I'm looking to boot Debian from Virtualbox, but once I selected UEFI mode in VBox it brings me to a shell menu. I would like to avoid this process altogether but the program I'm looking to work with only has a build for Debian at the moment.

How do I go about either:

A: adding the .efi log to /efibootmgr so that way VBox can boot Debian properly
B: re-installing grub so that way it can boot (one of the options I've read online)
C: implementing some other method of booting Debian

I have read multiple forum threads online, but the majority of them talk about VirtualBox on Ubuntu 14. I was going to try out the ubuntu fix and see if it would work for Linux Mint, but I figured I would ask for some help here.

Please excuse my lack of knowledge, I just installed Mint on this machine maybe 2 weeks ago, I am still learning the ropes, so please forgive me if this is a total noob question lol

If anyone knows how to make Virtualbox EFI boot any Windows versions, this would help as well.

Any help on this would be greatly appreciated.

User avatar
xenopeek
Level 24
Level 24
Posts: 23099
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Can't load Debian with VBox in UEFI boot mode

Post by xenopeek » Fri Jun 01, 2018 12:59 pm

Moved here and updated the topic title.

Perhaps ask on the VirtualBox forums as they will know VirtualBox best: https://forums.virtualbox.org/

Something similar on the Debian forums, where user ended just doing a dual boot install and abandoning the virtual machine idea: http://forums.debian.net/viewtopic.php?f=17&t=134965
Image

User avatar
pbear
Level 5
Level 5
Posts: 596
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Can't load Debian with VBox in UEFI boot mode

Post by pbear » Fri Jun 01, 2018 11:35 pm

jfatal wrote:
Fri Jun 01, 2018 12:43 pm
I am running Linux Mint 18.1 Sylvia, on a 2005 Mac Mini, this particular model is UEFI , so I do understand that it boots differently, and if there is no .efi file, then there's no boot. Am I right?
Actually, I think you are not. I have VBox installed on a UEFI machine (running Win10). My Linux Mint virtual machines nonetheless install and run in BIOS mode. You can test what yours is doing by running the following command in Terminal (inside the VM):-

Code: Select all

[ -d /sys/firmware/efi ] && echo "Currently in UEFI mode" || echo "Currently in Legacy mode"
Per § 3.14 of the VBox Manual, there's experimental support for virtual EFI firmware, but I've never tried it. Default is BIOS.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Post Reply

Return to “Virtualization”