How to fix VMware 14 player/workstation startup / memory issue

Questions about virtualization software
Forum rules
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 7
Joined: Fri Jun 15, 2018 5:00 am

How to fix VMware 14 player/workstation startup / memory issue

Post by Altersoundwork » Fri Jun 22, 2018 6:35 am

Hi all,

Just thought I'd share a fix with those of you who use VMWare Workstation or Player (version 14.x)

After installation (this happens to me on both mint 18.3 and 19) and running it for the first time, you'll get the following message:

"Before you can run VMware, several modules must be compiled and loaded into the running kernel."

After you click ok, "Virtual machine monitor" will faill followed by an "Unable to start services" warning and the whole process essentially in a loop.

If you don't get this message you may also have an issue when running a VM for the first time (be it new or loaded) with the message:

"The virtual machine is unable to reserve memory"

Either or both error can be fixed with the following commands:
cd /tmp
git clone
cd vmware-host-modules
git checkout workstation-14.0.0
tar cf vmmon.tar vmmon-only
sudo cp vmmon.tar /usr/lib/vmware/modules/source
sudo vmware-modconfig --console --install-all
The issue is due to VMWare 14 not having been patched yet for the most recent kernels so credit goes to "Michal Kubeček" for creating said patches and "scrapebyitguy" where I found these commands.

Hope this helps anyone searching for these 2 issues :)

Level 12
Level 12
Posts: 4335
Joined: Sun Aug 09, 2015 10:00 am

Re: How to fix VMware 14 player/workstation startup / memory issue

Post by deepakdeshp » Sun Jun 24, 2018 11:32 am

In my case VMware gave the same error and indicated gcc-7 to be installed. I installed gcc-7 with a lot of effort and the problem was solved.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19.1 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Virtualization”